Table of Contents

iMail Technical

iMail 6.99 03.17.22:

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Issue

ESNDDBF command when sending file as .CSV, the file gets sent, but it's empty, only has the column headers, but no data.

Cause

When using the ESNDDBF or ESNDDBF commands (or their variants) with a User Profile that does not have a password (*NONE for the password), the job gets a Java exception. This worked with iDocs 6.86, but not with iDocs 6.99.

Fix

6.99 6.26.2022
When using ESNDSPLF to convert a spool file to *XLS or *XLSX; or when using ESNDDBF to convert a database file to *CSV, *XLS, or *XLSX the iMail program will be called.

The iMail program will check the newly created DSUSEJDBC data area.

If the DSUSEJDBC value is ‘Y’, then the program will use the original the JavaSoft specification of a standard application programming interface (API) that allows Java programs to access database management systems.

If using ‘Y’ for DSUSEJDBC setting, then iMail will need use the standard JDBC method in the processing of the conversion. When using JDBC you will need to add the CLASSPATH as this is used in this method. Additionally, User Profiles which are used to submit a job will need to have a Password associated with the User Profile for this method to function correctly. If you need to use a User Profile which does not uses a password, then use the newer method to process by selection ‘N’ on the DSUSEJDBC data area.

If the DSUSEJDBC value is ‘N’, then the program will use the revised method for processing which does not use Java™ database connectivity (JDBC).

When using the new method for processing if iMail encounters a Java Exception, then iMail will use QSHELL to call IMR7000 or IMRSPLF2XLS (depending on what type of conversion is being performed). Instead of using JDBC iMail will use SequentialFile class in Java Toolbox for AS400 as a method for the database connection.

When using the new method, CLASSPATH does not need to be configured. However, it is recommended that you do setup CLASSPATH to point to the location of the new IFDJAVA.JAR file.

In the event that there is an exception in QSHELL, the job will continue to run and an error will appear in the job log. Most likely possibilities for an error in QSHELL will be 1.) The ‘JAR FILES Directory’ field in iMap was not configured correctly; or 2.) The IFDJAVA.JAR file does not exist in the specified directory.

These changes will address these two points:

1.) Provides for an alternative path to the IFDJAVA.JAR file when there is a Java exception;
2.) Provides for an alternative processing option/path when the User Profile does not have a password (as how IBISOWNER is configured) and there is a Java exception.

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