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Software Registration Form 
We welcome your comments on flashFORM Designer 5.0 and flashFORM400, this 
documentation and our technical support.  This is very important to us in order 
continue providing the best products and support possible.  Please feel free to 
email or fax us comments throughout your use of this software.   

In order to receive the 90 day no charge application support, we must have the 
below information faxed, mailed or emailed to our attention.  Please complete as 
detailed and add any comments.  Thank you: 

Company Name:  

Technical Contacts:  
Address 1/Address 2:  
City/ST/Zip:  
Voice Phone Number:  
Fax Number:  
Email Address:  
PC Host Model/AS/400: Host  
Operating System Level:  
AS/400 Serial Number:  
Product(s) Ordered:  
Comments:  
  

  

 

The undersigned acknowledges that he has read and agrees to be bound by the terms and conditions of 
the FORMation mg Software License Agreement. 

__________________________________________    ___________________________ 

Signed                                                                             Date 

Please make a photocopy for your records and FAX or MAIL to: 

FORMation mg, 15540 Rockfield Boulevard, Suite A, Irvine, CA  92618 
(949) 598-8890 Technical Support 

(949) 598-8899 FAX 
info@formationmg.com 

World Wide Web:    http://www.formationmg.com





 

 

Software License Agreement 
By using this software,  you agree to be bound by the terms of this license.  If you do not agree to the 
terms of this license, promptly return the software tape cartridge, diskettes or other media and 
documentation to FORMation mg, Inc. 

FORMation mg (“Fmg”) grants to you, the end user, the right to load and use the accompanying software 
on a single tape system.  This software is owned by Fmg and is protected by United States copyright laws 
and international treaty provisions. You may not lease, rent or sub-license the software.  You may not 
transfer the software of the accompanying documentation to another party.  You may not reverse 
engineer, decompile disassemble or create derivative works from the software.  Upon payment of the 
software license fee(s), Fmg will provide a “soft code unlock” derived from customer’s serial number,  
which grants customer unlimited,  non-exclusive license to use the Software and accompanying 
documentation (“Documentation”) in the manner described below in “Scope of Grant.” 

Limited Warranty 

Fmg warrants that for a period of ninety (90) days from the date of acquisition, the Software, if operated 
as directed, will substantially achieve the functionality described in the Documentation.  Fmg does not 
warrant, however, that your use of the Software will be uninterrupted or that the operation of the Software 
will be error-free.  Fmg also warrants that the media containing the Software, if provided by Fmg, is free 
from defects in material and workmanship and will so remain for ninety (90) days from the date you 
acquired the Software. Fmg’s sole liability for any breach of this warranty shall be, in Fmg’s sole 
discretion: (i) to replace your defective media; or (ii) to advise you how to achieve substantially the same 
functionality with the Software as described in the Documentation through a procedure different from that 
set forth in the Documentation; or (iii) if the above remedies are impracticable,  to refund the license fee 
you paid for the Software. Repaired,  corrected, or replaced Software and Documentation shall be 
covered by this limited warranty for the period remaining under the warranty that covered the original 
Software, or if longer, for thirty (30) days after the date (a) of shipment to you of the repaired or replaced 
Software, or (b) Fmg advised you how to operate the Software so as to achieve the functionality 
described in the Documentation. Only if you inform Fmg of your problem with the Software during the 
applicable warranty period and provide evidence of the date you purchased a license to the Software will 
Fmg be obligated to honor this warranty. Fmg will use reasonable commercial efforts to repair, replace, 
advise or, for individual consumers, refund pursuant to the foregoing warranty within 30 days of being so 
notified. 

THIS IS A LIMITED WARRANTY AND IT IS THE ONLY WARRANTY MADE BY Fmg.  Fmg MAKES NO 
OTHER EXPRESS WARRANTY AND NO WARRANTY OF NONINFRINGEMENT OF THIRD PARTIES’ 
RIGHTS. THE DURATION OF IMPLIED WARRANTIES, INCLUDING WITHOUT LIMITATION, 
WARRANTIES OF MERCHANTABILITY AND OF FITNESS FOR A PARTICULAR PURPOSE, IS 
LIMITED TO THE ABOVE LIMITED WARRANTY PERIOD; SOME JURISDICTIONS DO NOT ALLOW 
LIMITATIONS ON HOW LONG AN IMPLIED WARRANTY LASTS, SO LIMITATIONS MAY NOT APPLY 
TO YOU. NO Fmg DEALER, AGENT, OR EMPLOYEE IS AUTHORIZED TO MAKE ANY 
MODIFICATIONS, EXTENSIONS, OR ADDITIONS TO THIS WARRANTY. If any modifications are made 
to the Software by you during the warranty period; if the media is subjected to accident, abuse, or 
improper use; or if you violate the terms of this Agreement, then this warranty shall immediately be 
terminated. This warranty shall not apply if the Software is used on or in conjunction with hardware or 
software other than the unmodified version of hardware and software with which the software was 
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designed to be used as described in the Documentation.  THIS WARRANTY GIVES YOU SPECIFIC 
LEGAL RIGHTS, AND YOU MAY HAVE OTHER LEGAL RIGHTS THAT VARY BY JURISDICTION. 

Scope of Grant 

You may: 

use the Software on any single personal computer, if applicable; 

use the Software on an AS/400-network, if applicable; 

copy the Software for archival purposes, provided any copy must contain all of the original Software’s 
proprietary notices; or 

You may not: 

permit other individuals to use the Software except under the terms listed above; 

permit concurrent use of the Software; 

modify, translate, reverse engineer, decompile, disassemble (except to the extent applicable laws 
specifically prohibit such restriction), or create derivative works based on the Software; 

copy the Software other than as specified above; 

rent, lease, grant a security interest in, or otherwise transfer rights to the Software; or 

remove any proprietary notices or labels on the Software. 

Title 

Title, ownership rights, and intellectual property rights in the Software shall remain in Fmg and/or its 
suppliers. The Software is protected by the copyright laws and treaties.  Title and related rights in the 
content accessed through the Software is the property of the applicable content owner and may be 
protected by applicable law. This License gives you no rights to such content.  

Termination 

The license will terminate automatically if you fail to comply with the limitations described herein.  On 
termination, you must destroy all copies of the Software and Documentation. 

LIMITATION OF LIABILITY. UNDER NO CIRCUMSTANCES AND UNDER NO LEGAL THEORY, TORT, 
CONTRACT, OR OTHERWISE, SHALL Fmg OR ITS SUPPLIERS OR RESELLERS BE LIABLE TO YOU 
OR ANY OTHER PERSON FOR ANY INDIRECT,  SPECIAL, INCIDENTAL, OR CONSEQUENTIAL 
DAMAGES OF ANY CHARACTER INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF 
GOODWILL, WORK STOPPAGE, COMPUTER FAILURE OR MALFUNCTION, OR ANY AND ALL 
OTHER COMMERCIAL DAMAGES OR LOSSES. IN NO EVENT WILL Fmg BE LIABLE FOR ANY 
DAMAGES IN EXCESS OF THE AMOUNT Fmg RECEIVED FROM YOU FOR A LICENSE TO THE 
SOFTWARE, EVEN IF Fmg SHALL HAVE BEEN INFORMED OF THE POSSIBILITY OF SUCH 



 

 

DAMAGES, OR FOR ANY CLAIM BY ANY OTHER PARTY. THIS LIMITATION OF LIABILITY SHALL 
NOT APPLY TO LIABILITY FOR DEATH OR PERSONAL INJURY TO THE EXTENT APPLICABLE LAW 
PROHIBITS SUCH LIMITATION. FURTHERMORE, SOME JURISDICTIONS DO NOT ALLOW THE 
EXCLUSION OR LIMITATION OF INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO THIS 
LIMITATION AND EXCLUSION MAY NOT APPLY TO YOU.   

This Agreement represents the complete agreement concerning this license and may amended only by a 
writing executed by both parties. THE ACCEPTANCE OF ANY PURCHASE ORDER PLACED BY YOU 
IS EXPRESSLY MADE CONDITIONAL ON YOUR ASSENT TO THE TERMS SET FORTH HEREIN, 
AND NOT THOSE IN YOUR PURCHASE ORDER. If any provision of this Agreement is held to be 
unenforceable, such provision shall be reformed only to the extent necessary to make it enforceable.  
This Agreement shall be governed by California law (except for conflict of law provisions). 
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Forms Design User’s Guide            

Welcome 
 

Welcome to flashFORM DesignerTM and flashFORM400TM AS/400 electronic form 
integration software.  flashFORM is the easiest way to convert your paper forms to 
electronic forms. Use flashFORM to edit, design, merge AS/400 spool data, fill 
forms, manage information databases, and print and mail forms among other 
functions.  The following documentation has been provided to help you learn about 
flashFORM Designer and flashFORM400 AS/400 form integration software. 

FORMation mg endeavors to combine a powerful fully automatic forms 
conversion product with a flexible, innovative integration software.  flashFORM has 
a powerful automatic form conversion (“vectorization”) capability that enables you 
to automatically create electronic forms from scanned in pre-printed forms. It 
recognizes lines, text, circles and graphics  with great accuracy and even creates 
data fields where they are appropriate. In addition, it has all the tools necessary to 
design, from scratch, new forms or edit converted forms. 

How to Use this Manual 

This manual is laid out into two User’s Guides: flashFORM Designer User’s Guide 
and flashFORM400 AS/400 Form Integration User’s Guide. 

flashFORM Designer User Guide 

The first User’s Guide covers all aspects of initiating the forms recognition, forms 
design, generating AS/400 overlay and spool field mapping files, advanced 
features, filling forms, managing databases, troubleshooting, etc.. 

flashFORM400 AS/400 Electronic Form Integration User Guide 

The second User’s Guide covers all the steps to integrate your designed forms and 
graphics to your AS/400 application environment.  Including, electronic form 
definition, spool data mapping operations, MICR Security check printing operations 
(if this option was ordered), advanced functions, and auto-engine definition.  
Documentation for flashMAIL400 (AS/400 email system), flashVIEW400 (AS/400 
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archive and retrieve), flashFAX400 (AS/400 automated fax system) and Positive 
Pay will come under separate cover when those products are ordered. 

Generating AS/400 Form Overlay (“macros) and AS/400 Field 
Mapping Files 

…  two important steps to AS/400 form integration 

The flashFORM Designer User’s Guide will provide instruction for basic forms 
design operations. However, there are three important components you need to 
refer to for AS/400 Form integration. These are “Generating an AS/400 form 
overlay (“macro”) “on page 38. “Generating an AS/400 field mapping file“on page  
40    and “Creating AS/400 Field Mapping Fields” on your form, page 68. The 
flashFORM400 User’s Guide will cover the integration of macros and field files on 
the AS/400 side. 

flashFORM Designer’s Online Help 

flashFORM Designer’s online help contains information on features, settings, and 
procedures. The online help conforms to Windows online help conventions and 
has been designed for quick and easy information retrieval. Please see information 
on using the online help. 

Scanner Setup Notes 

The Scanner Setup Notes contains information about supported scanners and 
related issues. To open this PDF file, click Start in the Windows taskbar and 
choose Programs4 FORMation4 FORMation Documents4Scanner Setup Notes 
after flashFORM has been installed. 
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Using This Manual 

This manual is written with the assumption that you know how to work in the 
Windows environment. Please refer to your Windows documentation if you have 
questions about how to use dialog boxes, menu commands, scroll bars, drag and 
drop functionality, shortcut menus, and so on. 

The following conventions are used in the flashFORM Designer User’s Guide 
section:  

 
Convention Purpose  

Italicized text •  Emphasizes menu commands, dialog box 
options, and labeled buttons  

 For example:  
 “Choose Open... in the File menu.” 
•  Emphasizes new terms the first time they 

are used 
•  Emphasizes important words in a sentence 

 

Note symbol  

Introduces a tip or an item of note 

 

Warning symbol  

Introduces important information 

Courier font AS/400 Commands and user entry 

 

AS/400 screen shots are captioned for easy 
reference 

 

Getting Online Help 

In addition to using this manual, you can use flashFORM’s online help topics to 
learn about features and procedures. Online help is available after you install 
flashFORM.  

flashFORM’s online help follows the conventions of Microsoft Windows 95 Help. 
Choose How to Use Help in flashFORM’s Help menu to get information on using 
Help. 





Forms Design User’s Guide 
Welcome 

 
 

flashFORM Designer User’s Guide   5   

Help menu 

Use the commands in the Help menu to find information about flashFORM topics. 

 

 

Select flashFORM Help to obtain flashFORM’s main Help topics. Select Getting 
Started to begin flashFORM’s tutorials. Select How to Use Help to get Microsoft 
Windows Help topics that explain how to use and customize Help. Select Product 
Support to find out how to get product support services for flashFORM. Select Tip 
of the Day... (if a form is open) to obtain tips to help you use flashFORM. Select 
About flashFORM to get information about your version of flashFORM. 

flashFORM Tutorials 

flashFORM has four online tutorials to step you through the basics. If you have 
never used flashFORM before or you need to review some of the procedures, 
please go through these tutorials. 

• In the first tutorial, Load and Fill a Form, you will scan (or 
import) and fill a Sample form (included in the flashFORM 
package) by using the Form Assistant. 

• In the second tutorial, Edit and Design a Form, you will scan or 
import the Sample form into flashFORM again and learn to use 
the basic buttons and menu commands, verify and correct 
OCR, and modify the form.  

• In the third tutorial, Design Your Own Form, you will create a 
form and learn how to create objects, define calculations, 
customize the form, set the tab order, and add a graphic.  

• In the fourth tutorial, The flashFORM Database, you will use 
the form that you created in the third tutorial and learn some 
basics about flashFORM’s database as well as how to create 
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and manipulate database records.
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Context-Sensitive Help 

You can get on-the spot information about a particular flashFORM command, 
toolbar button, or dialog box option in the following ways:  

•  Click the Help button in the flashFORM design/fill toolbar 
to turn your cursor into a question mark icon. Click any 
command, button, or portion of the window to open context-
sensitive help for that topic. 

•  Click the question-mark button in the upper-right 
corner of a dialog box and then click an item in the dialog box 
to get a pop-up explanation for that item.  

•  Some dialog boxes have a Help button. Click 
Help to get information about that dialog box. 

Product Support 

For the fastest and easiest way to get help, please look for solutions in this manual 
or in the online Help. See “ General Troubleshooting”  troubleshooting tips.  

If you need additional help, please use the following resources: 

• FORMation mg’s World Wide Web site 
Go to FORMation mg’s World Wide Web site for common 
questions and answers, updates, patches, troubleshooting 
procedures, and product information. FORMation mg’s Web 
site address:  http://www.formationmg.com 

• Scanner Setup Notes 
Read the Scanner Setup Notes document to learn about 
supported scanners and related issues. This document has 
been provided to you as an electronic document in PDF format. 
To open this document, click Start in the Windows taskbar and 
choose Programs… FORMation… FORMation Documents…  
Scanner Setup Notes. 
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You must have Adobe Acrobat Reader 3.01 or greater installed if you want to read 
the Product Support and Scanner Setup Notes PDF documents. To install the 
Reader, click Start in the Windows taskbar and choose Programs… FORMation 
Applications… FORMation Documents… Acrobat Reader. 
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Installation and Setup 
 

This chapter describes how to install flashFORM and begin using it.  

For technical and troubleshooting information, please see “Technical Information.” 

This chapter contains the following sections: 

• System Requirements  

• Installing flashFORM Designer and flashFORM Filler  

• Registering flashFORM  

• Starting flashFORM   
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System Requirements 

To install and run flashFORM, you need the following setup: 

• Computer with an 80486 or higher processor 

• VGA or SVGA monitor (24-bit display adapter recommended 
for color forms) 

• Windows-compatible mouse 

• CD-ROM drive  

• A minimum of 25MB hard disk space for flashFORM and up to 
a maximum of 45MB 

• A minimum of 10MB hard disk space for flashFORM Filler and 
up to a maximum of 20MB 

• A compatible scanner if you plan to scan documents 

• Please see Scanner Setup Notes, which are included on your 
flashFORM CD-ROM, for a list of tested scanners 

• Total system memory of at least 16MB RAM (32MB 
recommended) for Windows 95 or 98, and Windows NT 4.0. 
 

 
flashFORM 5.0 for Windows 95 or 98 and Windows NT 4.0 is a 32-bit application 
and will not run on earlier versions of Windows. 

Installing flashFORM Designer 

This section describes how to install flashFORM and MacMaker on Windows 95,  
98, or NT 4.0. If you have an older version of flashFORM Designer, you might want 
to uninstall it before you install the latest version.  

 

 
Close all applications — including screen savers, virus checkers, and mail applica-
tions — before installing flashFORM. 

To install flashFORM and flashFORM Filler:
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Start Windows. 

Insert flashFORM’s CD-ROM in the CD-ROM drive. 

• Run Setup.exe 

• Follow all the instructions in the dialog boxes that appear. 
During installation, you will be prompted to enter a serial 
number. You can find the serial number on the label of the CD-
ROM.  

• It is recommended to install the two modules Scan Manager 
and Print to OmniForm Support.  The MacMaker module will 
automatically install. 

• flashFORM installs by default to the location c:\Program 
Files\FORMation\flashFORM. You can select another 
location if you wish. 

• Installation instructions for flashFORM400 AS/400 Electronic 
Form Integration Software can be found in the AS/400 User’s 
Guide “Installing and Updating flashFORM400”. 

flashFORM Designer 5.0 comes with a 25 usage license 

Registering flashFORM Designer 5.0 

Register your copy of flashFORM with FORMation mg Corporation to receive 
notification of special offers and the best prices on product upgrades. fashFORM 
Designer comes with a registration, but will only generate the AS/400 overlay files 
25 times. 

Once the software has been purchased, contact FORMation mg for the registration 
code to continue usage  (800) 693-3933.  Anyone in sales or tech can give you the 
registration code upon confirmation the purchase with Accounting.  Can also reach 
FORMation mg by email at info@formationmg.com. 

 
After registration is complete, you will be given a registration number. Be sure to 
write that number down and keep it handy in case you need to use it for 
reinstallation. If you reinstall flashFORM using your registration number on the 
same computer, you will not have to go through the entire registration process 
again to reregister it. 
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Starting flashFORM 

This section describes how to launch flashFORM after it is installed.  

 
Install your scanner and test it in Windows before using it with flashFORM. Consult 
your scanner documentation or the scanner manufacturer to resolve any scanner 
problems that may occur. 

 

To start flashFORM: 

1. Click Start in the taskbar and choose  

Programs, FORMation, flashFORM 5 

The Form Assistant dialog box appears. It contains six options. Each is a basic 
flashFORM procedure.  

 

2. Select an option and click Next>. 

Proceed to “flashFORM Procedures,” for detailed information on the basic 
flashFORM procedures. Or, if you are new to flashFORM try the online tutorials. 
Click Getting Started in the Help menu to access the tutorials. 
Click Cancel to close Form Assistant if you do not want to choose a particular 
option. 
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Form Usage  
 

This chapter describes basic flashFORM concepts you should know before 
scanning, importing or designing a new form. It includes the following sections: 

• Using Form Assistant 

• Form Usage Options 

• International Settings 
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Using Form Assistant 

Form Assistant is a dialog box that appears when launching flashFORM. If you are 
new to flashFORM, you might prefer to use the Form Assistant, which makes 
decision-making easy when processing a form. Later, you might choose to use the 
commands in the design toolbar or menu. See  “flashFORM Procedures,” for more 
information about using the commands. 

This section contains the following topics: 

• Opening Form Assistant 

• Form Assistant Options 

Opening Form Assistant 

There are several ways to open Form Assistant. 

• Form Assistant opens automatically the first time you open 
flashFORM. 
Click Start in the Taskbar and choose Programs�FORMation 
�flashFORM 5.0. 

•  If Form Assistant is not open, you can either click the 
Form Assistant button in the design toolbar at the top of the 
window, or choose Form Assistant... in the File menu. 

The Form Assistant dialog box contains six options for basic flashFORM 
procedures as described in the next section. You can also select or deselect the 
option Show on StartUp, which determines whether the Form Assistant dialog box 
appears on startup. 
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Form Assistant Options 

This section gives a brief description of each option in Form Assistant. Through a 
series of dialog boxes, Form Assistant easily steps you through the process of 
converting your form into an electronic form.  

Scan a Form or Image File 

Select Scan a form or image file to scan a paper form or import an image file and 
to determine how you will work with the form in flashFORM. 

Fill in a Form 

Select Fill in a form to fill the currently open form or to open a form and fill it. See 
“Filling a Form,” for more information. 

Print a Form 

Select Print a form to print the currently open form or to open a form and print it.  
You can also generate the AS/400 overlay file and field mapping file from the Print 
Menu.  (The AS/400 field mapping file is automatically generated when a macro is 
generated.) 

Search a Form for Information 

Select Search a form for information to search the currently open form for 
information or to open a form and search it. 
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Work on a Form’s Design 

Select Work on a form’s design to redesign the currently open form or to open a 
form in design view. See “Designing a Form,” for more information. 

Create a New, Blank Form 

Select Create a new, blank form to open a blank page in design view. 

Form Usage Options 

Form usage affects the way you can use a form once it is in flashFORM. This 
section contains the following topics: 

• Choosing a Form Usage Option 

• Where to Select Form Usage Options 

• Changing Form Usage  

 
Decide how you will use a form in flashFORM before you scan or import it: as a 
designed form, as an original form, or as a nondesigned form image as described 
below. 

Choosing a Form Usage Option 

The following table provides the three usage options — designed, original, and 
nondesigned form — and recommendations for your choice.  

Choose Designed 
Form when you want: 

Choose Original Form 
when you want:  

Choose Nondesigned 
Form when you want:

full control over a form’s 
design 

partial control over a form’s 
design 

to input a form of such poor 
quality that it would cause 
recognition problems 

to edit all form elements in 
design view 

to maintain a form’s origi-
nal look 

to draw new fillable objects 
on the form in design view 

to create new objects in 
design view 

to create new fillable 
objects on the form in 
design view 

print or mail the form only 

 to fill fields in fill view to fill fields in fill view  

Where to Select Form Usage Options 

Different form usage options are available depending on whether you open Form 
Assistant or choose Scan Form... in the File menu. 

Form Assistant 
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You can choose to scan in or import either a designed form or an original form in 
Form Assistant. 

 

 

This dialog box is one of several in Form Assistant and appears during the 
scanning or import process. See “Form Assistant Options” for more information. 

Scan Form Dialog Box 

You can choose to scan in or import either a designed form or a non-designed 
form in the Scan Form dialog box after choosing Scan Form... in the File menu. 

 

 

Designed form option 

Original form option 
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Changing Form Usage 

Choose Form Usage... in the View menu to change the way you can use a form. 
For example: 

• If you have an original form but decide to change the design, 
then you would change the form to a designed form. 

• If you have a designed form that you have edited but want to 
mail the original form to someone, then you would change the 
form to an original form. 

 
There is no original view for a form that you design yourself in flashFORM. 

To change form usage: 

1. Choose Form Usage...in the View menu. 

2. The Form Usage dialog box appears. 

 

3. Select a form usage option. 

• Select Use Designed Form to view the form as it was designed 
by flashFORM on import along with any changes you have 
made to the form’s design. 
You can edit all text and fields, and add graphics to the form. 

• Select Use Original Form to view the form as it looked 
originally, before you scanned or imported it to flashFORM. 
You can create, resize, move, delete, define, or change the 
appearance of the spool data mapping or fillable fields with this 
option. Changes you make to text, graphics, and nonfillable 
objects are not visible until you select Use Designed Form. 

4. Click OK.  
Your form changes to reflect the selected option. 
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You can change the form usage from a non-designed form to a designed form. 
However, the form will be blank except for any fillable objects you may have 
added. 

International Settings 

flashFORM supports different language and cultural conventions. You can choose 
from 45 different locales in the International tab in the Options dialog box. A locale 
— as defined for flashFORM usage — is a combination of a language and a 
region. The language you select for a particular region affects how your form 
displays currency, numbers, and dates. 

To Select a Language for Your Form:  

1.  If you are in fill view, click the Design button in the design toolbar or 
choose Design in the View menu. 

2. Choose Options... in the Tools menu. 

3. Click the International tab. 
Two options are Current Form and New Forms. 

 

4. Click Current Form. 

The Language drop-down list displays the language being used for the currently 
open form. If you have the International English, French, or German versions of 
flashFORM or if you have multiple dictionaries, a dictionary in this language will 
also be used during a spell check. 
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You can only change the language for this option if you open the Options dialog 
box in design view. 

5. Select a language for the current form. 

6. Click New Forms. 
The Language drop-down list displays the default language that will be used 
for the next form you open, scan, or import. 
The language selected for a new form will also become the Current Form 
selection when that form opens in flashFORM. 

7. Select a language for new forms. 

8. Click OK. 

How flashFORM Uses Language Selections 

The Current Form language selection affects: 

• The formatting of currency, number, and date entries in the 
currently open form. 

• Which dictionary is used for spell checking.  

• The international symbol that appears in the status bar when a 
form is currently open. 

• The New Form language selection affects: 

• The formatting of currency, number, and date entries in new 
forms you create by scanning or importing, or by choosing New 
in the File menu. 

• The international symbol that appears in the status bar when a 
form is not open. 

Control Panel Selections 

Selections made in the International tab do not affect selections made in the 
Regional Settings control panel.  

Only the List Separator option in these control panels affects how data is displayed 
in flashFORM. 

The Options Dialog Box Readouts 
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Below the Language selection, flashFORM displays readouts: the international 
symbol for the selected language (which appears in the status bar); and currency, 
number, and date conventions specific to that language 

The readouts show: 

• How flashFORM expects data to be entered in fill view. 

• How flashFORM will format data in fill view if it is not entered 
correctly. (Formatting takes place after you move the cursor out 
of a field.) See the next section for formatting examples. 
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Formatting Examples 

Currency 

If you select German (Austrian) as the Current Form language, the numbers 
123456 entered in an appropriately defined currency field would display as öS 
1.234,56. 

If you select German (Liechtenstein) as the Current Form language, the numbers 
would display as CHF 1’234.56. 

Date 

If you select English (United States) as the Current Form language, the date 2/ 
5/96 entered in an appropriately defined date field would display as February 5, 
1996. 

If you select German (Standard) as the Current Form language, the date would 
display as 2. Mai 1996. 

Euro Currency Symbol 

Select the Use euro currency symbol to format currency fields with the euro 
currency symbol. You can use this feature if your system supports the euro 
currency symbol, that is, it can be entered via the keyboard, displayed on your 
screen, and printed.  

The Scan Form Dialog Box 

The New Form language selection appears in the Options dialog box, which 
is selected from the Scan Form dialog box. 

 

You cannot change the New Forms 
language if you select this option. 

Click Options… to view the current 
language for your form or to change 
the language selection. 
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• Click Options... to view the language of your current form and 
to change the language for your new form. 
You cannot change the New Form language selection if Add 
Page(s) to Current Form is checked because a language is 
already associated with the current form. A form can have only 
one language. 

• If you select Add Page(s) to Current Form, the Language 
display changes to reflect the Current Form language if it is 
different. 

The Object Definition Dialog Box Options 

The Current Form language selection affects available formatting options for 
fillable objects defined as Number, Date, or Currency in the Object Definition 
dialog box. For example, the long-date format for English (United States) is 
MMMM dd, yyyy. The long-date format for German (Standard) is d.MMMM yyyy. 

The Allow Multiple Languages Option 

How it Works 

You can select Allow Multiple Languages in the Scan Form dialog box (by first 
clicking Options... in this dialog box and then selecting the Recognition tab) for 
multiple-language forms. flashFORM then recognizes all characters in all 
languages that it supports. The setting does not affect the language(s) selected for 
your form in the Options dialog box and vice versa. 

When you select Allow Multiple Languages, flashFORM turns off dictionaries 
during optical character recognition (OCR) so that all recognizable characters are 
allowed. If dictionaries were on, special characters such as umlauts might be 
discarded or questionable words in one language could be mistaken for words in 
another language.  

 
Do not select Allow Multiple Languages for a single-language form. OCR may not 
be as efficient with dictionaries turned off. 

Selecting the New Forms Language 

Determine which language composes the majority of your form and select that as 
the New Forms language before scanning. To do so, click Options... in the Scan 
Form dialog box. 

Remember that the selected language affects sort order and how dates, numbers, 
and currency are formatted in fill view. See “ Spell Checking Multiple Languages”  



Forms Design User’s Guide 
Form Usage 

 
 

flashFORM Designer User’s Guide   25   

for information on spell-checking for information on spell-checking a form with 
multiple languages. 
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flashFORM Procedures 
 

This chapter describes basic flashFORM procedures, including the following 
sections: 

• Scanning a Paper Form 

• Importing an Image File 

• Proofing a Form 

• Filling a Form 

• Printing a Form 

• Generating an AS/400 form overlay (“macro”) 

• Generating an AS/400 field mapping file 

• Importing an Existing Electronic Form 

• Searching a Form 

• Creating a Form 

• Opening a Form 

• Mailing a Form 

• Saving a Form 

• Publishing a Form to the Web 
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Scanning a Paper Form 

This section describes how to use the Scan Form... command to turn your paper 
form into an electronic form. You can also use the Form Assistant dialog box to 
scan a form. See “ Using Form Assistant” . 

You can scan paper forms directly into flashFORM if you have a scanner. Forms 
should be blank with crisp, dark text for best results. flashFORM can scan black- 
and-white and color forms. 

You can use the Sample Form included with your flashFORM package as a test 
page. 

To scan a paper form:  

1.  Place your form in your scanner. 

2. Click the Scan button in the design toolbar or choose Scan Form... in the File 
menu. 
The Scan Form dialog box appears.  

 

3. Select Scanner in the Source box. 

4. If you are scanning a form that contains color (text or background) and you 
want the color to be recognized, then select the Scan in color check box.  

 
flashFORM will not scan or convert forms in grayscale.  The scan must be black 
and white, line art, 300 dpi, *PCX or *TIF images only. 
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5. Click Set Up Scanner... to choose a page size and adjust scanning brightness. 
  

• Select an option under Page Size. 
Select Letter if the form is 8.5 by 11 inches. 
Select Legal if the form is 8.5 by 14 inches. 
Select A4 if the form is 21 by 29.7 centimeters (European). 

• Select how light or dark the scanned image will be under 
Brightness. 
Select Lighten if the form has very thick or run-together text, or 
if the background is smudged, shaded, or colored. 
Select Normal if the form has crisp, black text and objects are 
on a white background. 
Select Darken if the form has very thin or broken text such as a 
poor- quality fax or a copy of a copy. 

                                                     

 

 

6. Click OK to return to the Scan Form dialog box. 

7. Select an option in the Orientation drop-down list. 

• Select Auto to have flashFORM determine orientation 
automatically. 

• Select Portrait for a vertically oriented page. 

• Select Landscape for a horizontally oriented page. 

• Select Flipped to automatically rotate a portrait page 180 
degrees during the scan. 

• Select Flipscape to automatically rotate a landscape page 180 
degrees during the scan. 

 
The Flipped and Flipscape options are useful for scanning pages in a book that 
needs to be turned upside down or sideways. 

Text on a shaded 
background. Select 
Auto (AccuPage). 

Crisp, black 
text. 
Select Normal.

Thin, broken text. 
Select Darken. 

Thick, dark text. 
Select Lighten 
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8. Select import options under the Settings options. 

• Select Auto Form Design to use Logical Form Recognition in 
order to recognize text and fillable fields in the form. 

• This gives you full control over a form’s design. 

• Deselect Auto Form Design to scan a form without recognizing 
form design. Text and fillable fields are not recognized. 
This is useful if you just want to print or mail a form, or if the 
form is of such poor quality that it would cause recognition 
problems. 

• Select Auto Form Straightening to have flashFORM 
automatically straighten a crooked page. 
This is useful if you scan a page in a large, unevenly cut, or 
thick document that is difficult to position correctly. 

Select Add Page(s) to Current Form to make the newly scanned page the next 
page in the current form. 
This option is only available if a form is open. 

9. Click Options... in the Scan Form dialog box and then click the Recognition tab 
to set recognition options for your form. 

• Select Allow Multiple Languages if you have a form with 
multiple languages and you want flashFORM to recognize 
more than one language. 
This setting does not affect the language setting in the 
International tab. Do not select this setting for a single 
language form because optical character recognition (OCR) 
may not be as efficient. 

• Select Find Calculations automatically if your form has 
calculations and you want flashFORM to recognize the 
calculations. 

• Select Find Hyperlinks automatically if your form contains 
hyperlinks and you want flashFORM to recognize the 
hyperlinks. This option is only available if you are importing a 
form. 

• Select Detect paper color automatically if your form’s 
background has color and you want flashFORM to recognize 
the color during OCR. If you deselect this option, the form’s 
background will be detected as white. 
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• Select Show Proofreader after recognition to open the 
Proofreader After your form has been recognized. See “ 
Proofing a Form”  for more information. 

• Click Font Mapping... to open the Font Mapping dialog box. In 
this dialog box you select options to retain the font 
characteristics of your form during OCR.  
Select the fonts you want mapped to each font type and click 
OK when you are done. 

10.  Click Options... in the Scan Form dialog box and then click the International 
tab to make sure the appropriate language is selected. If you need to change 
the language for your new form, select an option in the Language drop-down 
list. 
See “International Settings” for more information on international options. 
Click OK to return to the Scan Form dialog box. 

11.  Click OK in the Scan Form dialog box to begin scanning. 
flashFORM scans the form. The flashFORM window displays the scanning, 
designing, and straightening progress if you selected those options. 
If your scanner does not allow you to stop the scanning process, then the Stop 
button will be grayed out. 
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How your form appears depends on whether or not you chose Auto Form Design 
in the Scan Form dialog box. 

12.  Click the Save button in the design toolbar or choose Save... in the File menu 
to name and save your file.  

 

 
Color forms generally use more memory than black-and-white forms. If you are 
scanning a color form and are concerned about the amount of memory you might 
use, do not save your color form image with the file. Choose Save As... in the file 
menu, name your file, and deselect Save original form(s) with form file. Click Save 
to save your file. 

If you have selected Show Proofreader after recognition, the Proofreader window 
appears to the left of the main window. For more information, please see “Proofing 
a Form” . 

13.  Begin to edit or fill your form. 

See “Designing a Form,” for detailed information on defining, moving, resizing, and 
creating fields, as well as other design functions 

See “Filling a Form,” for detailed information on the kinds of fields you may find on 
a form and how to fill them. 

Importing an Image File 

This section describes how to use the Scan Form... command to import an image 
file as a recognized flashFORM form. You can also use the Form Assistant dialog 
box to import a form. See “ Using Form Assistant”. 

flashFORM can import and recognize black-and-white and 24-bit color forms in 
either PCX or TIFF format. Image resolution must be 200, 300, or 400 dots per 
inch (dpi) for black-and-white forms, and 300 dpi for color forms. If you have a fax 
modem, for example, you can receive a faxed form and use the fax program’s 
software to save the file in PCX or TIFF format. flashFORM offers the same import 
options for image files as it does for scanned forms. 

 

 
flashFORM automatically detects color/black-and-white forms when processing an 
image file. 
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To Import an image file as a form: 

1.  Click the Scan button in the design toolbar or choose Scan Form... in the 
File menu. 
The Scan Form dialog box appears. 

2. Select Image File(s) in the Source box to recognize a form in a supported 
image format.  

 

3. Click Select Files. 

The Select Files dialog box appears.  

• Locate and select a file. This could be a form created in 
another program or one received as a fax file. 

• Click Add File to add the file to the Files to Process list box. 

• Click OK to return to the Scan Form dialog box when you are 
done. 

4. Follow steps 5 through 8 in the preceding section, “To scan a paper form:” 

5. Click  OK. 
flashFORM imports the form. The flashFORM window displays the scanning, 
designing, and straightening progress if you have selected these options. 
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How your form appears depends on whether you chose to have flashFORM 
design the form during import. 

6.  Click the Save button in the design toolbar or choose Save... in the File 
menu to name and save your file. 

7. If you have selected Show Proofreader after recognition, the Proofreader 
window appears to the left of the main window. For more information, please 
see “ Proofing a Form”. 

8. Begin to fill or edit your form. 

See “Designing a Form,” for detailed information on defining, moving, resizing, and 
creating fields, as well as other design functions. 

See “Filling a Form,” for detailed information on the kinds of fields you may find on 
a form and how to fill them. 

Proofing a Form 
 

After you scan or import an image file, you can use the Proofreader option to make 
improvements to your form. If you have selected Show Proofreader after 
recognition, the Proofreader window appears to the left of the main window 
immediately after you scan or import a form. 

 

If the Proofreader does not appear, choose Proofreader in the Tools menu. 
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If you do not want the Proofreader window to appear, you can turn it off. Choose 
Options... in the Tools menu and click the Recognition tab. In the Recognition tab, 
deselect Show Proofreader after recognition. 

To begin proofing: 

1. Click Next> in the Proofreader window and follow all instructions in the panels 
that appear. 

2. Click Finish to display the Proofreader Index panel.  
 
The following Proofreader window appears 

                                  

 

This window displays all the options in the Proofreader. Click a bulleted topic in the 
Proofreader Index panel to display that section in the Proofreader Instruction 
panel. 

 To close the Proofreader window, click the Tools button in the design toolbar. 
Or, click the X button in the upper-right corner of the Proofreader window.  

 

Proofreader 
Instruction 
panel: This 
panel displays 
all the options in 
the Proofreader. 

Proofreader Index 
panel: The red bullet 
indicates what will 
be displayed in the 
Proofreader 

Instruction panel. 
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The Proofing Toolbar 

Use the proofing toolbar to edit your form. To view the proofing toolbar, select 
Toolbars in the View menu and then select Proofing in the drop-down menu. Or, 
click the Toolbar button in the Final Adjustments Instruction panel.  

 

 

     
 

 

If you would like to keep this toolbar on your desktop, see “ Customizing Toolbars”  
for more information. See the online help or the panels in the Proofreader for more 
information about how to use this toolbar. 

Filling a Form 

This section describes how to fill a form. You can also use the Form Assistant 
dialog box to fill a form. See “ Using Form Assistant”. 

To fill a form:  

1.  If you have a form open and are in design view, click the Fill button in the 
design toolbar or choose Fill in the View menu. 

2. Click in a field to place the cursor in the first field. 

3. Type the information you want to enter. 

4. Press the Tab key to move to the next field. 
Press Shift-Tab to move to the previous field. 

5. Continue to fill fields in this way. 

See “Filling a Form,” for more information. 

Printing a Form 

This section describes how to print a form, how to generate an AS/400 overlay file, 
and how to print to flashFORM (import forms from other applications). You can 
also use the Form Assistant dialog box to print a form. See “Using Form Assistant”. 

 
Format Painter  

Object Stamp 

Line Convert  Tab Group  

Field 
Name  

Proofing 
Options  
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Before you Print Your Form 

Before you print your form, you can use the Page Setup dialog box to select the 
paper size, margins, orientation, and color. To change the color of your form, see “ 
Adding Color to a Form”. You can print forms with different page sizes, margins, 
orientations (portrait and landscape) and color.  

To set up your form for printing: 

1. Choose Page Setup... in the File menu.  

The Page Setup dialog box appears.  

2. In the Page Setup dialog box select/fill in your options for Paper, Orientation 
and Margins.  

3. Select an option in the Apply to drop-down list.  

• Select Current page only to have your selections apply to only 
the current page. 

• Select Current page forward to have your selections apply to 
the current page of your form and all subsequent pages. 

• Select All pages to have your selections apply to all the pages 
of your form. 

4. Click OK to apply your options and close the dialog box. 

 

To Print a blank Form 

1.  Click the Print button in the design toolbar or choose Print... in the File 
menu. This is how the dialog box look. 
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See “Generating an AS/400 form overlay file (“macro”)”  

2. Select Print Paper Color if you want to print the background color of your form. 

3. Select any other print options desired. 

4. Click OK. 
flashFORM prints your form with the selected settings.The Print to File dialog 
box appears after you click OK if you have selected the Print to file option in 
the Print dialog box. Select a location for the file, type a file name in the File 
name text box, and click OK. 

Generating an AS/400 form overlay (“macro”) 

This is a very important step to integrating your form to the AS/400 environment.  
Once your form is designed, you’ll need to generate an AS/40 form overlay 
(“macro”) which will be dragged and dropped to your AS/400 FORMFMG directory.  
See the flashFORM400 User’s Guide on Moving designed forms to the AS/400 in 
the second section on AS/400 electronic form integration, once you’ve generated 
your overlay macro. 

1.   Click the Print button in the design toolbar or choose Print... in the File 
menu. The dialogue box is the same as the Print dialogue above, as shown 
below. 
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2. You must use THE HP LaserJet 4 driver for the Printer selection.  This is a 
standard driver included with all the Windows operating systems. 

3. Check the Print to file button. 

You will be prompted for the name and path of the file.  

 

Make sure the *.PRN extension stays with the name and path or the MacMaker will 
not be able to convert the file to a macro. 

4. Enter any desired macro number between 1 and 5 digits long. 

5. Click ok,  and flashFORM will generate an overlay file to the desired location. 

See “Moving Electronic Forms to the AS/400” in the second section on AS/400 
electronic form integration, once you’ve generated your overlay macro. 

To print your macro to the printer versus to an overlay file 
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Printing a macro is useful to see what the actual macro form looks like versus the 
regular Windows driver.  I you print using the regular Windows driver, the form 
could alter somewhat from the overlay macro.  The reason is flashFORM uses 
some compression and font decision algorithms to make a compressed file for 
AS/400 overlay operations. 

1. Launch flashFORM and open the form that you want to print. 

2. Choose Print... in the File menu to open the Print dialog box. 

3. Set your Printer Driver to be a LaserJet 4 

4. Select Use macro to print form. 

5. Do not select the Print to file button 

6. Select any other options that you want and click OK. This output will replicate 
exactly what the AS/400 form will look like. 

Generating an AS/400 field mapping file 

flashFORM400 on the AS/400 side gives you screens to map your AS/400 spool 
data to your designed form. This field mapping file is an optional method to drag ‘n’ 
drop selected portions of spool data to selected locations on the designed form. 
Before choosing this approach it is recommended to review the AS/400 Chapter on 
Configure Data Map, section “Two Mapping Techniques” for more information on 
which mapping approach will be best for your application. 

This field file contains fields inputted in your form design, which allows you to re-
map AS/400 spool file data to the inputted field locations (yellow boxes) on the 
form.  See “Creating AS/400 Field Mapping Fields” on page 68 for information on 
how to input fields.  flashFORM400 will read this file for instructions to map the 
AS/400 spool file data.  The PCL macro overlay file will join the field mapping in 
the FORMFMG folder.   

Steps to create the AS/400 field mapping file: 

1. This is a simple operation.  When you generate the AS/400 form overlay file 
(shown above), the field mapping file is automatically created and saved in the 
same location as the macro with an *.fld extension. 

Importing an Existing Electronic Form 

flashFORM has a useful feature to import documents from other programs within 
Windows. Using Print to OmniForm driver, you can print an electronic form 
(created from any Windows application) to flashFORM. flashFORM adds the 
OmniForm driver as a printer to the Windows Printer Group during installation. If 
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you do not have this feature, reinstall flashFORM and make sure that the Print to 
OmniForm Support option is selected in the Additional Components dialog box. 
Then, use the following instructions: 

To print your form to flashFORM: 

1. Open the form in the application in which it was created. 
Remove any colored or shaded background from the form. 

2. Choose Print in the File menu. 

3. Select OmniForm in the Name drop-down list. 

4. Click OK.  

flashFORM automatically scans in the form. The flashFORM window displays the 
scanning progress of the form. Your form opens in flashFORM. To make any 
corrections to the form, see “Designing a Form.” 

Searching a Form 

This section describes how to perform a search on a form. You can also use the 
Form Assistant dialog box to search a form. See “ Using Form Assistant”. 

To search a form:  

1.  If you have a form open and are in design view, click the Fill button in the 
design toolbar or choose Fill in the View menu. 

2. Choose Search... in the Records menu. 
The Search dialog box appears 

             
 

3. Select the field to search in the Field Name drop-down list. 

4. Select how to search for the information in the Condition drop-down list. 

5. Type the information to find in the Value text box. 

Which records to search 

What to search for 

How to search 

The field to search 
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6. Select which records to search. 

• Select Search All Records in the Database to search all 
records in the current database. 

• Select Only Search Current Record Set to search the current 
found set of records. This option is only available after a 
search. 

7. Click OK. 
flashFORM searches the records and finds any that contain the information 
you specified. 

See “ Searching Record for Information” for detailed information on searching. 

Creating a New Form 

This section describes how to create a new form.  You can also use the Form 
Assistant dialog box to create a new form. See “ Using Form Assistant”. 

See “Designing a Form” for detailed information on form design. 

To create a new form:  

1.  Click the New button in the design toolbar or choose New in the File 
menu. 
flashFORM opens a blank form in design view.  

 

2. Use the design view tools to create fields and objects on your new form. 
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Opening a Form 

This section describes how to open a form. 

To open a form: 

1. Click Start in the Taskbar and choose Programs4FORMation4flashFORM 5.0. 
Click Cancel in the Form Assistant dialog box if it appears. 

2.  Click the Open button in the design toolbar or choose Open... in the File 
menu. 
The Open dialog box appears. 

 

3. Make sure flashFORM Form is selected in the Files of type drop-down list. 

4. Locate and select a file. 

5. Click Open. 

The form opens in the last view in which it was saved: design or fill. You can switch 
the view if you wish. 

6.  If you are in design view and want to switch to fill view, click the fill view 
button on the design toolbar. See “Designing a Form,” for detailed information 
on defining, moving, resizing, and creating fields, as well as other design 
functions. 

7.  If you are in fill view and want to switch to design view, click the design 
view button on the fill toolbar. See “Filling a Form,” for detailed information on 
the kinds of fields you may find on a form and how to fill them. 



Forms Design User’s Guide 
flashFORM Procedures 

44   flashFORM Designer User’s Guide 

Mailing a Form 

This section describes how to select a mail system and mail a form from 
flashFORM. 

You must have either Lotus cc:Mail (2.0 and above)/Lotus Notes or Microsoft 
Exchange/Outlook installed to mail a form. 

To select a mail system: 

1. Choose Options... in the Tools menu in either fill or design view. The Options 
dialog box appears.  

    

2. Click the General tab and select an option under Mail System. 
Select either Lotus cc: Mail/Lotus Notes or Microsoft Exchange/ Outlook.  
flashFORM selects your installed mail application by default if you have only 
one installed. 

3. Click OK. 

To send a form:  

1. Open or scan in the form that you want to send. 

2.  Click either the design or fill view button in the design toolbar. (You can 
also choose Design or Fill in the View menu.) In design view you have two 
options: you can send only the form or send the form as a mailable filler. In fill 
view you have several options: you can send only the form, only the data, form 
and data, or send the form as a mailable filler. 

3. Choose Send in the File menu. 
The following Mail Options dialog box is for fill view. 
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4. Select an option. 

• Select Send the Form and Data to send all text, graphics, and 
any information in fillable fields. This option is available only in 
fill view.  

• Select Send the Data only to send just the information you 
have typed in the fillable fields. This option is available only in 
fill view. 

• Select Send the Form only to send the form as it would appear 
in design view, without any information in the fillable fields. 

• Select Send as a Mailable Filler to send the current form and 
have it filled out by a user who does not have flashFORM. 

• Select Include the current record to include the current record 
that you have open. This option is available only in fill view. 

5. If you are in design view or you are sending a mailable filler, proceed to step 8. 

6. If you are in fill view and not sending a mailable filler, you can also specify a 
range of records to send.  
Click Range... to open the Record Range dialog box and specify a range of 
records to send.  

                      
            
If you do not specify a range, flashFORM will send all records by default. 

7. Specify a range. 
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• Select All Records to send all records in the current database. 

• Select Current Record Set to send the current found set of 
records. This option is available after a search. 
Type the first record number to send in the From text box and 
the last record number to send in the To text box to specify a 
range of records. 

• Click OK to return to the Mail Options dialog box. 

8. Click OK in the Mail Options dialog box. 
A dialog box with your mail application program (either Lotus CC: Mail/Notes 
or Microsoft Exchange/Outlook) appears. 

9. Enter the information in your mail program’s dialog box. Refer to your mail 
program’s documentation for more information. 
The following box shows the Lotus CC: Mail application dialog box. 

 

10.  Click Send to mail your message and form as specified. 
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Adding a Routing Slip 

Microsoft Exchange/Outlook users can add a routing slip to mail. See the Microsoft 
Exchange/Outlook documentation for detailed information. 

To add a routing slip: 

1. Open or scan in the form to send. 

2. Choose Add Routing Slip... in the File menu. 
The Add Routing Slip dialog box appears. 

3. Select the recipients and other routing information. 

4. You can either send the document now or later. 

• Click Route to route the document. 

• Click Add Slip to close the dialog box without routing the form. 

Saving a Form 

This section explains how to save your form and how to use the Save As... and 
Save As Mailable Filler... commands. You can save your form in a variety of 
formats. 

To save your form: 

1.  Click the Save button or choose Save in the File menu. You can save 
your form at any time in either fill or design view. 

flashFORM saves your form in the default format: flashFORM Form. 

To save your form in various formats: 

1. Choose Save As... in the File menu. 
The Save As dialog box appears. 

2. Select an option from the Save as type drop-down list. 

• Select flashFORM Form to save to flashFORM’s default format. 

• Select flashFORM 3.0 Form to save to flashFORM’s 3.0 
version. 

• Select flashFORM 2.0 Form to save to flashFORM’s 2.0 
version. 
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• This is useful if you have users with a 16-bit Filler. You save 
your form in 2.0 so that users of the 16-bit Filler can access the 
form. However, some features available in flashFORM 5.0 may 
not be displayed or printed in the 2.0 version. 

• Select OFML 2.0 to save to FORMation mg’s flashFORM 
Markup Language (OFML), version 2.0. 

• Select OFML 1.0 to save to FORMation mg’s flashFORM 
Markup Language (OFML), version 1.0. OFML 1.0 is 
compatible to flashFORM Internet Publisher, version 2.02. 

• Select HTML to save the form to Hyper Text Markup Language 
(HTML). 

• You can see how a form looks in HTML before you convert it to 
HTML. Open a form and choose Preview in Browser... in the 
File menu. The Preview in Browser dialog box appears. Select 
a browser and click Preview. Your form appears in the selected 
browser.  

• Select PDF to save to a Portable Document Format. 

• Select Microsoft Word (RTF) to save the form in the Microsoft 
Word rich text format. 

3. Type the name of your file in the File name text box if necessary. 

4. Click Add to PageKeeper if you would like to link the saved form in 
PageKeeper’s default folder. This setting only appears if you have 
PageKeeper installed on your system. 

5. Depending on the Save as type option you have selected, do one of the 
following: 

• If you have selected flashFORM Form, flashFORM 3.0 Form, 
flashFORM 2.0 Form, OFML 2.0, or OFML 1.0, click Save and 
flashFORM saves the form to your chosen format. 

• If you have selected Microsoft Word (RTF), click Options... and 
proceed to page 45 

• If you have selected HTML, click Options... and proceed to 
page 46.  

• If you have selected PDF, click Options... and proceed to page 
47. 
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To set your options for Word conversion: 

1. Select an option under Word Version. 

       

2. Select an option under Line Retention. 

• Select None if you do not want the converter to change the text 
to fit the lines. 

• Select Size line by Scaling (Word 97 only) to change the width 
of the characters to fit the lines. 

• Select Size line by Character Spacing in order to change the 
amount of space between the characters to fit the lines. 

3. Click OK to close the dialog box. 

4. Click Save to save your form to your chosen format. 
flashFORM converts your form to the Microsoft Word format. Open the 
converted form in Microsoft Word and select Page Layout in the View menu. 
You can now modify the form’s design. To fill in the form’s fields, you must 
protect your form. To do so, first select Protect Document in the Tools menu, 
and then select Forms in the Protect Document For text box. If you decide to 
modify the protected form’s design, you must select Unprotect Document in 
the Tools menu before you can modify the form. Please refer to your Microsoft 
Word documentation for more information. 

To set your options for HTML conversion: 

1. Select an option under HTML Version.  
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• Select HTML Version 4.0 & CSS to support HTML version 4.0 
and cascading style sheets, which provide the exact placement 
of objects on a form.  

• Select HTML Version 3.2 to support HTML versions earlier 
than 4.0. 

2. In the option under Form Fields, select whether you want to add a submit 
button, a reset button, or both. 

• Select Submit Button to add a submit button to the bottom of 
your form. This will allow you to submit your form to a Web 
address after your form has been converted. To do so, first 
type the Web address in the Submission tab of the Properties 
dialog box. See “ Setting Submission Information”  on page 136 
for more information.  

• Select Reset Button to add a reset button to the bottom of your 
form. This will allow you to clear the information from the form’s 
fields after your form has been converted to HTML. 

3. If you have selected HTML Version 4.0 & CSS, select an option under Browser 
Support (Version 4.0). You can select Microsoft Internet Explorer or Netscape 
Navigator. 
You can also choose to have both browsers supported. If you select Both 
Browsers Supported the file will contain HTML for both browsers and will 
double the file size, increase download times and decrease performance. 
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4. Select Calculation and Validation Support if you want calculations, validation, 
and field formatting options to be converted. 

5. Select Convert Tables to Layers if you have tables and other objects on your 
form and you want to maintain the position of the objects. 

6. Click OK to close the dialog box.  

7. Click Save to save your form to your chosen format. 
flashFORM converts your form to HTML with your selected options. 

To set your options for PDF conversion: 

1. Select an option under the Image Compression box. 

 
    

2. Select Compress using Zip if your file is large and you want to compress it. If 
you have selected the compression option, you can also select the Convert to 
7-bit ASCII format . This option converts your compressed file back to an ASCII 
format. 

3. In the option under Form Fields, select whether you want your form’s fields 
converted and if you want to add a submit button, a reset button, or both. 

• Select Convert Fields so that you will be able to fill all the fields 
on the form after your form has been converted to a PDF. The 
form retains the field’s definition. For example, if the form’s field 
has been defined as a text field, you will be able to fill that field 
with text. Likewise, if the form’s field has been defined as a 
check box, you will be able to fill that box with a check mark. 

• Select Submit Button to add a submit button to the bottom of 
your form. This will allow you to submit your form to a Web 
address after your form has been converted. To do so, first 
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type the Web address in the Submission tab of the Properties 
dialog box. See “ Setting Submission Information”  on page 136 
for more information.  

• Select Reset Button to add a reset button to the bottom of your 
form. This will allow you to clear the information from the form’s 
fields after your form has been converted to a PDF. 

4. Click OK to close the dialog box.  

5. Click Save to save your form to your chosen format. 
flashFORM converts your form to a PDF with your selected options. 

To save as a Mailable Filler: 

The mailable filler option is a limited function filler that allows other users, who do 
not have flashFORM installed, to receive and fill out flashFORM forms. This option 

is also a limited license usage, that is, you can use it for up to 100 licenses (and 
each license can be used once for a specific form). 

1. Choose Save As Mailable Filler... in the File menu. The Save As dialog box 
appears. 

 

2. Select flashFORM Mailable Filler in the Save as type text box. 

3. Type the name of your file in the File name text box if necessary. 

4. Click Save. flashFORM saves the form as a mailable filler. You can then send 
it electronically to a user to fill out and have the user return it to you in the 
same manner. 

Publishing a Form to the Web 

flashFORM can easily publish your forms on intranets and to the Internet.  
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To publish forms to the Web you will need Microsoft’s Web Publishing Wizard 
installed on your system. If your system does not have Microsoft Web Publishing 
Wizard installed, you can obtain this Wizard by 1) installing the full application of 
Internet Explorer 4.0 and above, 2) downloading the Web Publishing Wizard from 
Microsoft’s Web site, or 3) installing the Web Publishing Wizard from the Windows 
98 installation CD if you are running Windows 98. 

To publish a form to the Web: 

1. Do one of the following: 

• Scan a paper form 
See “Scanning a Paper Form”. 

• Import an existing PCX or TIFF form file. 
See “Importing an Image File”. 

• Open an existing flashFORM (OFM) or flashFORM Markup 
Language (OFML) form. See “ Opening a Form”. 

• Create your own design. 
See “Designing a Form.”  

2. After you have your form ready to publish, choose Publish To Web... in the File 
menu. The following dialog box appears. 
 

 

3. Select whether you want to publish the current form or previously saved forms. 

• Select Publish the current form to publish the form you have 
open. 

• Select Publish previously saved forms to publish saved forms. 
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4. Click Next>.  

• If you have selected Publish the current form, proceed to step . 

• If you have selected Publish previously saved forms, enter the 
file name or folder name in the dialog box that appears and 
proceed to step 8.  

                        

• If you have entered a folder name, all files in that folder will be 
published to the Web. If you have also selected Include 
subfolders, all subfolders in that folder will be published to the 
Web. 

5. Select the type of file you would like to publish in the dialog box that appears.  

                     

You can select flashFORM Form, flashFORM 3.0, flashFORM 2.0, OFML 2.0, 
OFML 1.0, HTML, PDF or Microsoft Word (RTF).  
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• If you have chosen HTML, PDF, or Microsoft Word (RTF), click 
Options... to set specific formatting options. 

• If you have selected flashFORM Form, flashFORM 3.0, 
flashFORM 2.0, or Microsoft Word (RTF), proceed to step . 

• If you have selected OFML 2.0, OFML 1.0, HTML or PDF, click 
Next>, and proceed to step . 

6. Enter an action (that is, where your data will be sent after it is submitted) in the 
Action text box.  
It will be saved in the drop-down list for selection the next time you open this 
dialog box. 

 

• The action could point to a Common Gateway Interface (CGI) 
script on a Web server; for example: 
http://www.formationmg.com/location-bin/script.pl 
This would tell flashFORM to submit data to a script on 
FORMation mg’s Web server. 

• The action could also be an e-mail address; for example: 
mailto:name.othername@company.com 
The form data would be submitted to that e-mail address. 

7. Select a means of submitting data in the Method drop-down list.  

• Select GET to append text to the Universal Resource Locator 
(URL) specified in the Action drop-down list. 

• Select POST to notify the Web server to open the CGI 
application and pass the data to it. 

8. Click Next>. Microsoft’s Web Publishing Wizard appears. Follow all the dialog 
boxes in this wizard to publish your form to the Web. 
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The Web Toolbar 

Use the web toolbar to preview your form in a browser, to access the Publish 
Wizard, and to access the Hyperlink options. To view the web toolbar, select 
Toolbars in the View menu and then select Web  in the drop-down menu.  

 

          

 

If you would like to keep this toolbar on your desktop, see “ Customizing Toolbars”  
on for more information. See the online help for more information about each 
button in this toolbar. 

flashFORM Internet Filler 

After you publish a form to an intranet or the Internet, you can have users fill in 
your form by using flashFORM Internet Filler. The Internet Filler is an easy-to- use 
version of flashFORM that has a fill view but no design view. Therefore, Filler 
users cannot edit the form’s design in any way. 

flashFORM Internet Filler can operate within a Web browser or on its own. When it 
runs within a browser, you can hyperlink to an OFML form and fill it out online. 
When it runs on its own, you can work with OFML forms off-line.  

Installing flashFORM Internet Filler 

flashFORM Internet Filler is included on your CD-ROM. 

Close all applications — including screen savers, virus checkers, and mail 
applications — before installing flashFORM. 

To install flashFORM Internet Filler: 

1. Start Windows. 

2. Insert flashFORM’s CD-ROM in the CD-ROM drive. 

3. Click Start in the Taskbar and choose Programs4Windows Explorer (if you 
have Windows 95 or 98) or NT Explorer (if you have Windows NT). 

4. Locate InetFill on the CD-ROM. 

5. Select Oif32.exe (to install the 32-bit version) or Oif16.exe (to install the 16-bit 
version). 

6. Follow all the instructions in the dialog boxes that appear. 
flashFORM Internet Filler installs by default to the location C:\Program 

Preview in 
Browser 

Hyperlink 

Publish 
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Files\flashFORM Internet Filler. You can select another location if 
you wish. 

See “Filling a Form,” for more information about filling a form. 
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Designing a Form 

 
This chapter discusses how to design new forms and edit existing ones in 
flashFORM. flashFORM contains numerous tools in design view that let you create 
fields and objects, define calculations, and decide how your form will look. 

This chapter contains the following sections: 

• The Design Process 

• The Design View Window 

• The Design View Toolbars 

• Creating Objects on a Form 

• Defining Objects on a Form 

• Changing Object Appearance on a Form 

• Editing a Form 

The flashFORM\Sample Forms folder contains several sample forms that you 
can use or redesign for your needs.  
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The Design Process 

This section gives a brief overview of how to design a new form. A form can be as 
simple as you need or as complex as flashFORM allows. Although the steps below 
are not required, they are recommended. 

See “ Editing a Form” for information on how you can change existing forms. 

To design a new form: 

1. Choose New in the File menu to open a new, blank form. 

2. Choose Page Setup... in the File menu. 

3. Select page size, orientation, and margins, and click OK. 

4. Choose Save As... in the File menu. 

5. Assign a name and location for your form, and then click OK. 
Remember to save periodically so you do not lose any work. 

6. Use the drawing toolbar to create objects on the form. See “Creating objects on a 
Form” for more information on creating objects. 

7. Choose Object Definition... in the Format menu to define the objects that you have 
created. 
You can assign unique names, filling, and validation properties for each object. 

8. Choose Object Appearance... in the Format menu to set the new object’s appearance 
if necessary. 
You can set borders, background color, and other properties. 

9. Use the font/text toolbar to format both text objects and fillable objects. Text entered 
in fill view will take on the formatting that you specify in design view. 

10.  Drag the objects where you want them on the form and use the arrange toolbar to 
align them. 

11.  Choose Tab Order in the Tools menu to set a logical tabbing order for filling the form 
when it is in fill view. 

12.  Test your form in fill view. 

The Design View Window 

This section provides an overview of the design view window. 
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 If a form is open in fill view, click the Design button in the fill toolbar or choose 
Design in the View menu to switch to design view.  

 
To open a shortcut menu, click the right mouse button and choose Design in this 
menu. 

The design view window (after registration) contains five toolbars and seven 
menus. If you have not registered your product with FORMation mg, the window 
will have eight menus, including one for registration. 

                                           

                                              

The design view window also contains the calculation toolbar. Choose Calculation 
in the Tools menu to display this toolbar.  

Use design view to edit and create fields on an existing form or to create an 
entirely new form. 

The Design View Toolbars 

This section describes each toolbar in design view and defines its buttons. There 
are seven toolbars: 

• The design toolbar 
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• The font/text toolbar 

• The drawing toolbar 

• The arrange toolbar 

• The proofing toolbar (See “ Proofing a Form”  for information on 
this toolbar and its functions.) 

• The calculation toolbar (See “Using Calculations,” for 
information on this toolbar and its functions.) 

• The web toolbar (See “ The Web Toolbar” for more information 
about this toolbar and its functions.) 

You can drag these toolbars to any other location in the flashFORM window. The 
toolbars remain where you last positioned them, even when you close and reopen 
the program. 

You can also move the toolbars from a horizontal position to a vertical position. In 
this case, some of the icons may change. See the specific toolbars for information 
on which icons may change.  

Customizing Toolbars 

There are several ways to customize the toolbars.  

• To move toolbar buttons to other toolbars, simply drag the 
button you want (by holding down the ALT key and clicking on 
a button) to the desired location on another toolbar.  

• You can toggle the visibility of the toolbars on your desktop by 
selecting the Toolbars command in the View menu. In the 
popup menu that appears, select the toolbars that you want 
displayed on your desktop; or, deselect those that you do not 
want displayed on your desktop. 

• You can right-click on the perimeter of the main window to get 
a shortcut menu for toggling the visibility or customizing the 
toolbars.  

• You can customize the toolbars by using the Customize... 
command in the Tools menu. See the next sections “To 
customize toolbars using the Toolbars tab:” and “To customize 
toolbars using the Commands tab.” 

To customize toolbars using the Toolbars tab: 

In the Toolbars tab, you can:  
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• select and deselect the toolbars that you want  
displayed on your desktop,  

• select or deselect the Show ToolTips option, 

• create a new toolbar,  

• reset a toolbar to its original state, or  

• delete a toolbar that you have created.  

1. Choose Customize... in the Tools menu. The Customize dialog box appears. 

   

2. Click the Toolbars tab if it is not selected. 

3. Select the toolbars that you want displayed on your desktop. Deselect those 
toolbars that you do not want displayed on your desktop. 

4. If you want ToolTips to appear, select the Show ToolTips option. Likewise, if 
you do not want ToolTips to appear, make sure Show ToolTips is deselected.  

5. Click New if you want to create a new toolbar. 
The New Toolbar dialog box appears.  
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• Type the name of your new toolbar in the Toolbar name text 
box. 

• Click OK to apply your name. 
Your new toolbar appears on your desktop. If you want, you 
can drag the new toolbar to another location on your desktop. 

• To add buttons to your new toolbar, drag the buttons of other 
toolbars to your new toolbar.  

6. Click Delete if you want to delete a toolbar that you have created. Select the 
toolbar you want to delete in the Toolbars list box and then click Delete. 

7. Click Reset if you want to return a toolbar to its original state.  
For example, suppose you have created a new toolbar and have dragged 
some buttons from the design toolbar. To return the design toolbar to its 
original state with all its buttons, select the Design toolbar in the Toolbars 
window and then select Reset.  
The design toolbar will return to its original state.  

8. Click OK to close the dialog box and apply your selections. 

To customize toolbars using the Commands tab: 

In the Commands tab, you can customize the toolbars by selecting a toolbar and 
then dragging its button or buttons to another toolbar. 

1. Choose Customize... in the Tools menu. The Customize dialog box appears. 

2. Click the Commands tab in the Customize dialog box. 
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• Select a toolbar from the Categories list box. The 
corresponding buttons for that toolbar are shown in the Buttons 
box.  

• Click the button that you want and drag it to another toolbar on 
your desktop. The button now appears in the other toolbar. 

• Keep clicking and dragging buttons to another toolbar until you 
have finished customizing the toolbar.  

3. Click OK to close the dialog box and apply your selections. 

The Design Toolbar  

Use the design toolbar for basic file operations such as saving and printing. Use it 
also to define and format the fields you create.  

All buttons correspond to menu commands of the same name. Note how the Zoom 
button changes in the vertical position. Refer to the online help for an explanation 
of each button/menu command. 

 

 

 

 

 

 

The Font/Text Toolbar 

Use the font/text toolbar to format text. This toolbar is only active when a fill text, 
comb, comb element, circle text, or table cell object is selected. 

 

 

 

 

New Save Form  Print  Cut Paste Fill Highlight Object Calculation Help  
 Assistant Preview    Fill Areas Definition 

 Open Scan Print Spelling Copy Design Zoom Object  Size and Tools 
       Appearance  Position 

Zoom button in  
Vertical position 

 

 Font size  Italic Left   Justify
 Center  Grow Font  
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The drop-down lists and buttons correspond to options in the Font or Text dialog 
boxes (choose Font... or Text... in the Format menu). Note how the Font drop-
down list and Font Size drop-down list buttons change in vertical position. Each 
button displays a thumbnail example of how it formats text. 

Text entered in fill view displays the formatting that you specify in design view. 

Refer to online help for an explanation of each button/menu command. See “ 
Formatting Text” for detailed information on each formatting option. 

The Drawing Toolbar 

Use the drawing toolbar to create and select objects. See the online help for an 
explanation of each tool’s function. See “Creating Objects on a Form” for detailed 
information on using the drawing tools. 

             

 

 

The Arrange Toolbar 

Use the arrange toolbar to arrange and align objects on a form. Refer to the online 
help for a brief explanation of each button’s function. These buttons correspond to 
the Align, Bring to Front, and Send to Back  commands in the Format menu.  

The last six buttons on the toolbar are only active when multiple objects are 
selected. Each button gives a thumbnail example of how it aligns objects. 

 

                         

 

Creating Objects on a Form 

This section explains how to create objects on your form. You can create AS/400 
spool file mapping objects, fillable objects that a user fills in fill view, and non-
fillable objects such as lines and rectangles that contribute to a form’s design.  

 Text  Oval Graphic   Comb Circle Text   Fill Graphic 
     

 Selection Line Rectangle  Fill Text  Check Box Table Lock On/Off 

Bring to front Align Left Center Horizontally  
   Align Bottom 

 Send to back  Align Right Align Top 
    Center Vertically 
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This section discusses general creation guidelines and then lists all objects in the 
same order as they appear in the drawing toolbar. All instructions assume that you 
are in design view using either a new form or a designed form. 

See “Defining Objects on a Form” for information on how to define objects after 
you create them. 

See “Filling a Form,“ for detailed information on how to fill objects (fields) in fill 
view. 

General Creation Guidelines 

Use the same basic steps to create most objects. Some require more steps as 
described in the following sections. 

To create an object: 

1. Click a tool in the drawing toolbar. 

2. Click anywhere on the form to create an object of a default size, or hold down 
the mouse button and drag the tool to make the object the size that you want. 

3. While drawing, hold down the Shift key to: 

• Make a rectangular object a square. 

• Make an oval object a circle. 

• Make a horizontal, vertical, or 45-degree angle line object. 

4. With the object still selected, you can: 

• Type text if it is a text or a circle text object. 

• Choose Object Definition... in the Format menu to define the 
object. See “Defining Objects on a Form” for detailed informa-
tion. 

• Choose Object Appearance... in the Format menu to set the 
object’s appearance. See “Changing Object Appearance on a 
Form” for detailed information. 

• Hold down the Ctrl key and drag the object to copy it. 

5. Drag the object where you want it on the form. 
When the object is complete and no longer selected, the drawing tool reverts 
to the Selection tool unless the Lock On/Off is on. 
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Creating AS/400 Field Mapping Fields 

The same fields created for the “Filling a Form” operations can be used for 
dragging ‘n’ dropping AS/400 spool file data to your form. The only two field 
objects you should use for this operation are the Fill Text object and Table field 
object (primarily Fill Text). Below we will describe how to add the fields to the form, 
view the field numbers, and transfer the field file to the AS/400. See the 
flashFORM400 User’s Guide, section on “Configure Data Map” for information on 
how to link the spool data to the mapped fields. 

 

 

 

1. Select the Fill Text or Table field tool (again the Fill Text should be your 
primary choice) 

2. Drag a field box in the appropriate location on your form. 

• After drawing the field box, you can select the fill object, right 
click with your mouse and select Object Appearance to define 
properties of the field. Lines or rectangles can surround the 
field, thus no need to draw boxes or lines around fields. See 
“Defining a Fill Text Object” for information on defining fields for 
PC filling operations. 

• Once your fields are laid out on the form, you’ll need to view 
the field numbers in order to know what field number to map 
the AS/400 data to. The AS/400 spool data mapping screens 
ask for the field number for that selected portion of spool file 
data,  thus the numbers to the fields are important to you. 

3. Under Tools menu, select Tab order.  This will display the fields, field numbers 
and locations of each field. 
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• For AS/400 mapping, you should not renumber, rename, or 
reorder these fields – nor should you.  Each field has a unique 
number associated to it… that number is what we will map 
AS/400 spool data to. 

4. When a form overlay macro (*.mac) file is generated the *.fld file is saved with 
the same name and path. 

• The *fld file will be moved to the AS\400’s FORMFMG directory 
along with the form overlay macro (*.mac). When the design is 
complete. See flashFORM400 User’s Guide, “ 

When you save the form with the field boxes, flashFORM Designer automatically 
creates a field file (*.fld) in the same directory as flashFORM’s saved form (*.ofm).    
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Creating a Text Object 

A text object is most often used as a title, label, or header. 

Text object used as label    State   xxxxxxx           the State mapping field or 
fill text field 

To create a text object: 

1. Click the Text tool in the drawing toolbar. 

2. Draw the text object. 

3. With the object still selected, type the text that you want to replace the word 
Label. 

Creating a Line Object 

Use a line object to separate sections of a form or as a design element. 

To create a line object: 

1.  Click the Line tool in the drawing toolbar. 

2. Draw a line. 

 
To make sure a line is horizontal or vertical, hold down the Shift key while you draw.  

To rotate a line: 

1.  Click the Selection tool and select the line to edit. 
A handle appears on each end of the line. 

2. Place the cursor over one handle. 

3. When the cursor turns into a crosshair, hold down the mouse key and drag the 
end of the line where you want it. 
To rotate the line in 45-degree increments, hold down the Shift key while 
pulling one of the handles in the desired direction. 
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Creating an Oval Object 

Use an oval object to highlight areas on a form or as a design element. 

To create an oval object: 

1.  Click the Oval tool in the drawing toolbar. 

2. Draw an oval. 

 
To create a circle, hold down the Shift key as you draw. 

Creating a Rectangle Object 

Use a rectangle object to highlight areas on a form or as a design element. 

                      

To create a rectangle object: 

1.  Click the Rectangle tool in the drawing toolbar. 

2. Draw a rectangle. 

 
To create a square, hold down the Shift key as you draw. 

Adding Graphics to Your Form 

You can add graphics to your form by first creating a rectangular object by using 
the Graphics tool. Then copy, import, or scan graphics into this object. For 
example, use this feature when you want the same graphic (such as a company 
logo) to appear in every copy of your form. 

To copy a graphic from your original scanned form to your designed form: 

1. Scan in your form. 

2. Choose Form Image in the View menu. The screen splits to show the form 
both as it was designed with Logical Form Recognition and as it was originally 
scanned. 
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Each view window has its own scroll bar so that you can scroll to the same place in 
each form.You can use the horizontal bar in-between the two windows to resize 
the view.Your cursor turns into a resize cursor over the bar. 

3.  Click the Graphic tool in the drawing toolbar. 

4. Select the graphic that you want to copy (in the bottom window) by holding 
down the mouse button and slowly dragging the cursor across the graphic. 
Your cursor changes to a graphic tool shape in this window. 

5. Let go of the mouse button and your graphic appears in your designed form 
(the top window) in the same place as in the original form (the bottom window). 

6. The Graphic Definition dialog box automatically appears. Proceed to “ To 
define attributes of your graphic object:”  on page 68 to continue. 

To import a graphic into your form: 

1.  Click the Graphic tool in the drawing toolbar. 

2. Draw a graphic object. 

 
 To create a square graphic object, hold down the Shift key as you draw. 

The Graphic Definition dialog box appears. 

 
 
 
 
 
 
Designed form without graphic 
 
 
 
Horizontal bar 
 
 
 
Original form with graphic 
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3. Select Graphic File in the Source drop-down list. 

4. Type a file name in the File Name text box.  
Or, click Browse... if you need to locate a file. 

• Locate and select a file.  

• Click OK to return to the Graphic Definition dialog box. 
The name of the selected file appears in the File Name text 
box. 

5. Proceed to “ To define attributes of your graphic object”  to continue. 

To scan a graphic into your form: 

1.  Click the Graphic tool in the drawing toolbar. 

2. Draw a graphic object. 

 
To create a square graphic object, hold down the Shift key as you draw. 

The Graphic Definition dialog box appears 

3. Select Twain in the Source drop-down list. 

4. Proceed to the next section ” To define attributes of your graphic object:”  to 
continue. 

To define attributes of your graphic object: 

1. Select an option for the graphic. 

• Select Maintain Original Size to import the graphic exactly as it 
is. 

 

• Select Scale Proportionally to fit the graphic in the fill graphic 
field while maintaining its exact proportions. 
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• Select Stretch to Fit to change your graphic’s original shape 
and size to fit in the fill graphic field. 

 

• This option does not maintain a graphic’s original proportions. 
Depending on the shape of the fill graphic field, your graphic 
may be stretched or compressed. You might want to use this 
for special effects. 

• Select Just Change the Options for this Graphic if the graphic 
object already contains a graphic. This changes how the 
graphic appears without reimporting it. 

• Select Store a Copy of the Graphic with the Form to place a 
copy of the graphic directly in the form. This increases form 
size depending on graphic file size. Otherwise, flashFORM 
loads the graphic each time you open the form. If you move the 
original graphic, flashFORM cannot load it and it will not appear 
in the form until you reimport it. This option only appears if 
Graphic File is selected in the Source drop-down list. 

2. Click OK. flashFORM scans or loads the graphic, depending on the selected 
source. The graphic appears in the Graphic object box. 

Creating a Fill Text Object 

Use a fill text field wherever you want to enter text in fill view. Fill text fields are 
commonly used for information such as name, company, address, comments, and 
so forth. 

To create a fill text object: 
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1.  Click the Fill Text tool in the drawing toolbar. 

2. Draw the fill text object. 

 
To create a square field, hold down the Shift key as you draw. 

Creating a Comb Object 

Use a comb field to separate information into separate groups of elements while 
maintaining the field as a whole. This object is used for PC fill applications only. 
For example, forms used in the United States typically require that you enter zip 
code numbers in five or nine separate boxes. 

To create a comb object: 

1.  Click the Comb tool in the drawing toolbar. 

2. Either click anywhere on the form to create a four-element comb field, or move 
the cursor to anyplace on the form and hold down the mouse button as you 
slowly drag the cursor. 
The number of elements in the comb field increases as you drag the mouse. 
Let go of the mouse button when the comb field contains the number of 
elements that you want. 

                              

Many sample forms included with your flashFORM package, such as the Objects 
form, contain comb objects that you can copy and paste into your own form. 

Creating a Check Box Object 

Use check boxes for Yes/No questions and for selecting one or more choices on a 
form.  This object is used for PC based fill applications only. 

 

To create a check box object: 

1.  Click the Check Box tool in the drawing toolbar. 
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2. Draw a check box. 

 
To create a square check box, hold down the Shift key as you draw. 

Creating a Circle Text Object 

Use circle text objects for Yes/No questions and for selecting one or more choices 
on a form. This object is used for PC fill applications only. 

To create a circle text object: 

1.  Click the Circle Text tool in the drawing toolbar. 

2. Draw a circle text object. 

 To create a circle instead of an oval, hold down the Shift key as you draw. 

3. With the object still selected, type the text that you want to replace the number 
in the object. 

                             

Creating a Table Object 

Use a table to enter information for order forms, invoices, comparison charts, 
purchase orders, and so forth.  This object is used for PC fill applications only. 

A table consists of cells. Each cell contains a fill text object by default, with the 
exception of the header. The header cells contain text objects by default. 

You can convert these objects to any other kind of object. You can insert any 
object in a table cell. Cells can contain multiple objects. 

See “ Formatting a Table”, “ Placing Objects in Table Cells”, and “ Breaking a 
Table Apart” for more information on tables. 

To create a table object: 

1.  Click the Table tool in the drawing toolbar. 

2. Either click anywhere on the form to create a table, or move the cursor to 
anyplace on the form and hold down the mouse button as you slowly drag the 
cursor. 
The number of rows and columns in the comb field increase as you drag the 
mouse. Let go of the mouse button when the table contains the number of 
rows and columns that you want. 
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To create a square table, hold down the Shift key as you draw. 

Creating a Fill Graphic Object 

Use a fill graphic object to allow the person who fills in the form to add a graphic.  
This object is used for PC fill applications. For example, suppose you have 
designed a real estate form that requires a picture of the property. You place a fill 
graphic object on the form so that the person who fills in the form can add the 
picture of the property. If, instead, you want to add a graphic to the form, see “ 
Adding Graphics to Your Form”. 

To create a fill graphic object: 

1.  Click the Fill Graphic tool in the drawing toolbar. 

2. Draw the fill graphic object. 

 
To create a square, hold down the Shift key as you draw. 

Defining Objects on a Form 

This section describes the options in the Object Definition command and how they 
affect a selected object. The dialog box that appears varies according to the 
selected object and form language. Each definable object is described in this 
section in the order it appears in the drawing toolbar. 

When you define an object you can: 

• Give it a unique name that is useful when sorting or searching 
records, arranging tab order, or defining calculations. 

• Provide filling options such as a list of possible entries and help 
messages that appear in fill view. 
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• Set validation options such as whether a field must be filled or 
can be skipped. 

See the previous section, “Creating Objects on a Form” to learn how to create 
objects. See “International Settings” for information on selecting a form language. 

1. To define an object: 

2. Select a fillable object on your form, a fillable object in a table cell, or a comb 
element in design view. 
You cannot define nonfillable objects such as lines. 

3.  Click the Object Definition button in the design toolbar or choose Object 
Definition... in the Format menu. 

 
To open a shortcut menu, click the right mouse button over the selected object. 
Choose Object Definition... in this menu. 

The dialog box that appears varies depending on the selected object. See the 
following sections for descriptions of the definition options available for each type 
of fillable object in a form. 

Defining a Graphic Object 

Click the Object Definition button in the design toolbar (or choose Object 
Definition... in the Format menu) to open the Graphic Definition Dialog box when a 
graphic object is selected. This dialog box lets you select how you want the 
graphic object to appear in the fill graphic field. See “ Adding Graphics to Your 
Form” 66 for detailed information. 

Defining a Fill Text Object 

Click the Object Definition button in the design toolbar (or choose Object 
Definition... in the Format menu) to open the Fill Text Definition dialog box when a 
fill text object is selected. This dialog box allows you to set property, filling, and 
validation options. The properties tab allows you to: 

• Provide a name for your field. 

• Select a field type. 

• Select a data format and define the format further. 

To set property options for fill text objects: 

1. Click the Properties tab. 
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2. Type a unique name in the Name text box. 
Each object must have a unique name. A descriptive name such as Address 
makes a field easy to find when sorting, searching, defining calculations, and 
so forth. 

3. Select a field type in the Type drop-down list. 
The field type will be displayed in the status bar in fill view when the cursor is 
in that field. This information helps the user know what kind of entry is 
expected in each field. Field type also helps flashFORM match data when 
sorting records and when importing and exporting information. 
If you select Serial Numbers or Signature as a field type, please see the 
sections “ Setting Serial Numbers” or “Adding Security to Your Forms”.  

4. Select a display format in the Format drop-down list. 
The format you select affects how field information is displayed in fill view. 
Options vary according to the Type selection. 

• If you select Currency as the Type, for example, you might 
select $0.00 as the format. If you enter 7889 in the field, 
flashFORM would format the entry as $7889.00. Formatting 
takes effect in fill view after you move the cursor out of the 
field. 

• A General format leaves the field entry exactly as it is entered. 
In the previous example, 7889 entered in the field would be 
displayed as 7889. 

• Field type also affects field validation. You can require that the 
field entry match the field type. See “ To set validation options 
for fill text objects”for more information. 
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5. The next two options are enabled when Number, Currency, or Percentage is 
selected in the Type drop-down list. 

• Select Use 1000’s Separator to separate a series of three digits 
with a separator specific to the form’s language. 
See “ International Settings” for detailed information on 
selecting a language for a form. 

• Select Enclose Negatives in Parentheses to display negative 
numbers within parentheses in the field; for example, -123 
would display as (123). 

To set filling options for fill text objects: 

1. Click the Filling tab. 

  

The Filling tab lets you: 

• Enable the AutoFill Wizard to set up automated data entry.  

• Designate whether a field can be filled. 

• Set tab stops to allow the user to automatically move to the 
next field. 

• Set the length of the allowable characters in a field. 

• Enter help messages that will appear in the status bar in fill 
view. 

2. Deselect or select Enable AutoFill. See “Setting up a Form for Automated Data 
Entry” for more information. 

3. Deselect or select Can be Filled. 
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• If you deselect Can be Filled, then an empty field cannot be 
filled and a filled field cannot be changed in fill view. This option 
is particularly useful for fields such as calculations where you 
do not want the person who fills out the form to be able to 
change it.  

• If you select Can be Filled, then an empty field can be filled and 
a filled field can be changed in fill view. 

 
The Can be Filled option, when deselected, overrides the Must be Filled in option 
when it is selected in the Validation tab. 

4. You can either select or deselect the Tab Stop.  

• Select Tab Stop so that the cursor automatically moves to the 
selected field when the user presses the Tab key. 

• Deselect Tab Stop so that the cursor tabs past the selected 
field. 

5. Select a Maximum Length option from the drop-down list. This option lets you 
set the length of allowable characters in a field. You can set the length from 5 
to 100, or select Unlimited. 

6. Select Help Message and type a message in the field box if you wish. This 
message will appear in the status bar in fill view when the cursor is in that field. 
A help message can be up to 100 characters long. 

To set validation options for fill text objects: 

1. Click the Validation tab. 
The validation option allows you to: 

• Select whether a field must be filled in.  

• Select whether the data must match the field type.  

• Select whether the data must be in the list of choices. 

• Select the highest and lowest number to specify the highest 
and lowest number that a user can enter.  
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2. Select Must be Filled in to display a prompt in fill view if the user does not fill 
the field. 

 
The Can be Filled option in the Filling tab, when deselected, overrides the Must be 
Filled in option when it is selected. 

3. Select Data Must Match Field Type to display a prompt in fill view if the user 
enters incorrect information in the field. 
If the selected field type is Number, for example, the user cannot enter text in 
the field; 5 is acceptable but five is not. 

4. Select Data Must be in List of Choices to force the user to enter a choice from 
the field’s drop-down list. (Use the Filling tab to create a List of Choices.) 

5. Select the options under Number Checking to set parameters for lowest and 
highest allowable numbers in a field.  
flashFORM displays a prompt in fill view if a user enters numbers outside the 
set range. 
Number Checking is enabled when Number, Currency, or Percentage is the 
selected type in the Properties tab. 

• Select Lowest Number and enter a number in the text box. 
Numbers entered in the selected field must be equal to or 
greater than this number. 

• Select Highest Number and enter a number in the text box. 
Numbers entered in the selected field in fill view must be equal 
to or lesser than this number. 

6. Select or deselect Allow user to override validation. If you deselect this option 
then you force the user to enter data in the selected field. Otherwise, users can 
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choose to override the warning that appears if they enter either no or 
inappropriate information in a field (such as five instead of 5 in a Number field). 

7. Click OK to apply the changes and close the dialog box. 

Defining a Comb Object 

Choose Object Definition... in the Format menu to open the Comb Definition dialog 
box when a comb object is selected. 

 

This dialog box contains most of the same options as the Fill Text Definition dialog 
box, but with these additions: 

• It contains an Interpret As drop-down list in the Properties tab 
instead of a Format drop-down list. 

• It contains an Elements section in the Properties tab. 

• It contains a Fill Right to Left option in the Filling tab. 

These options are described in this section. See “ Defining a Fill Text Object” for 
detailed information on the other options. 

Interpret As drop-down list 

The Interpret As selection determines the way information entered in the comb 
field will be used when searching, sorting, importing, and exporting. Available 
options vary according to the Type selection. 

For example, suppose you select Number in the Type drop-down list and 0.00 in 
the Interpret As drop-down list. If you enter 1234 in the field in fill view, flashFORM 
would interpret this number as 12.34 even if the comb did not contain a decimal 
point as a prefill element. A search for 12.34 would return this record. 



Forms Design User’s Guide 
Designing a Form 

84   flashFORM Designer User’s Guide 

A specific Interpret As setting is not necessary when you define the correct prefill 
elements in a comb object, such as a decimal point. flashFORM would know the 
entry in this case is a decimal number even if you select the General option in the 
Interpret As drop-down list. 
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Element Options 

You have three element options: number of elements, width of elements, and inter-
element spacing. 

To set the Element options: 

1. Click the Properties tab. 

2. Type a number in the Number of Elements text box. 
A zip code field for the United States, for example, would have either five or 
nine elements. 

3. Type a number in the Width of Elements text box to set how wide all comb 
elements will be. 
You can resize individual elements later if you want to change their width. 

4. Type a number in the Inter-Element Spacing text box to set the amount of 
space between each comb element. 
You can resize individual elements later if you want to change inter- element 
spacing. 

Fill Right to Left Option 

The Fill Right to Left option allows you to designate whether you want the user to 
fill the comb elements from right to left. 

To set the Fill Right to Left option: 

1. Click the Filling tab. 

2. Select Fill Right to Left if you want the first character in the comb field to 
appear in the rightmost element and move left as other characters are added. 
You would still read this entry from left to right.  
This is useful for entering decimal numbers, such as percentage and currency 
amounts, in fields with a prefill decimal point element. When entering $598.07 
in a field, for example, 07 would always appear after the decimal point. This 
would not always happen if the numbers were entered from left to right. 

3. Click OK to apply the changes and close the dialog box. 

See “Defining a Comb Element Object” in the next section for information on prefill 
elements. 

Defining a Comb Element Object 

Choose Object Definition... in the Format menu to open the Comb Element 
Definition dialog box when a comb element is selected. 

This dialog box allows you to:  
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• Designate the border height of the element. 

• Create a prefill element. 

• Enter a number to designate the amount of allowable numbers 
for each element. 

 

To define a comb element: 

1. Select left and right border measurements under Border Height. 
This sets the left and right border height of each element. You might, for 
example, select 1/2 to use the popular half-border height often seen on forms. 
See “ Changing Object Appearance on a Form” for more information. 

                        

2. Select Prefill element to place a hyphen (the default character) or other 
characters, such as a period, comma, or parenthesis in the selected element. 
You will need to delete the hyphen and type the character that you want. 
This is useful for phone numbers and other hyphenated numbers. You can 
select this element in design view and change it to another character such as a 
parenthesis. 

3. Type a number in the Length text box. 
This tells flashFORM how many characters to allow in the selected element 
before moving to the next element. In some countries, for example, the length 
of the area code element in a phone number is 3. 

4. Click OK to apply the changes. 
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Defining a Check Box Object 

Choose Object Definition... in the Format menu to open the Check Box Definition 
dialog box when a check box object is selected. 

This dialog box allows you to set property, filling, and validation options for your 
selected check box. 

To set property options for check boxes: 

1. Click the Properties tab. 

 

2. Type a unique name in the Name text box. 
Each object must have a unique name. A descriptive name such as Yes Check 
Box makes a field easy to find when sorting, searching, defining calculations, 
and so forth. 

3. Type a group name in the Option Group drop-down list if the check box 
belongs to an option group. 
Creating an option group restricts you to one selection per check box group. 
Selecting a check box in an option group automatically deselects any checked 
box in the same group. 
The group name you enter automatically appears in the Option Group drop-
down list of the next check box you create. Select this name to include the 
check box in the group. 

4. Select or enter an option in the On-Value drop-down list. 
The on-value is stored in the database when the check box is selected. It is 
exported along with other information during export. It can also be used in 
calculations. Grouped check boxes must have unique on- values. You can let 
flashFORM create a unique on-value for each new check box added to a 
group. 

5. Select or enter an option in the Off-Value drop-down list. 
The off-value is stored in the database when the check box is deselected. It is 
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exported along with other information during export. It can also be used in 
calculations. This option is not available for grouped check boxes. 

To set filling options for check boxes: 

1. Click the Filling tab. 

2. Select a mark for the check box: a check mark, an X, or a fill. 

3. Deselect Can be Filled so an empty field cannot be filled and a filled field 
cannot be changed in fill view. 

4. Select Tab Stop so that the cursor automatically moves to the selected field 
when the user presses the Tab key. 
Deselect Tab Stop so that the cursor tabs past the selected field. 

5. Select Help Message to type a message that appears in the status bar in fill 
view when the cursor is in that field. 

6. Click OK to apply the changes and close the dialog box. 

To set validation options for check boxes: 

1. Click the Validation tab. 

2. Select Must be Filled in to require that the user fill in the check box. 

3. Select or deselect Allow user to override validation. If you deselect this option 
then you force the user to enter data in the selected field.  
Otherwise, users can choose to override the warning that appears if they enter 
either no or inappropriate information in a field (such as five instead of 5 in a 
Number field). 

Defining a Circle Text Object 

Choose Object Definition... in the Format menu to open the Circle Text Definition 
dialog box when a fill circle object is selected. 
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This dialog box has the same options as the Check Box Definition dialog box. See 
“ Defining a Check Box Object” for information. 

Defining a Table Object 

Choose Object Definition... in the Format menu to open the Table Definition dialog 
box when a table object is selected. This dialog box lets you: 

• Set tabbing properties so that you can tab either from left to 
right or top to bottom. 

• Select the amount and width of columns. 

• Select the amount and height of rows. 

To define a table object: 

1. Define the table object. Click the Properties tab and type a unique name in the 
Name text box. 

 

Each table object must have a unique name. A descriptive name such as Order 
Information makes a field easy to find when sorting, searching, changing tab order, 
and so forth. 

2. Select the Tabbing option that you want: Left to Right or Top to Bottom. Click 
OK to apply the option.  

3. in the Number of Columns text box. 

4. Set column width: 

• Type the column width in the Width of Columns text box. 

• If you have unequal column widths and would like them to be 
the same width, select Make Columns Equal Width. 
flashFORM resizes columns to an equal width without 
changing table size. If you had two columns, one four 
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centimeters wide and the other two centimeters wide, for 
example, each would be resized to three centimeters wide. 

5. Click OK to apply the option. 

6. Click the Rows  tab. Type the number of rows that you want in the table in the 
Number of Rows  text box. 

7. Set row height: Type the row height in the Height of Rows text box. If you have 
unequal row height and would like all the rows to be the same height, then 
select Make Rows Equal Height. flashFORM resizes rows to an equal height 
without changing table size. If you had two rows, one four centimeters high 
and the other two centimeters high, for example, each would be resized to 
three centimeters high. 

8. Click OK to apply the option. 

Defining a Table Cell 

A table cell contains a fill text object by default. See “Defining a Fill Text Object”  
for more information. See any relevant entry in ” Defining Objects on a Form” if the 
table cell contains another type of object. 

A table cell can contain more than one object. It can also contain graphics. See 
“Placing Objects in Table Cells” for information. 

Defining a Fill Graphic Object 

1. Choose Object Definition... in the Format menu to open the Fill Graphic Definition 
dialog box when a fill graphic object is selected. 

2. Type a unique name in the Name text box. 

 

3. Each graphic object must have a unique name. A descriptive name such as Logo 
makes a fill graphic field easy to find when importing, exporting, and changing tab 
order. 

4. You can either select or deselect the Tab Stop. Select Tab Stop so that the cursor 
automatically moves to the selected field when the user presses the Tab key. 
Deselect Tab Stop so that the cursor tabs past the selected field. 
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5. Select Help Message and type a message in the text box. This message will appear 
in the status bar in fill view when the cursor is in that field. 

6. Click OK to apply the changes. 

Setting Serial Numbers 

You can keep track of your form by using serial numbers. You can set serial 
numbers for fill text objects and comb objects. You define serial numbers in design 
view and they appear in fill view. As a new record is created in fill view, serial 
numbers will automatically change by the increment you have entered. You can 
also use serial numbers in calculations. If you save your form to an older version of 
flashFORM, the serial number fields will convert to a General field type and 
General format. 

To set serial numbers: 

1. Select either a fill text object or a comb object on your form. 

2. Choose Object Definition... in the Format menu. Or, click the Object Definition 
button in the design toolbar. 
If you have selected a fill text object, the Fill Text Definition dialog box 
appears.  
If you have selected a comb object, the Comb Definition dialog box appears.  

3. Select Serial Number in the Type drop-down list. 

4. Click Settings.... 
The Serial Number Settings dialog box appears. 

 

5. In the Serial Number Settings dialog box: 

• Enter a starting number in the Start at text box. You can enter 
any number from -99,999,999 to 999,999,999. The default is 1. 

• Enter an increment number in the Increment by text box. You 
can enter any number from -999 to 9,999. The default is 1. 

• Type a prefix, if you want, in the Prefix text box. You can enter 
up to 8 characters. 
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• Type a suffix, if you want, in the Suffix text box. You can enter 
up to 8 characters. 
The sample text box displays your first serial number, 
including, if applicable, a prefix and suffix.  

6. Click OK in the Serial Number Settings dialog box to apply your settings. 

7. Click OK in the Fill Text Definition dialog box to close the dialog box.  

Changing Object Appearance on a Form 

This section describes the options in the Object Appearance dialog box and how 
they affect a selected object. See the section “ Creating Objects on a Form” to 
learn how to create objects. 

To change object appearance: 

1. Select an object or objects in design view. 

2.  Click the Object Appearance button in the design toolbar or choose 
Object Appearance... in the Format menu. 

 
To open a shortcut menu, click the right mouse button over the selected object. 
Choose Object Appearance... in this menu. 

3. Click each of the four tabs in the Object Appearance dialog box to change the 
background, border, fill lines, and visible options. Available options depend on 
the selected object. 

Background options 

There are four options that affect the background of your form. These are Color, 
Pattern, Pattern Color, and Clear. 
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Color  

For background color of the object, select a color from the Color drop-down 
palette. 

 

For custom colors, click More Colors.... The Color dialog box appears. To 
customize a color, enter a number from 0 to 255 in the text boxes (Hue, Sat, Lum, 
Red, Green, and Blue). Or, drag the crosshair across the Color box.  

See “ Adding Color to your form”  for more information about the Color dialog box 
and how to add color to a form’s background. 

As long as your program is open, you can store up to eight custom colors in your 
Color drop-down palette. Each time you choose a custom color and click OK, the 
new custom color is stored in the area below the 40-color drop-down palette. This 
makes it easy to use a variety of custom colors in your form.  

You can also change the colors of your object. See “ Adjusting Colors” for more 
information. 
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Pattern  

For background pattern of the object, select a pattern from the Pattern drop- down 
list. 

 

Gradient 

You can select from Gradient (Horizontal) and Gradient (Vertical). 

• Select Gradient (Horizontal) to have the background color 
gradually change to the pattern color, from top to bottom. 

• Select Gradient (Vertical) to have the background color 
gradually change to the pattern color, from left to right. 

Pattern Color  

For a color for the background pattern, select a pattern color from the Pattern 
Color drop-down list. 

Clear 

Make sure that Clear is deselected so that your selected colors and pattern appear 
as the object’s background. 

See “ Paint Order” for a description of how paint order affects color and pattern 
display Border Options 

Border options affect the sides of your object. There are six Border options: Color, 
Style, Weight, Clear, Borders, and Shadow. 
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Color 

For a border color, select a color in the Color drop-down palette. See “Color” for 
more information about how to choose color. 

Style 

To change a line style, select Style from the drop-down list. You can select from 
one continuous line to a variety of dotted line styles. 

Weight 

To change the border thickness, select Weight from the drop-down list. You can 
select from a 1- to 12-point thickness. 

Clear 

Select Clear to hide the border and flashFORM will display any paint layers 
beneath it. 

See“ Paint Order” for an explanation of how paint order affects border display. 

Borders 

The Borders section lets you remove borders from your object. The rectangle in 
the Borders section represents your object. With your object selected, click each 
side of the Borders rectangle that you want to remove. 
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• To round the corners of the border, select Rounded. 

• To round or square individual corners, click the corners of the 
rectangle after selecting Rounded. 

• To indicate the degree of border curve, enter a measurement 
from 0 to 14 in the Rounded text box. 

Shadows 

For a shadow effect, select an option in the Location drop-down list in the Shadow 
section. To offset the shadow from the border, select the amount of points in the 
Offset drop-down list. 

Fill Line Options 

Fill Line options affect fill lines inside an object. There are four Fill line options: 
Color, Style, Weight, Clear, and Start Fill Line at First Line Indentation. 

Options in this tab are only active for selected fill text objects. Text alignment must 
be set to Top or Exactly in the Text dialog box before fill lines can be set. See “ 
Formatting Text” for information.  

 

 

Fill lines appear inside the object much like lines appear on writing paper. 
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Color 

Select a color for the fill lines in the Color drop-down palette. See “ Color” for more 
information about how to choose color. 

Style 

Select a line style in the Style drop-down list. See “Style” for more information. 

Weight 

Select line thickness in the Weight drop-down list. See “ Weight” for more 
information. 

Clear 

Deselect Clear to display the fill lines. 

See “ Paint Order” for information on how paint order affects fill line display. 

Start Fill Line at First Line Indentation 

Select Start Fill Line at First Line Indentation to indent the first fill line the same 
amount as the first line of text entered in the field. 

See “ To format the placement of text objects” for more information. 

Visible Options 

Visible options pertain to how you want the selected object to appear to the user. 
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Display 

• Select how you want the selected object to appear to the user. 

• Select Always if you want the field/object to always appear on 
screen and when printed. 

• Select Never if you do not want the field/object to appear in fill 
view. However as the designer of the form, you can see the 
object in design view. 

• Select Print Only if you want the field/object to appear on the 
printed form, but not on the screen. 

• Select Screen Only when you want the field/object to appear 
on the screen, but not when printed. 

Paint Order 

flashFORM uses a specific paint order. For example, a table object itself is painted 
first, then the cells inside the table, and then objects inside the cell. This makes it 
possible to have three layers of paint. The last layer painted in an object overrides 
all other layers. Because objects inside a cell are painted last, they will cover up 
the cells and portions of the table. 

If an object’s background or border is Clear, however, then that part of the object is 
transparent and an object painted below can show through. You can use the Send 
to Back and Bring to Front commands in the Format menu to change paint order. 
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Adding Color to a Form 

You can add color to the background of your form. You can add it to one page or 
to all pages of your form.  

You can also add color to an object on your form. For information about adding 
color to an object, see “ Changing Object Appearance on a Form” . 

You can adjust the color of the background of your form, the selected objects, or 
the background of your form. 

To add background color to your form: 

1.  Open a form in design view. 

2. Choose Page Setup... from the File menu. 
The Page Setup dialog box appears. 

 

3. Select the color you want from the Color drop-down palette. 

 

4. Click More Colors... to customize colors.  
The following Color dialog box appears. 
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5. Customize a color and click OK.  

6. To customize a color, enter a number in the boxes; or, drag the crosshair 
across the Color box. 

• Hue is the color itself. Enter a number from 0-225 in the Hue 
box, or drag the crosshair horizontally in the Color box. 

• Saturation is the intensity of the color. The higher the number, 
the more intense the color. Enter a number from 0-255 in the 
Sat box, or drag the crosshair vertically in the Color box.  

• Luminance is the brightness of the color, or the amount of 
black or white added to the color. The larger the number, the 
lighter the color. Enter a number from 0 to 255 in the Lum box, 
or drag the slider on the vertical Color bar. 

• In the Red text box, enter a number from 0 to 255 to adjust the 
amount of red in the color. The larger the number, the more red 
the color contains. 

• In the Green text box, enter a number from 0 to 255 to adjust 
the amount of green in the color. The larger the number, the 
more green the color contains. 

• In the Blue text box, enter a number from 0 to 255 to adjust the 
amount of blue in the color. The larger the number, the more 
blue the color contains. 

The smaller window in the bottom right corner will display your current color 
(bottom), which is the existing background color of your form, and new color (top), 
which is the color you have selected in this dialog box.  

7. Select an option in the Apply to drop-down list of the Page Setup dialog box. 
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• Select Current page only to apply the color changes to the 
current page of your form. 

• Select Current page forward to apply the color changes to the 
current page of your form and all subsequent pages. 

• Select All pages to apply the color changes to all the pages of 
your form. 

As long as your program is open, you can store up to eight custom colors in your 
Color drop-down palette. Each time you choose a custom color and click OK, the 
new custom color is stored in the area below the 40-color drop-down palette. This 
makes it easy to use a variety of custom colors in your form. 

8. Click OK to apply your changes and close the dialog box. 

See “Paint Order” for a description of how paint order affects color and pattern 
display. 

Adjusting Colors 

You can change the existing colors on your form to new colors. You can change 
the background color as well as the color of selected objects.  

To adjust the colors: 

1. Choose Adjust Colors... in the Format menu. 
The Adjust Colors dialog box appears. 

2. Select whether you want to change the background color of the current page, 
the selected objects on the form, or the background color of all the pages of 
the form. 

3. Select a color from the drop-down color palette. For more information about 
the drop-down color palette, see the previous section. 

4. Click OK to apply your changes and close the dialog box. 

Editing a Form 

This section describes how to edit a form using the design view tools and 
commands. Once you have created objects, you may want to move, resize, or 
convert them. You may also want to make changes to a newly scanned or 
imported form. 

This section contains the following topics: 
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• Selecting an Object 

• Moving an Object 

• Resizing an Object 

• Deleting an Object 

• Formatting Text 

• Merging Text 

• Formatting a Table 

• Breaking a Table Apart 

• Aligning Objects on a Form 

• Sending Objects Front or Back 

• Changing Tab Order on a Form 

• Placing Objects in Table Cells 

• Converting an Object to Another Type of Object 

Selecting an Object 

You can select one or more objects in several ways. 

• Click an object to select it. 

• Shift-click to select multiple objects. 

• Click an object such as a table once to select it, and then click 
again to select an individual table cell. Do the same to select 
an individual comb element. 

• Hold down the mouse button and drag the cursor around or 
through all objects to select them. 

• Choose Select All in the Edit menu to select all objects on a 
form. 

• Choose Select Special... in the Edit menu to select all objects 
of the same type. 
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Moving an Object 

You can move a selected object or objects in several ways. 

• Hold down the mouse button and drag the selected object to 
another location. 

• Choose Size and Position... in the Format menu to position the 
selected object precisely on the form. 

• Use the Align commands in the Format menu or the 
corresponding button in the arrange toolbar to align selected 
objects. 

• Use the Bring to Front and Bring to Back commands in the 
Format menu or the corresponding buttons in the arrange 
toolbar to layer overlapping objects. 

• Hold down the Shift Key and drag a line handle to rotate it in 
45-degree increments. 

• Use the nudge/arrow keys to move the object(s). 

Resizing an Object 

You can resize a selected object in the following ways. 

• Click any handle on the selected object, hold down the mouse 
button and resize the object as needed. 

• Hold down the Shift key before clicking a handle to: 
Constrain an oval or a fill circle object to a circle shape. 
Keep a line object straight. 
Constrain any other object to a square shape. 

• Or, choose Size and Position... in the Format menu to enter 
exact measurements for an object’s size. 
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Deleting an Object 

Choose Delete in the Edit menu or press Delete on your keyboard to delete one or 
more selected objects. 

Formatting Text 

Use the Font... and Text... commands in the Format menu or the corresponding 
buttons in the font/text toolbar to format text in selected objects. See “The 
Font/Text Toolbar” for information about each button in the toolbar. 

To format fonts: 

1. Select the text/fill objects that you want to format. Text entered in fill view takes 
on formatting assigned to fill objects in design view. 

2. Choose Font... in the Format menu. 
The Font dialog box appears. 

 

3. Select a font in the Font list. 

4. Select a style for the selected font in the Font style list. 

5. Select a point size for the selected font in the Size list. 

6. You can also select three options in the Effects box. 

• To place a line through all characters, select Strikeout. 

• To underline all characters, select Underline. 

• To choose the color of the text, select a color in the Color drop-
down palette. For more information about the Color drop-down 
palette and custom colors, see “ Adding Color to a Form”. 
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A preview of your choices appears in the Sample box. 

7. Click OK to apply the formatting. 

To format the placement of text objects: 

1. Select the text/fill objects that you want to format. 
Text entered in fill view takes on formatting assigned to fill objects in design 
view. 

2. Choose Text... in the Format menu. 
The Text dialog box appears. 

 

3. Click the Alignment tab.  

4. Select a horizontal alignment option: Left, Center, Right, or Justify. 

5. Select a vertical alignment option: Top, Center, Bottom, or Exactly. 

6. Click the Spacing tab and select a line-spacing option: Single, 1.5 Lines, 
Double, or Exactly. 
You can change the vertical spacing between paragraph lines. Vertical spacing 
is dependent on selected font size. A single-spaced paragraph with 12-point 
text, for example, would have 12 points between each line in the paragraph. 

7. If you want to indent the first line of each paragraph, type a measurement in 
the Paragraph Indentation text box. 

8. Click the Margins tab and enter margin measurements in the Left, Right, Top, 
and Bottom text boxes. 
This measurement is the amount a paragraph will be offset within its bounding 
box. You may want to use margins if you have field borders that would 
interfere with reading the text. 
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9. Click the Text Flow tab and select how you want text to flow within the set 
margins of a field. 
This option is available only for text and circle text objects. 

• Select Flow Text Across Lines to enter text in a field with 
automatic word-wrapping. 

                               

• Select Make Text Fit to Lines to fit text to the size of the line. 
This can alter the appearance of text. 

                                

Press Enter to create a new line of text. Each new line can be resized separately 
from other lines. 

 
flashFORM uses the Make Text Fit to Lines option to design forms during scanning 
and importing. Generally, you would want to use the Flow Text Across Lines option 
when formatting your text and circle text objects. 

• In the Orientation box, select how you want the text positioned: 
Select the first box to position the text from left to right. 
Select the middle box to position the text from bottom to top. 
Select the last box to position the text from top to bottom. 

10.  Click OK to apply the changes. 

Merging Text 

You can merge text objects by choosing Merge Text in the Format menu. This 
option is useful if you want to combine text from different locations on your form. 

To merge text: 

1. Shift-click each text object that you want to combine.  

2. Choose Merge Text in the Format menu. 
Your selected text merges. The merged text will acquire the attributes of the 
top-left selected text (except for the font type and size). 

Each line can be selected separately 
and resized.  
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Formatting a Table 

Use the Table AutoFormat... command in the Format menu to format a selected 
table.  

To format a table: 

1. Select a table. 

2. Choose Table AutoFormat... in the Format menu. 
The Table AutoFormat dialog box appears. 

3. Select the Yes option to enable the Appearance list box. 

4. Select an appearance option for your table. 

 

5. Click Next> if it is available to open the Naming window. 
Depending on your appearance selection, the Naming window may not be 
available. In that case, click Finish. 

6. Select Yes, change the column names if it is available and you want to change 
the column names. 

• Select a column name, click Rename, and type in a new name. 

• Repeat these steps for each column name to change. 

7. Select Yes, change the row names if it is available and you want to change the 
row names. 

• Select a row name, click Rename, and type in a new name. 

• Repeat these steps for each row name to change. 
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8. Click Finish to apply the changes to your table. 

See “Placing Objects in Table Cells” for additional information on tables. 

Breaking a Table Apart 

Use Break Table Apart in the Format menu to break a selected table in sections. 
This option is useful if you need to rearrange the elements of your table. 

 
You cannot regroup the objects once you break them apart. For this reason, you 
might want to save your table before you break it apart; and if you do not like what 
you have created, you can always revert to the saved copy. 

To break a table apart: 

1. Select a table in your form. 

2. Choose Break Table Apart in the Format menu. 
You can now select and drag sections of your table to rearrange in the order 
that you want.  

Aligning Objects on a Form 

Use the Align commands in the Format menu or the corresponding buttons in the 
arrange toolbar to move and align multiple selected objects. See “ The Drawing 
Toolbar”  for information about each button in the toolbar. 

Each selected object aligns to the edge of its bounding box, the imaginary box that 
surrounds all objects. A bounding box appears when you select an object and hold 
down the mouse button. Objects align to the outermost selected object. 

 

To align objects: 

1. Select the objects to align.  

2. Choose Align in the Format menu and an alignment command in its cascading 
menu, or click the appropriate button in the align toolbar. 

• Select Left to align all selected objects by their left edges. 
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• Select Right to align all selected objects by their right edges.  

• Select Center Horizontally to align the selected objects by their 
horizontal centers. 

 

• Select Top to align all selected objects by their top edges. 

• Select Bottom to align all selected objects by their bottom 
edges.  

• Select Center Vertically to align the selected objects by their 
vertical center. 

 

The objects align according to the chosen command. 

Sending Objects Front or Back 

You can use the Bring to Front or Send to Back  commands in the Format menu to 
layer overlapping objects. 

Choose Bring to Front to move one or more selected objects in front of all objects 
on a form. 

Choose Send to Back  to move one or more selected objects behind all objects on 
a form. 

Changing Tab Order on a Form 

Tab order is the order in which the cursor moves from field to field on a form in fill 
view. You should check the tab order on all the forms you design or scan. 
Remember, to not modify the tab order if you are using the fields for AS/400 field 
file mapping.  

To change tab order: 

Horizontal centers 

Vertical centers’ 
alignment midpoint 
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1.  Click the Tools button in the design toolbar or choose Tab Order in the 
Tools menu. 
The Tools window appears to the left of the form.  

2. Click the Tab Order tab in the Tools window if either the Proofreader or 
Scrapbook  window appears.  
The Tab Order window appears and tab numbers appear by each field in this 
window and on the form. These indicate current tab order. 

 
3. Select the fields to reorder in the Tab Order window or on 

the form. The fields will be selected on both the Tab Order 
window and the form.  
Reorder the fields in one of the following ways: 
• Drag the fields up or down in the Tab Order window to change 

their tab order. 

• Select the tab numbers on the form and enter a new order 
number. 

• Click the Move Up button in the Tab Order window to move the 
selected fields up. Click as many times as needed to move the 
fields into place. 
Or, you can right-click your mouse button to get a shortcut 
menu to move the selected fields up.  

• Click the Move Down button in the Tab Order window to move 
the selected fields down. Click as many times as needed to 
move the fields into place. 
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• Or, you can right-click your mouse button to get a shortcut 
menu to move the selected fields down.  

• Click Auto Order to reorder all the fields on the form. 
flashFORM uses “smart” auto ordering, and generally reorders 
fields from top to bottom and left to right. 

4. Click the Tools button in the design toolbar or choose Tab Order in the Tools 
menu to close the Tab Order window. 

Reordering Fields Not in a Sequential Order 

You can select fields that are not in a sequential tab order on the form and group 
them together.  
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To reorder fields not in a sequential order: 

1.  Click the Tools button in the design toolbar or choose Tab Order in 
the Tools menu. 
The Tools window appears to the left of the form.  

2. Click the Tab Order tab in the Tools window if either the Proofreader or 
Scrapbook window appears.  

3. Select the fields (on the form or in the Tab Order window) that you want to 
group.  

4. Click Group in the Tab Order window. The corresponding fields are now 
grouped in the tabbing order, that is, from top to bottom and from left to right. 
Or, you can right-click your mouse button to open a shortcut menu to group the 
selected fields. 

5. Click the Tools button in the design toolbar or choose Tab Order in the Tools 
menu to close the Tab Order window. 

Grouping Check Boxes or Circle Text Objects 

You can group check boxes or circle text objects into an option group. 

Alternatively, you can group check boxes and circle text objects by choosing 
Object Definition... in the Format menu. See “Defining a Check Box Object” and 
“Defining a Circle Text Object”  for more information. 

To group check boxes or circle text objects: 

1.  Click the Tools button in the design toolbar or choose Tab Order in the 
Tools menu. 
The Tools window appears to the left of the form.  

2. Click the Tab Order tab in the Tools window if either the Proofreader or 
Scrapbook  window appears.  

3. Select the check boxes or circle text objects on the form or in the Tab Order 
window.  

4. Right-click your mouse button in the Tab Order window to open a shortcut 
menu.  

5. Select Option Group... in this menu and enter a name for the option group. 

6. Click the Tools button in the design toolbar or choose Tab Order in the Tools 
menu to close the Tab Order window. 

Reordering Tables: 
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Tables can be ordered from left to right or top to bottom. 
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To reorder tables: 

1.  Click the Tools button in the design toolbar or choose Tab Order in the 
Tools menu. 
The Tools window appears to the left of the form.  

2. Click the Tab Order tab in the Tools window if either the Proofreader or 
Scrapbook  window appears.  

3. Select the table in the Tab Order window. 

4. Right-click your mouse button in the Tab Order window to open a shortcut 
menu and reorder your table from this menu. 

5. Click the Tools button in the design toolbar or choose Tab Order in the Tools 
menu to close the Tab Order window. 

Changing the tab order within a table cell 

You can also change the tab order within a cell if it contains multiple fillable fields.  

To change the tab order within a table cell: 

1.  Click the Tools button in the design toolbar or choose Tab Order in the 
Tools menu. 
The Tools window appears to the left of the form.  

2. Click the Tab Order tab in the Tools window if either the Proofreader or 
Scrapbook  window appears.  

3. Click a field in the Field Name list (one that has a plus sign in front of it) to 
display its list of contained fields. 

4. Select and drag the fields within the group, or use the Move Up or Move Down 
buttons (either in the Tab Order window or right-click your mouse button to get 
a shortcut menu). 

5. Click the Tools button in the design toolbar or choose Tab Order in the Tools 
menu to close the Tab Order window. 

Alternatively, you can select a tab number on the form (one that has a decimal 
point; for example, 10.3) and type a new order number. 

Placing Objects in Table Cells 

Each table cell contains one fill text object by default (except for column headers 
which contain a text object). A cell can contain more than one object, fillable or 
nonfillable. 

To place objects in a table cell: 
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1. Select a tool in the drawing toolbar. 

2. Your cursor changes to reflect that object. 

3. Move the cursor over the cell to fill so that it highlights the cell. 

4. Click to place the object in the cell, or hold down the mouse button and draw 
an object to the size that you want. 

To resize an object to fit a cell exactly: 

1. With the object in the table cell still selected, choose Size and Position... in the 
Format menu. 
The Size and Position dialog box appears. 

2. Select Snap Object(s) to Fit Table Cell. 

 

3. Click OK. 
The object resizes to fit the cell exactly. 

Converting an Object to Another Type of Object 

You can convert any selected object to another type of object. You might, for 
example, want to convert objects in table cells to check boxes. 
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Be careful when converting objects in an existing form. If the old object contained 
information, you will permanently lose that object’s information in every record. 

You can also convert objects that were not defined properly during import; for 
example, flashFORM might define a line with space above it as a fill text field. You 
could convert this to a line. 
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To convert a selected object: 

1. Choose Convert... in the Edit menu. 
The Convert dialog box appears. 

2. Select an object type in the Convert Object(s) To list and click OK. 
The object is converted. 

Use the Select Special... command in the Edit menu to select all objects of a 
specific type. 





Forms Design User’s Guide 
Advanced Features 

 
 

flashFORM Designer User’s Guide   119   

Advanced Features 

 
This chapter discusses how to use some of the advanced features in flashFORM. 
Although these are advanced features they are not hard to learn. After you have 
become familiar with some of the basic form design options in flashFORM, try 
some of these features. These features can really enhance the design of your 
forms. For a description of flashFORM’s basic design features, see “Designing a 
Form.” 

This chapter contains the following sections: 

• Setting up a Form for Automated Data Entry 

• Setting Attributes for a Form 

• Adding Security to Your Forms 

• Adding Hyperlinks to Your Forms 

• Using the Scrapbook 

• Inserting OLE Objects in a Form 

The flashFORM\Sample Forms folder contains several sample forms that you 
can use or redesign for your needs.  
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Setting up a Form for Automated Data Entry 

Using the AutoFill Wizard, you can set up a form for automated data entry. You 
can create or use an AutoFill list to provide a drop-down list of possible entries for 
the person who fills in a form or to provide an automatic filling of specific fields on a 
form. You can create a new AutoFill list, use a list from another field, use a 
previously defined list, create a list from an ODBC source, or create a list from a 
flashFORM form or database. 

This section describes how to: 

• create a new AutoFill list 

• create an AutoFill from another source 

• automatically fill fields on a form 

• create an AutoFill list and automatically fill fields 

• create an AutoFill list and/or automatically fill fields in a table 

• create a replacement list 

 
Before you begin using the AutoFill Wizard, please read all the sections of “Setting 
up a Form for Automated Data Entry” to get an idea of how the Wizard works and 
to become familiar with some of the Wizard’s dialog boxes. 

Creating a New AutoFill List 

This section explains how to create a new AutoFill list. By creating a new AutoFill 
list, you create a drop-down list of choices for the person who fills in the form, 
including the information for this new list.  

To create a new AutoFill list: 

1. Open a form and select a field (either Fill Text or Comb objects) where you 
want to create a drop-down list.  

2. Choose Object Definition... in the Format menu. 
The Fill Text Definition dialog box appears. 

3. Click the Filling tab in the Fill Text Definition dialog box. 

4. Select Enable AutoFill and click AutoFill Wizard.... 

The following AutoFill Wizard dialog box appears.  
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1. Select Create or edit the AutoFill of the current field to create a list for your 
selected field and click Next>.  
The following dialog box appears.  

 

2. Select Show a list of choices and click Next>.  
The following dialog box appears. 
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3. Select Manually entered list to create the information for your AutoFill list and 
click Next>.  
The following dialog box appears.  

         

4. Click Add and type the information that you want to include in your list in the 
provided text box. Each item in a column can have a maximum of 100 
characters. 
After each entry, press Enter. Continue adding information to your list and, 
when you are finished, click Next>. 

5. Select whether you want to save your list in the dialog box that appears. If you 
are saving your list, type a name. 
flashFORM saves your list as a .txt file. 



Forms Design User’s Guide 
Advanced Features 

 
 

flashFORM Designer User’s Guide   123   

6. Click Finish to close the AutoFill Wizard and, if selected, to save your list.  
The Fill Text Definition dialog appears.  

7. Click OK to apply your settings and close the dialog box. 

Create or Use an AutoFill List From Another Source  

You can create or use an AutoFill list from a variety of sources, such as a 
previously saved AutoFill list, an AutoFill list from another field, an AutoFill list from 
an ODBC source, and an AutoFill list from a flashFORM Form or Database. 

Use a Previously Saved AutoFill List 

You can use a previously saved AutoFill list and apply it to your current field. This 
can save you time if you have already created a list that could be used again. For 
example, you may have created a list containing the names of all your customers 
and would like to use that information for your current field.  

To use a previously saved AutoFill list: 

1. Open a form and select a field where you want to use another AutoFill list. 

2. Choose Object Definition... in the Format menu. 
The Fill Text Definition dialog box appears. 

3. Click the Filling tab in the Fill Text Definition dialog box. 

4. Select Enable AutoFill and click AutoFill Wizard.... 

5. Select Apply a saved AutoFill to the current field. 

6. Select the AutoFill list that you want to use for your form from the drop-down 
list. 

• If you are not customizing your list, you are finished. Click 
Finish to close the Wizard, and OK to apply your settings and 
close the dialog box. 

• If you want to customize or make changes to your list, select I 
want to customize this AutoFill check box and click Next>. 

7. Select Show a list of choices in the next dialog box to display your list and 
make your changes. Each item in a column can have a maximum of 100 
characters. 

• To add an entry to the list, click Add and type the new entry in 
the provided text box.  

• To make a change to the list, select the entry and then click 
Edit. Type your changes in the provided text box.  
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• To remove an entry, select the entry and then click Delete. 

• To remove all entries from the list, click Delete All.  
Click Next> when you are finished customizing the list. 

8. Select whether you want to save your list. If you are saving your list, type a 
name. flashFORM saves your list as a .txt file. 

9. Click Finish to close the AutoFill Wizard and, if selected, to save your list.The 
Fill Text Definition dialog box appears.  

10.  Click OK to apply your settings and close the dialog box.  

Use an AutoFill List From Another Field 

You can use an AutoFill list from another field and apply it to your current field. For 
example, you may have created an AutoFill field (for example, a State field) for all 
50 states and would like to use that field’s list and apply it to your current field. 

To use an AutoFill list from another field: 

1. Open a form and select a field where you want to use an AutoFill list from 
another field. 

2. Choose Object Definition... in the Format menu. 
The Fill Text Definition dialog box appears. 

3. Click the Filling tab in the Fill Text Definition dialog box. 

4. Select Enable AutoFill and click AutoFill Wizard.... 

5. Select Copy the AutoFill of another field to the current field. 

6. Select the AutoFill list that you want to use in the drop-down list. 

• If you are not customizing your list, you are finished. Click 
Finish to close the Wizard, and OK to apply your settings and 
close the dialog box. 

• If you want to customize or make changes to your list, select I 
want to customize this AutoFill check box and click Next>. 

7. Make any changes to your list in the dialog box that appears. Each item in a 
column can have a maximum of 100 characters. 

• To add an entry to the list, click Add and type the new entry in 
the provided text box.  

• To make a change to the list, select the entry and then click 
Edit. Type your changes in the provided text box.  

• To remove an entry, select the entry and then click Delete. 
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• To remove all entries from the list, click Delete All. 
Click Next> when you are finished customizing the list. 

8. Select whether you want to save your list. If you are saving your list, type a 
name. flashFORM saves your list as a .txt file. 

9. Click Finish to close the AutoFill Wizard and, if selected, to save your list.  
The Fill Text Definition dialog box appears.  

10.  Click OK to apply your settings and close the dialog box.  

Create an AutoFill List From a flashFORM Form or Database 

You can create an AutoFill list from a flashFORM form or database for your current 
field. For example, you may have a flashFORM database containing all Zip codes. 
You can use that information as an automatic data entry for your current field. 

To create an AutoFill list from a flashFORM form or database: 

1. Open a form and select a field where you want to use the information from 
another form or database.  

2. Choose Object Definition... in the Format menu. 
The Fill Text Definition dialog box appears. 

3. Click the Filling tab in the Fill Text Definition dialog box. 

4. Select Enable AutoFill and click AutoFill Wizard.... 

5. Select Create or edit the AutoFill of the current field and click Next>. 

6. Select Show a list of choices and click Next>. 

7. Select the type of source you want to use.  
Each item in a column can have a maximum of 2000 characters. 

• Select flashFORM Form to use information from another 
flashFORM form. 

• Select flashFORM Database to use information from a 
flashFORM database, that is, a file with an .ofd extension.  

8. Click Next>. 
The following dialog box appears if you have selected flashFORM Form. 
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9. Type the file name of the flashFORM form (or flashFORM database) you will 
be using in the File name text box.  
Or, click Browse... to locate your file. 

• Locate and select a file. 

• Click OK to return to the AutoFill Wizard dialog box. 

The name of the selected file appears in the File name text box. 

10.  Click Next>. 

11.  Specify the columns (or fields) that you want to use in your drop-down list. 
Also, select the field that you want to appear first in your drop- down list. You 
can have a maximum of 10 columns displayed in your drop-down list. 

• Select the columns in the Available columns list and click the 
right- arrow button. The columns you have chosen appear in 
the Columns to show list box. All the columns you choose will 
appear in the drop- down list. This is useful if you want more 
information to appear in the drop-down list.  

• In the Columns to enter text box, choose the field you want to 
appear first in the drop-down list. The information you choose 
from this column is what appears first in the field in fill view. 

12.  Click Finish to close the AutoFill Wizard. 
The Fill Text Definition dialog box appears. 

13.  Click OK to apply your settings and close the dialog box.  

Create an AutoFill List From an ODBC Source 
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You can create an AutoFill list from an ODBC source and use the information for 
your current field. 

To create an AutoFill list from an ODBC source: 

1. Open a form and select a field where you want to create on AutoFill list using 
information from an ODBC source. 

2. Choose Object Definition... in the Format menu. 
The Fill Text Definition dialog box appears. 

3. Click the Filling tab in the Fill Text definition dialog box. 

4. Select Enable AutoFill and click AutoFill Wizard.... 

5. Select Create or edit the AutoFill of the current field and click Next>. 

6. Select Show a list of choices and click Next>. 

7. Select ODBC Database to use information from a database (such as, dBASE 
or Microsoft Access) and click Next>. 
Each item in a column can have a maximum of 2000 characters. 

8. Specify the data source and table in the following dialog box.  

 

                       

            

 
If you have not set up your data source previously, click Administrator... and follow 
all the dialog boxes for your specific database. For more information about these 
dialog boxes, please see your specific database documentation. 
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• Select the data source you will be using from the Data Source 
drop- down list.  

• Select a Table you would like to use from the Table drop-down 
list. 

9. Click Next>. 
A dialog box similar to the one below appears.  

 

10.  Specify the columns (or fields) that you want to use in the drop-down list. Also, 
select the field that you want to appear first in the drop-down list. You can have 
a maximum of 10 columns displayed in your drop- down list. 

• Select the columns in the Available columns list and click the 
right- arrow button. The columns you have chosen appear in 
the Columns to show list box. All the columns you choose will 
appear in the drop- down list.  

• In the Columns to enter text box, choose the field you want to 
appear first in the drop-down list. The information you choose 
from this column is what appears first in the field in fill view. 

11.  Click Finish to close the AutoFill Wizard. 
The Fill Text Definition dialog box appears. 

12.  Click OK to apply your settings and close the dialog box. 

Automatically Fill Fields on a Form 

You can automatically fill fields on your form with AutoFill lists from a variety of 
sources. You can fill fields automatically using lists you create, or information from 
ODBC sources, flashFORM forms or databases. 
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This section describes how to create an automatic filling for your form. You create 
an automatic filling by allowing specific fields to be filled automatically after a 
certain field has been filled. For example, your form may have Name, Address, 
City, State, and Zip fields. In this case, you might want to set up the form so that 
once the Name field has been filled, the Address, City, State, and Zip fields will be 
filled automatically. 

Automatically Fill Fields on a Form With an AutoFill List You Create 

You can have fields on your form automatically filled with an AutoFill list you 
create. First specify a field so that once that field is filled other fields will be 
automatically filled. Next, create an AutoFill list. Finally, specify the fields on the 
form that you want automatically filled and then define the information that will be 
automatically filled in each field. 

To automatically fill fields on a form with an AutoFill list you create: 

1. Open a form and select a field where you want to create an automatic filling 
using an AutoFill list.  

2. Choose Object Definition... in the Format menu. 
The Fill Text Definition dialog box appears. 

3. Click the Filling tab in the Fill Text Definition dialog box. 

4. Select Enable AutoFill and click AutoFill Wizard.... 

5. Select Create or edit the AutoFill of the current field and click Next>. 

6. Select Fill other fields automatically after the field is filled to create an 
automatic filling for your form, and click Next>.  

7. Select Manually entered list to use an AutoFill list for your form, and click 
Next>.  

A dialog box similar to the one below appears. 
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8. Specify the fields that you want to be filled automatically.  

• Select the fields in the Available fields list and click the right-
arrow button. The fields you choose appear in the Fields to fill 
list. The Available Fields list displays all the fields on your form. 
The Fields to fill list displays all the fields on the form that you 
want filled automatically. 

• To remove the fields from the Fields to fill list, select the fields 
from the Fields to fill list and then click the left-arrow button. 
The fields you have chosen return to the Available fields list. 

9. Click Next>.  
A dialog box similar to the one below appears.  

 

10.  Type the entries that you want in the columns. The first column, the Name field 
is the selected field on your current form. Once the Name field (or John Smith) 



Forms Design User’s Guide 
Advanced Features 

 
 

flashFORM Designer User’s Guide   131   

is filled, the other fields on the form, that is, Address (or in this case, 123 Main 
St.), City (that is, Gould), and State (that is, CO) fields, will be filled 
automatically. 
Click Next> when you are finished. 

11.  Click Finish to close the AutoFill Wizard. 
The Fill Text Definition dialog box appears. 

12.  Click OK to apply the settings and close the dialog box. 

Automatically Fill Fields on a Form With a flashFORM Form or 
Database 

You can have fields on your form automatically filled with information from a 
flashFORM form or database. First, specify the field so that once it is filled other 
fields on the form will be automatically filled. Next, select the flashFORM form or 
database that you want to use. Finally, specify the fields on the form that you want 
automatically filled and then define the information that will be automatically filled 
in each field. 

To automatically fill fields on a form with information from a flashFORM 
Form or Database: 

1. Open a form and select a field where you want to create an automatic filling 
using a flashFORM form or database.  

2. Choose Object Definition... in the Format menu. 
The Fill Text Definition dialog box appears. 

3. Click the Filling tab in the Fill Text Definition dialog box. 

4. Select Enable AutoFill and click AutoFill Wizard.... 

5. Select Create or edit the AutoFill of the current field and click Next>. 

6. Select Fill other fields automatically after the field is filled to create an 
automatic filling for your form and click Next>.  

7. Select the flashFORM form or database that you want to use. Each item in a 
column can have a maximum of 2000 characters. 

• Select flashFORM Form to use information from another 
flashFORM Form and click Next>.  

• Select flashFORM Database to use information from another 
flashFORM database (that is, a file with an .ofd extension) 
and click Next>. 
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8. Type the file name of the flashFORM form or database you will be using in the 
File name text box.  
Or, click Browse... to locate your file. 

• Locate and select a file. 

• Click OK to return to the AutoFill Wizard dialog box. 

• The name of the selected file appears in the File name text 
box. 
Click Next>.  

9. Select, in the Column/field drop-down list, the column (or field) from your 
database that you want to match against the data in the current selected field 
on your form. 
Click Next> when you are finished matching the data with the field on your 
form. 

10.  Specify the fields that you want filled automatically.  

• Select the fields in the Available fields list and click the right-
arrow button. The fields you have chosen appear in the Fields 
to fill list. The Available Fields list displays all the fields on your 
form. The Fields to fill list displays all the fields on the form that 
you want filled automatically. 

• To remove the fields from the Fields to fill list, select the fields 
from the Fields to fill list and then click the left-arrow button. 
The fields you have chosen return to the Available fields list. 

Click Next> when you are finished specifying the fields you want automatically 
filled. 

11.  Specify the links between the fields to be automatically filled in the form and 
the columns in the database. By linking the fields to the columns, you tell 
flashFORM what database information needs to be placed in what field on 
your form. 

• Select an entry from Fields in form and then an entry in 
Columns in database. Click <<Link>>. Your selection appears 
in the Links box. 

• You can let flashFORM automatically link fields with columns. 
Click <<Auto>>. flashFORM automatically matches fields with 
columns of the same name and displays the linkage in the 
Links box. 

• To remove an entry from the Links box, select the entry that 
you want and click Unlink . If you want to remove all entries in 
the Links box, click Unlink All. 
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12.  Click Finish to close the AutoFill Wizard. 
The Fill Text Definition dialog box appears. 

13.  Click OK to apply your settings and close the dialog box. 

 

Automatically Fill Fields on a Form With an ODBC Source 

You can have fields on your form automatically filled with information from an 
ODBC source. First specify a field so that once it is filled other fields will be 
automatically filled. Next, select the ODBC source that you want to use. Finally, 
specify the fields on the form that you want automatically filled and then define the 
information that will be automatically filled in each field. 

To automatically fill fields on a form with information from an ODBC source: 

1. Open a form and select a field where you want to create an automatic filling 
using information from an ODBC source.  

2. Choose Object Definition... in the Format menu. 
The Fill Text Definition dialog box appears. 

3. Click the Filling tab in the Fill Text Definition dialog box. 

4. Select Enable AutoFill and click AutoFill Wizard.... 

5. Select Create or edit the AutoFill of the current field and click Next>. 

6. Select Fill other fields automatically after the field is filled to create an 
automatic filling for your form and click Next>.  

7. Select ODBC Database to use information from a database (such as dBASE 
or Microsoft Access) and click Next>. 
Each item in a column can have a maximum of 2000 characters. 

8. Specify the data source and table. 

• Select the source of your data from the Data Source drop-down 
list. 

• Select the table from the Table drop-down list.  

 
If you have not set up your data source previously, click Administrator... and follow 
all the dialog boxes for your specific database. For more information about these 
dialog boxes, please see your specific database documentation. 

9. Click Next>. 
A dialog box similar to the one below appears.  



Forms Design User’s Guide 
Advanced Features 

134   flashFORM Designer User’s Guide 

  

10.  In the Column/field drop-down list, select the column (or field) from your 
database that you want to match against the data in the current selected field 
on your form.  
Click Next> when you are finished matching the data with the field on your 
form. 

11.  Specify the fields that you want filled automatically.  

• Select the fields in the Available fields list and click the right-
arrow button. The fields you have chosen appear in the Fields 
to fill list. The Available Fields list displays all the fields on your 
form. The Fields to fill list displays all the fields on the form that 
you want filled automatically. 

• To remove fields from the Fields to fill list, select the fields from 
the Fields to fill list and then click the left-arrow button. The 
fields you have chosen return to the Available fields list. 

12.  Click Next> when you are finished specifying the fields you want automatically 
filled. 
 
A dialog box similar to the one below appears  
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13.  Specify the links between the fields to be automatically filled in the form and 
the columns in the database. By linking the fields to the columns, you tell 
flashFORM what database information needs to be placed in what field on 
your form.  

• Select an entry from the Fields in form and then an entry in 
Columns in database. Click <<Link>>. Your selection appears 
in the Links box.  

• You can let flashFORM automatically link fields with columns. 
Click <<Auto>>. flashFORM automatically matches fields with 
columns of the same name and displays the linkage in the 
Links box. 

• To remove an entry in the Links box, select the entry that you 
want and click Unlink . If you want to remove all entries in the 
Links box, click Unlink All.  

14.  Click Finish to close the AutoFill Wizard. 
The Fill Text Definition dialog box appears. 

15.  Click OK to apply your settings and close the dialog box. 

Creating an AutoFill List and Automatically Fill Fields 

You can create both an AutoFill list and have fields automatically filled for your 
form. You can automatically fill fields by using a list you create, information from an 
ODBC source, flashFORM form, or database. The AutoFill Wizard can easily do 
both.  

To create an AutoFill List and automatically fill fields: 
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1. Open a form and select a field where you want to create an AutoFill list and 
automatically fill fields.  

2. Choose Object Definition... in the Format menu. 
The Fill Text Definition dialog box appears. 

3. Click the Filling tab in the Fill Text Definition dialog box. 

4. Select Enable AutoFill and click AutoFill Wizard.... 

5. Select Create or edit the AutoFill of the current field and click Next>. 

6. Select Show a list of choices and automatically fill other fields in the dialog box 
that appears and click Next>.  

7. Select Manually entered list to use information created with the AutoFill Wizard 
and click Next>. 

8. Specify the fields that you want to be filled automatically.  

• Select the fields in the Available fields list and click the right- 
arrow button. The fields you have chosen appear in the Fields 
to fill list. The Available Fields list displays all the fields on your 
form. The Fields to fill list displays all the fields on the form that 
you want filled automatically. 

• To remove the fields from the Fields to fill list, select the fields 
from the Fields to fill list and then click the left-arrow button. 
The fields you have chosen return to the Available fields list. 

9. Click Next>.  
 
A dialog box similar to the one below appears.  
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10.  Type the entries in the appropriate columns. For example, the first column in 
this dialog box, the Company field, is the selected field on your current form; 
that is, the field that contains the drop-down list. The second column, the From 
field, is the field that will be automatically filled once the Company field is filled.  

11.  Click Next>.  

12.  Select whether you want to save your list. If you are saving your list, type a 
name.  

13.  Click Finish to close the AutoFill Wizard. 
The Fill Text Definition dialog box appears. 

14.  Click OK to apply the settings and close the dialog box. 

To create an AutoFill list and automatically fill fields with an ODBC source: 

1. Open a form and select a field where you want to create an AutoFill list and 
automatically fill fields using information from an ODBC source.  

2. Choose Object Definition... in the Format menu. 
The Fill Text Definition dialog box appears. 

3. Click the Filling tab in the Fill Text Definition dialog box. 

4. Select Enable AutoFill and click AutoFill Wizard.... 

5. Select Create or edit the AutoFill of the current field and click Next>. 

6. Select Show a list of choices and automatically fill other fields and click Next>.  

7. Select ODBC Database to use information from a database (such as dBASE 
or Microsoft Access) and click Next>.  
Each item in a column can have a maximum of 2000 characters. 

8. Specify a data source and table. 

 

 
If you have not set up your data source previously, click Administrator... and follow 
all the dialog boxes for your specific database. For more information about these 
dialog boxes, please see your specific database documentation. 

• Select the data source you will be using from the Data Source 
drop- down list. 

• Select the table you would like to use from the Table drop-
down list.  

• Click Next>. 
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9. Specify the columns (or fields) that you want to use in the drop-down list. Also, 
select the field you want to appear first in the drop-down list. You can have a 
maximum of 10 columns displayed in a drop-down list. 

• Select the columns in the Available columns list and click the 
right- arrow button. The columns you have chosen appear in 
the Columns to show list box. All the columns you choose will 
appear in the drop- down list. This is useful if you want more 
information to appear in the drop-down list.  

• In the Columns to enter text box, choose the field you want to 
appear first in the drop-down list. The information you choose 
from this column is what appears first in the field in fill view. 

10.  Click Next>.  

11.  Specify the form’s fields that you want to be filled automatically.  

• Select the fields in the Available fields list and click the right-
arrow button. The fields you have chosen appear in the Fields 
to fill list. The Available Fields list displays all the fields on your 
form. The Fields to fill list displays all the fields on the form that 
you want filled automatically. 

• To remove fields from the Fields to fill list, select the fields from 
the Fields to fill list and then click the left-arrow button. The 
fields you have chosen return to the Available fields list. 
Click Next>.  

12.  Specify the links between the fields to be automatically filled in the form and 
the columns in the database. By linking the fields to the columns, you tell 
flashFORM what database information needs to be placed in what field on 
your form.  

• Select an entry from the Fields in form and then an entry in 
Columns in database. Click <<Link>>. Your selection appears 
in the Links box.  

• You can let flashFORM automatically link fields with columns. 
Click <<Auto>>. flashFORM automatically matches fields with 
columns of the same name and displays the linkage in the 
Links box. 

• To remove an entry in the Links box, select the entry and click 
Unlink . If you want to remove all entries in the Links box, click 
Unlink All. 

13.  Click Finish to close the AutoFill Wizard. 
The Fill Text Definition dialog box appears. 
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14.  Click OK to apply the settings and close the dialog box. 

To create an AutoFill list and automatically fill fields with a flashFORM Form 
or Database: 

1. Open a form and select a field where you want to create an AutoFill list and 
automatically fill fields using information from a flashFORM form or database.  

2. Choose Object Definition... in the Format menu. 
The Fill Text Definition dialog box appears. 

3. Click the Filling tab in the Fill Text Definition dialog box. 

4. Select Enable AutoFill and click AutoFill Wizard.... 

5. Select Create or edit the AutoFill of the current field and click Next>. 

6. Select Show a list of choices and automatically fill other fields and click Next>.  

7. Choose the flashFORM form or database that you want to use. Each item in a 
column can have a maximum of 2000 characters. 

• Select flashFORM Form (to use information from a flashFORM 
form) and click Next>. 

• Select flashFORM Database (to use information from a 
flashFORM database, that is, a file with an .ofd extension) 
and click Next>. 

8. Type the file name in the provided text box.  
Or, click Browse... to locate your file. 

• Locate and select a file. 

• Click OK to return to the AutoFill Wizard dialog box. 
The name of the selected file appears in the File name text 
box. 
Click Next>.  

9. Specify the columns (or fields) that you want to use in the drop-down list. Also, 
select the field you want to appear first in the drop-down list. You can have a 
maximum of 10 columns displayed in a drop-down list. 

• In the Columns to show text box, specify all the fields you want 
to use from the Available columns list. All the columns you 
specify will appear in the drop-down list. This is useful if you 
want more information to appear in the drop-down list.  

• In the Columns to enter text box, specify the field you want to 
appear first in the drop-down list. The information from this 
column is what appears first in the field in fill view. 
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10.  Click Next>. 

11.  Specify the form’s fields that you want to be filled automatically.  

• Select the fields in the Available fields list and click the right-
arrow button. The fields you have chosen appear in the Fields 
to fill list. The Available Fields list displays all the fields on your 
form. The Fields to fill list displays all the fields on the form that 
you want filled automatically. 

• To remove fields from the Fields to fill list, select the fields from 
the Fields to fill list and then click the left-arrow button. The 
fields you have chosen return to the Available fields list. 
Click Next>.  

12.  Specify the links between the fields to be automatically filled in the form and 
the columns in the database. By linking the fields to the columns, you tell 
flashFORM what database information needs to be placed in what field on 
your form.  

• Select an entry from the Fields in form and then an entry in 
Columns in database. Click <<Link>>. Your selection appears 
in the Links box.  

• You can let flashFORM automatically link fields with columns. 
Click <<Auto>>. flashFORM automatically matches fields with 
columns of the same name and displays the linkage in the 
Links box. 

• To remove an entry in the Links box, select the entry and click 
Unlink . If you want to remove all entries in the Links box, click 
Unlink All. 

13.  Click Finish to close the AutoFill Wizard. 
The Fill Text Definition dialog box appears. 

14.  Click OK to apply your settings and close the dialog box.  

Replacing Data Entered in a Field With New Data 

This section describes how you can set up a field to replace entered data with data 
you have specified in a replacement list. This is useful if you want to standardize 
an entry in a field. For example, suppose your form contains a State field and you 
want the user to enter the state’s two-letter abbreviation. You can create a field 
that will allow the user to enter only the specified information. So, anytime the user 
enters a variant of the state name in fill view, the replacement feature will change it 
to your specified version. 
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To create a replacement list: 

1. Open a form and select a field where you want to create a replacement list. 

2. Choose Object Definition... in the Format menu. 
The Fill Text Definition dialog box appears. 

3. Click the Filling tab in the Fill Text Definition dialog box. 

4. Select Enable AutoFill and click AutoFill Wizard.... 

5. Select Create or edit the AutoFill of the current field and click Next>. 

6. Select Replace the data entered into this field with new data and click Next>. 
 
A dialog box similar to the one below appears.  

 

7. Type the entry to be replaced in the Replace column and type the replacement 
in the With column.  

8. Click Next> when you are finished. 

9. Select whether you want to save your list. If you are saving your list, type a 
name.  

10.  Click Finish to close the AutoFill Wizard and, if selected, to save your list.  
The Fill Text Definition dialog appears.  

11.  Click OK to apply your settings and close the dialog box.  
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Creating AutoFills for Tables 

You can create an Autofill list for your table as well as have fields in your table 
filled automatically. The procedure is similar to “ Creating a New AutoFill List”  on 
page 110 . Therefore, before you begin, please review all the sections in “Setting 
Up a Form for Automated Data Entry.” The following is a brief description of the 
selections in two of the dialog boxes unique to tables. 

The following dialog box appears when you have chosen to fill fields automatically. 

      

  

• Select All other fields in the form to show all the available fields 
on the form. 

• Select All fields not in this table to show just the fields outside 
of the table. 

• Select Fields in the current row to display just the fields in the 
current row of the table. 

• Select Fields in the current column to display just the fields in 
the current column of the table. 

The following dialog box appears after you have applied all your settings to the 
table.  
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• Select No if you do not want the AutoFill settings to apply to the 
rest of the fields in the table. 

• Select Yes if you want the AutoFill settings to apply to the rest 
of the fields in the table.  

Setting Attributes for a Form 

Setting Up a Shared Form 

You can set up a shared form whenever you need to do so. By creating a shared 
form, you allow other users to have access to the form. You also allow multiple 
users to open and fill the form at the same time. 

To set up a shared form: 

1. Open a form to design view. 

2. Choose Properties... from the File menu. 
A Properties dialog box appears. 

3. Click the Sharing tab and select Shared 
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4. Click OK to apply the change. 

 
The shared form settings are not applied until the form is saved and closed. 

Setting Summary Information 

Using the Summary tab, you can enter pertinent information about the form. 

To set summary information: 

1. Choose Properties in the File menu. 
The Properties dialog box appears 

  . 

2. Click the Summary tab. 

3. Enter information appropriate to your form. 
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4. Click OK to apply your settings. 

Setting Submission Information 

Using the Submission tab, you can set how you will submit your form and where 
you will send your form after you submit it. 

To set submission information: 

1. Choose Properties in the File menu. 
The Properties dialog box appears. 

   

2. Click the Submission tab. 

3. Type an action in the Action text box. It will be saved in the drop-down list for 
selection the next time you open this dialog box. 
An action describes where form data will be sent after submission from 
flashFORM Filler, a Web browser, or Adobe’s Acrobat software. 

• The action could point to a Common Gateway Interface (CGI) 
script on a Web server; for example: 
http://www.formationmg.com/location-bin/script.pl 
This would tell flashFORM Filler to submit data to a script on 
FORMation mg’s Web server. 

• The action could also be an e-mail address; for example: 
mailto:name.othername@company.com 
The form data would be submitted to that e-mail address. 

4. Select a means of submitting data. 

• Select GET to append text to the Universal Resource Locator 
(URL) specified in the Action drop-down list. 
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• Select POST to notify the Web server to open the CGI 
application and pass the data. 

Adding Security to Your Forms 

If your work environment contains several work groups, you might want to add 
security properties to your forms. Security properties can protect both the user who 
fills out the form and the user who processes the filled out form.  

To add security properties to a form:  

• First create a user database. 
This is a place to store the names of the users and their 
passwords.  

• Next, create a signature field or fields on the form.  
A signature field contains settings that allow users to lock fields 
on a form. In locking other fields, only the user with the correct 
password can change the locked fields.  

• Finally, track and verify who has signed the form. 

For example, suppose you have an Expense report that requires an employee’s 
signature and supervisor’s approval. For this form you might want to create an 
employee’s signature and have this signature field lock fields that the employee 
fills out. Once the employee’s signature field is signed (that is, filled), no one can 
change the locked fields unless that user has the correct password and unsigns 
the field.  

You might also want to create a supervisor’s signature field and have this 
signature field lock the employee’s signature field. Once the supervisor’s signature 
field is signed (that is, filled), no one can change any of the fields without the 
correct passwords. The supervisor’s password is required to unsign the 
supervisor’s signature field. The employee’s password is required to unsign the 
employee’s signature field, which will unlock the rest of the locked fields on the 
form. 

This section describes how to create a user database, how to set up signature 
fields, and how to verify the signature fields. 

Creating a User Database 

This section should be performed by your Work Group Administrator. A user 
database contains information about the members of your work group, such as, 
user names, passwords, and descriptive full names. It is the basis for form signing 
and signature verification in the work group. The database should be located 
where all work group members can access it; such as, the network drive. For 
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added security, the user database may be made read-only to everyone but the 
administrator. 

To create a user database: 

1.  If you are in fill view, click the Design button in the fill toolbar or choose 
Design in the View menu to switch to design view. 

2. Choose Security... in the Tools menu. The Security Database dialog box 
appears.  

  

3. Type the name of your database file in the File name text box.  
Or, click Browse... to locate your file. 

• Locate and select a file. 

• Click OK to return to the Security Database dialog box. 

4. Click OK when you are finished 
The Enter Administrator Password dialog box appears  

 

 
If an administrator password has not been defined, you will be prompted to enter 
one and verify it; otherwise just enter the password to continue. 

 
If you lose or forget your password it cannot be recovered. Do not use the 
following characters in your user name or full name: “/\ [ ] ; : | = , + * ? < > 

5. Click OK to return to the Security Database dialog box. 

6. Click OK in the Security Database dialog box to close the dialog box.  
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To add a user to the database: 

1.  If you are in fill view, click the Design button in the fill toolbar or choose 
Design in the View menu to switch to design view. 

2. Choose Security... in the Tools menu. 
The Enter Administrator Password dialog box appears.  

3. Enter your password in this dialog box.  

4. Click OK. 
The Security Database Administration dialog box appears. In the Users list 
box, all the current users are displayed.  

 

5. Click the New button to add a new user, and enter: 

• the user’s name in the Username text box. The user’s name 
can contain up to 20 characters.  

• the password for that user in the Password text box. The 
password can contain up to 14 characters and will appear as 
asterisks in the text box.  

• the password again in the Verify password text box. 

• the user’s full name in the Full name text box. The full name 
can contain up to 50 characters. The full name is the name that 
will be displayed in the signature field in fill view. 

 
If you lose or forget your password it cannot be recovered. Do not use the following 
characters in your user name or full name: “/\ [ ] ; : | = , + * ? < > 

6. Click Add to add the new user. 

7. Click OK to close the dialog box. 

To update a password or full name: 
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1. In design view, choose Security... in the Tools menu. 
The Security Database Administration dialog box appears. In the Users box, all the 
current users are displayed.  

2. In the Users list box, select the user that you want to update. 

 

Updating a user’s password will cause all records previously signed by this user to 
become unverified. The user will no longer be able to unsign those records. 

• Type a new password in the Password text box, and then type 
the password again in the Verify password text box to update 
the password.  

• Type the new user’s full name in the Full name text box to 
update the user’s full name.   

3. Click Update to update the password/user’s full name.  

4. Click OK to close the dialog box.  

To delete a user: 

1. In design view, choose Security... in the Tools menu. 
The Enter Administrator Password dialog box appears. Enter your password in 
this dialog box. 

2. Click OK. 
The Security Database Administration dialog box appears. In the Users box, all 
the current users are displayed.  

3. Select the user that you want to delete in the Users box. 

4. Click Delete. You will be warned that you are about to delete the user and will be 
prompted to continue. Click OK in this dialog box. The user is deleted. 

5. Click OK to close the Security Database Administration dialog box. 

Creating Signature Fields 

You create signature fields from fill text fields. Signature fields can lock other fields 
on a form. And once a signature field is signed (that is, filled) no one can change 
the locked fields unless that user has the correct password and unsigns the field.  

To create a signature field on a form: 

1. In design view, select a fill text field on the form where you want to create a 
signature field. 
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2. Choose Object Definition... in the Format menu.  
Or, open a shortcut menu by clicking the right-mouse button over the selected 
object. Choose Object Definition... in this menu. 

3. Click the Properties tab in the Fill Text Definition dialog box. 

4. Select Signature in the Type drop-down list. 

5. Click the Settings button.  
The Signature Settings dialog box appears.  

                            

• In the Fields in list box, select the fields that you want to lock 
with the signature field and click Add>> to add the fields. 

• To add all the fields on the form, click Add All>>. 

• To remove fields from the Fields to lock  list box, select those 
entries that you want removed and then click <<Remove.  

6. Click OK when you are finished.  
If Field Security has been turned on in fill view, signed fields will appear with 
an icon in fill view: a red icon if the signature is not verified and a green icon if 
the signature is verified. The fields that are locked will have a blue border in fill 
view. 

Filling/Signing Signature Fields 

A form is signed if a user has filled out a signature field. If online, the user must 
enter a valid user name and password. A form is considered online if the security 
database can be found and opened. When online, signatures can be verified.  

If offline a user can enter any user name and password. A form is considered 
offline if a security database file name has not been specified, or if an error 
occurred when opening the database. When offline, signatures cannot be verified. 

To sign a signature field: 

1. Click the signature field. 
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• If you are online, the Signature Required dialog box appears. 
You will be prompted for a valid user name and password. 

• If you are offline, the Signature Required (Offline) dialog box 
appears. You will be prompted for a user name and password. 

                                   

2. Enter your user name and password. 

3. Click OK. 

Verifying Signature Fields 

A form with signature fields is only of value if you can verify that the filled signature 
fields are valid and if the signed data has changed. You cannot verify a signature 
when you are offline. And if a form is signed offline, the user database cannot be 
accessed to verify the user information.  

To verify a signature: 

1.  If you are in design view, click the Fill button in the design toolbar or 
choose Fill in the View menu to switch to fill view. 

2. Choose Security... in the Tools menu. The Security Information dialog box 
appears.  
flashFORM tracks whether a signature field is currently verified or if it has ever 
been verified.   
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3. Click OK to close the dialog box.  

Adding Hyperlinks to Your Forms 

You can easily set up hyperlinks on your forms. A hyperlink is a connection from a 
place on your form to a file or Web site. For example, the person who fills out the 
form can link from a place on the form to your company’s Web site.  

To add hyperlinks to your forms: 

1.  If a form is open in fill view, click the Design button in the fill toolbar or 
choose Design in the View menu to switch to design view.  

2. Select an object on your form where you want to add a hyperlink. You can add 
hyperlinks to rectangle objects, oval objects, graphic objects, text objects and 
inside a text object (embedded within the text). 

3. Choose Hyperlink... in the Format menu. Or, click Hyperlink in the web toolbar. 
See “The Web Toolbar” for more information about this toolbar.  
The Hyperlink dialog box appears.  

                         

4. Select one of the options in the Link to file or URL drop-down list. 

• If you want to link to a specific Web site, select http:// and type 
the rest of the site address in the provided text box. 

• If you want to link to an FTP address, select ftp:// and type the 
rest of the address in the provided text box.  

• If you want to link to an electronic mail address, select mail to: 
and type the rest of the mail address in the provided text box.  

• Or, click Browse... if you need to locate a file. Locate and select 
a file.  

5. If you want, type a description of your hyperlink in the Description text box. 

6. Click OK to apply your settings and close the dialog box. 
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7. Choose Options... in the Tools menu if you would like to be able to view the 
link address. The Options dialog box appears. Select ScreenTips.  
When in fill view, if you place your cursor over the hyperlink area, a pop-up 
window appears displaying the link address.  

8. Click OK to apply your settings and close the dialog box.  

9. Right-click your mouse button over the hyperlink object to check your hyperlink 
while in design view. Select Follow Hyperlink.  
Or, you can hold down the Ctrl key and click it as you are over the hyperlink 
object.  

Using the Scrapbook 

This section describes the flashFORM scrapbook and how to use it. 

What Is the Scrapbook? 

The scrapbook is a convenient place to store frequently used or complex objects. 
Objects stored in the scrapbooks are called scraps. You can copy these scraps 
into any form. You can use one of the several scrapbook files provided with 
flashFORM or create your own. 

To open a scrapbook: 

1. Choose Scrapbook in the Tools menu. The scrapbook opens to the left of the 
flashFORM window in the Tools window. 



Forms Design User’s Guide 
Advanced Features 

154   flashFORM Designer User’s Guide 

a.  

2. Select a scrapbook to view in the Scrapbook  drop-down list, or create your 
own. 
See “ To create a new scrapbook” for information. 

To copy objects to the scrapbook: 

1. Open the desired scrapbook. 

2. Select one or more objects on your form and drag them into the scrapbook. 
Or, select one or more objects and choose Paste Scrap in the Scrapbook 
Commands icon menu. 
 

Small thumbnail sketches of the objects appear as Scrap 1, Scrap 2, and so forth 
in the scrapbook. 

 
You cannot store an OLE object in the scrapbook. 

To place scraps in a form: 

1. Open the desired scrapbook. 

2. Select a scrap and drag it into your form. Or, select a scrap and choose Copy 
Scrap in the Scrapbook Commands icon menu. 

You can select only one scrap at a time. The selected scrap appears as the 
original object in your form. 

Current scrapbook 

Stored graphic file (a scrap) 

Scrapbook Commands icon 
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To rename a scrap: 

1. Select a scrap. 

2. Choose Rename Scrap in the Scrapbook Commands icon menu. 

3. Type a new name for the scrap and press Enter to accept the name. 

 
Press Esc to cancel the command and leave the name as it is. 

To delete a scrap: 

1. Select a scrap. 

2. Choose Delete Scrap in the Scrapbook Commands icon menu.  
You can also press Delete to delete a selected scrap.  

 
You cannot undo the Delete Scrap command. 

flashFORM prompts you to confirm your choice. 

To create a new scrapbook: 

1.  Choose New Scrapbook... in the Scrapbook icon drop-down list. 
The New Scrapbook dialog box appears. 

2. Type a name in the Scrapbook Name text box. 
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3. Click OK. 
 

A new, empty scrapbook appears. 

 

To rename a scrapbook: 

1. Open the scrapbook to rename. 

2. Choose Rename Scrapbook... in the Scrapbook Commands icon menu. 

3. The Rename Scrapbook dialog box appears.  

 

4. Type a name in the New Name text box. 

5. Click OK. 
The new scrapbook name appears in the Scrapbook drop-down list. 

To delete a scrapbook: 

1. Open the scrapbook to delete. 

2. Choose Delete Scrapbook in the Scrapbook Commands icon menu. 

 
You cannot undo the Delete Scrapbook  command. 

3. flashFORM prompts you to confirm your choice. 

You can also delete a scrapbook file directly from the hard drive. Scrapbook files 
are stored in the location c:\flashFORM\Scrapbooks. Always close flashFORM 
before deleting any flashFORM files from the hard drive. 

To change the scrapbook view: 

1. Choose View in the Scrapbook Commands icon menu. 

2. Select a view in its cascading menu. 
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• Choose Icons to view the scraps as thumbnail sketches of the 
stored objects. 

• Choose List to view the scraps as a list. 

• Scraps are listed in the order they were created in both Icon 
and List views. 

Inserting OLE Objects in a Form 

This section describes how to use object linking and embedding (OLE) to insert 
objects in a form. 

Inserting objects is a convenient way to place information from other sources in 
flashFORM. flashFORM supports objects created in a variety of applications. 

For example, instead of scanning a page of text into flashFORM, you could create 
a Microsoft Word Document object and insert it in the form either as fully displayed 
text or as a launchable icon. This saves you scanning and editing time. An OLE 
object displayed as an icon also saves form and disk space. 

Linking and Embedding 

You can either link or embed an object when you insert it. This section describes 
both methods. 

Object Linking 

A linked object retains a connection, or link, to the source file. The source file is the 
file you select to insert as an OLE object. 

The source file stores the linked data. The flashFORM form stores the location of 
the source file and displays the linked object. Changes to the source file are 
reflected in the linked object. 

Use linking when: 

• The source file is likely to change. 

• The source file is on a network or needs to be accessed by 
others. 

• The source file is shared by more than one document. 

• The source file is very large and you do not want to increase 
your form’s file size significantly. 

Object Embedding 
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An embedded object becomes part of the flashFORM form. It is not linked to the 
source document. 

Use embedding when: 

• It is unlikely the object will need to be changed or updated. 

• The source document is unavailable for linking. 

• You are not concerned about the file size of your flashFORM 
form. 

How to Insert OLE Objects 

1. Choose Insert New Object... in the Edit menu. The Insert Object dialog box 
appears.  

 

2. Select an object type in the Object Type list box. 

3. Select one of the following. 

• To create a new object of the type selected and embed it in 
your form, select Create New. Proceed to step 4. 

• To import a file of the type selected and either embed it or link 
it to your form, select Create From File. The dialog box 
changes. Proceed to “Creating an OLE Object From a File”  on 
page 151. 

4. Select Display As Icon to display the object as an icon, rather than displaying 
its actual content. 
The Change Icon... button appears when Display As Icon is selected. Click it to 
select a new icon for the object or to change the icon’s name. By default, an 
object appears with the object type name if it is unlinked and the source file 
name if it is linked. 
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5. Click OK. 
How the object appears depends on the options that you selected. See “ 
Creating a New OLE Object” for detailed information. 

 
You cannot store an OLE object in the scrapbook. 

 

Creating a New OLE Object 

See the previous section, “ How to Insert OLE Objects” if you need to insert an 
object. How your object appears depends on the options you selected in the Insert 
Object dialog box. 

If you selected Display As Icon in step 4 in the previous section, the source 
application launches. Use its commands and tools to create your object. Choose 
Exit in the File menu to insert the object as an icon. 

If you did not select Display As Icon, an OLE window appears (some applications 
do not support OLE windows and the object will launch in the application itself). 
The flashFORM window changes to reflect the application window for the selected 
object type: 

• The name in the title bar changes to that of the source 
application. 

• The embedded object appears as an empty OLE window within 
the application window. Create your object here. 

• All menus but the File and Windows menus change to those of 
the source application. 

• All toolbars change to those of the source application. 

If you selected Bitmap Image, for example, you can use the Microsoft Paint menu 
commands and tools and some flashFORM commands.                     
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Create your object in the available window. Click outside the window or press Esc 
to embed the object in your form when you are done. 

Creating an OLE Object From a File 

See steps 1–3 in the section “ How to Insert OLE Objects” if you need to create an 
object. The Insert Object dialog box changes when you select Create from File.  

                  

1. Type a file name in the File text box. 
Or, click Browse... to locate a file. Select a file, and click OK to return to the 
Insert Object dialog box. 

2. Select Link if you want to link the object to its source file. 
Otherwise, the object will be embedded. 

Source application menus 
 
 
FlashForm form 
 
 
 
OLE window with newly created 
bitmap image to be embedded 
 
 
 
 
 
Paint tools used to create object 
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3. Select Display As Icon to display the object as an icon, rather than displaying 
its actual content. 
The Change Icon... button appears when Display As Icon is selected. Click it to 
select a new icon for the object or to change the icon’s name. By default, an 
object appears with the object type name if it is unlinked and the source file 
name if it is linked. 

4. Click OK. 
The object appears in your form. 

Pasting a Linked OLE Object 

You can paste information from another application into flashFORM as a linked 
OLE object. For example, you could copy cells from an Excel spreadsheet to the 
Clipboard. When you open flashFORM, the Paste Link  command in the Edit menu 
will be active. The object, once pasted, is linked to the copied cells. 

To paste a linked OLE object: 

1. Open a document in an application that supports links to its documents. 

2. Select the portion to link and leave it selected. 

3. Open a form in flashFORM. 

4. Choose Paste Link in the Edit menu. 
flashFORM pastes the information as a linked OLE object. 

Use the Links... command in the Edit menu to set linking options for any linked 
object. See the next section for information. 
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Setting Up Linking Options 

This section describes the Links... command. This command is only active if you 
have linked objects in the current form. Use the Links... command to update or 
break links, open an OLE object, or change an OLE source file. 

To use the Links... command: 

1. Choose Links... in the Edit menu. 

2. The Links dialog box appears.  

  

3. Select a link and click Automatic or Manual. 

• Select Automatic to update the selected link automatically each 
time you open a form. 
This is useful if the source file is updated frequently by you or 
other users and you want to keep the linked object current. 

• Select Manual to update only the selected link by using the 
Update Now button in the Links dialog box. 
This is useful if you do not want the linked object to reflect all 
changes made to the source file. 

4. Select a link and click a button to perform a linking procedure: 

• To update the selected link to reflect any changes made to its 
source file, click Update Now.  

• To launch the selected link in its source application, click Open 
Source. 

• To change the source file to which the object is linked, click 
Change Source. The Change Source dialog box appears.  
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Select a new source file for the object and a file type in the Files of type drop-down 
list. Item Name is assigned automatically by the server application, if one exists. 

Click OK to return to the Links dialog box. You can use the Convert... command to 
assign a new name to the object after its source has changed. See “Convert…”. 

• To permanently unlink an object from its source file and convert 
it to a static OLE object, click Break Link . 

 
An object converted to a static OLE object cannot be edited, opened, reconverted, 
or played. 

• The Cancel button changes to Close after you complete a 
linking procedure. 

5. Click Close when you are done. 

Using the Object Commands 

The Object command in the Edit menu is only available when an OLE object is 
selected. It changes according to the selected object. The commands in its 
cascading menu change as well. This section describes each command. 

 

Open 

Choose Open in the Object cascading menu to view a selected OLE object in its 
source application.  

• Linked objects and objects displayed as icons open in the 
source application. Choose Exit in the File menu when you are 
done. 
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• Unlinked objects not displayed as icons open in the window in 
which you created them. Click outside this window when you 
are done. 
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Edit 

Choose Edit in the Object cascading menu to edit a selected OLE object in its 
source application or in the OLE window in which it was created.  

Or, double-click the OLE object to open it.  

• Linked objects and objects displayed as icons open in the 
source application. Edit the object and choose Exit in the File 
menu when you are done. 

• Unlinked objects not displayed as icons open in the window in 
which you created them. Edit the object and click outside the 
window when you are done. 

Convert... 

Use the Convert... command to convert a selected OLE object to another type of 
object or to an icon, to choose a different icon, or to rename an icon. 

1. Select the object and choose Convert... in the Object cascading menu. 
The Convert dialog box appears. 

 
An object converted to a static OLE object cannot be edited, opened, reconverted, 
or played. 

2. Select an option in the Object Type list box. 
The available options depend on the selected object. There may be no 
available options. 

3. Select Display As Icon if you want to display the object as an icon, rather than 
displaying its actual content. 

4. Click Change Icon... when Display As Icon is selected if you want to select a 
new icon or change its name. 
The Change Icon... button appears when Display As Icon is selected. Click it to 
select a new icon for the object or to change the icon’s name. By default, an 
object appears with the object type name if it is unlinked and the source file 
name if it is linked. 

5. Click OK. 
The object is converted. 

Play 

Choose Play in the Object cascading menu to play a selected OLE object in its 
source application or in the OLE window in which it was created.  
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This command is only available for video clip, media clip, and MIDI sequence 
objects. 

• Linked objects and object displayed as icons open in the 
source application. Play the object and choose Exit in the File 
menu when you are done. 

• Unlinked objects not displayed as icons open in the window in 
which you created them. Play the object and click outside the 
window when you are done. .
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Filling a Form 
 

This chapter describes how you or another user would fill out a form created in 
flashFORM. 

This chapter contains the following sections:  

• The Fill View Window 

• Moving Through Fields 

• Filling Fields 

• Spell Checking 

• Saving in Fill View  

You must first open, scan, or import a form in order to fill it. 
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The Fill View Window 

This section provides an overview of the fill view window. 

 If you are in design view, click the Fill button in the design toolbar or choose 
Fill in the View menu to switch to fill view. 

 
To open a shortcut menu, click the right mouse button and choose Fill in this 
menu. 

The fill view window contains a toolbar and seven menus. 

 

Use fill view to enter data in fields, create a records database, import and export 
information to and from records, and print or mail forms. 

See “Managing a flashFORM Database” for detailed information on database 
creation and management. 

The Fill Toolbar 

Use the fill toolbar for basic file operations such as saving and printing. Use it also 
to move through records in a database. 

 

 

Fill tool bar 

The status bar 
displays the 
current activity 

New Save  Form Print  Cut  Paste Fill Highlight  First Record Next  New  
  Assistant  Preview     Fill Areas Record Record Record 
 

 Open Scan Print  Spelling  Copy Design  Zoom Previous Record  Last  Help  
        Record Number  Record 
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All these buttons correspond to menu commands of the same name. Clicking a 
button is the same as choosing its corresponding menu command. 

All corresponding menu commands are explained in online help or in various 
sections throughout this manual (see the index for exact locations). Processes 
such as scanning or opening a form are explained in the Chapter on “flashFORM 
Procedures.” 

You can also drag the fill toolbar to any other location in the flashFORM window. 

Moving Through Fields 

You can click in any field to place the cursor there or you can use the following 
keyboard commands to move the cursor within a form. 

 

Action Key Combination 

Place the cursor in a field When a form first opens, press Tab to place the  
cursor in the first field. 

Next field Press Tab  

Previous field Press Shift-Tab 

Next line in a fill text field Press Enter to move to the next line in a multiple-line 
fill text field  

End of a line in a fill text field Press End  

Beginning of a line in a fill text field Press Home 

End of all text in a fill text field Press Ctrl-End 

Beginning of all text in a fill text field Press Ctrl-Home 

Next word in a field Press Ctrl-right arrow 

Previous word in a field Press Ctrl-left arrow 

 

Filling Fields 

This section describes each type of fillable field in flashFORM, how to fill it, and 
how to check spelling. It contains the following topics: 
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• Type Ahead 

• Shrink Text to Fit Fields 

• Fill Text 

• Comb 

• Check Box 

• Circle Text 

• Table 

• Fill Graphic 

• List Fields 

• Fields Defined by a Calculation 

• Field Validation 

These instructions assume that the cursor is already in a field. 

The way information is displayed in a field depends on the current form language 
selection and the object definition. See “International Settings” and “Defining 
Objects on a Form” for more information. 

Type Ahead 

As you begin to enter a word in a fill text object, flashFORM will automatically 
complete the word. This option works only when there is previously filled 
information that matches the word you are entering. It also works for dates, times, 
and pop-up lists. 

To type ahead: 

1. Choose Options... in the Tools menu.he Options dialog box appears. 

2. Click the Filling tab. 

• Select Enable Type Ahead if you want this option. 

• Deselect Enable Type Ahead if you do not want this option. 

3. Click OK. 

Shrink Text to Fit Fields 

When filling a form, the text you enter may not always fit in the fill text fields. You 
can make your text automatically fit your fields. 

To shrink text to fit fields: 
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1. Choose Options... in the Tools menu. 
The Options dialog box appears. 

2. Click the Filling tab.  

• Select Automatically shrink text to fit within fields if you want this option. 

• Deselect Automatically shrink text to fit within fields if you do not want this option. 

3. Click OK. 

Fill Text 

Enter characters in a fill text field: letters, numbers, symbols, dates, and so forth. 
Fill text fields can contain any sort of textual information. The example below 
shows First Name and Last Name fill text fields. 

              

Comb 

Enter characters in a comb field: letters, numbers, or symbols appropriate to the 
field. Phone numbers and zip codes are commonly used comb fields. A comb field 
consists of individual comb elements. Each element can contain a different number 
of characters. 

 

              

You do not have to tab from element to element in a comb field. Just type the 
required amount of information and flashFORM automatically moves the cursor to 
the next element as appropriate. 

Check Box 

Click a check box field to fill it. A check box field can contain one of three 
elements: a check mark, an X, or a fill. The default value of a check box is an X; 
but you can easily change it to a check mark or a fill. 

Check boxes are commonly used for Yes/No questions and for selecting an item in 
a group, as in the two examples below: 

Prefill  3-Character  Prefill 8-Character  
Element  Element  Element  Element 
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Check boxes may be grouped; this means that only one can be selected. Selecting 
one check box automatically deselects another checked box in the group as in the 
example below. 

                       

To move through grouped check boxes, use the arrow key on your keyboard.  

Circle Text 

Click a circle text field to fill it. A border appears around the filled field. A circle text 
field can contain text and other characters, or it can function much like a check box 
(see the previous section “Check Box”). 

                     

Table 

A table field consists of individual cells. Table cells are fill text fields by default. 
Enter characters in these cells just as you would in fill text fields. 

A table cell can also contain any other type of field, even multiple fields of the 
same or different types. In the example below, the table cells on the right contain 
check box fields. 

Fill Check 
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The user clicks this cell to fill it in the same way as a check box field. See  
“Designing a Form,” for information on tables, converting fields from one type to 
another, inserting objects in table cells, and so on. 
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Fill Graphic 

A fill graphic field contains a graphic you select. You can import an existing graphic 
or you can select a TWAIN-compatible scanner source and scan an image directly 
into the fill graphic field. This section describes both options. 

To import an existing graphic: 

1. Click the fill graphic field or tab to the field and press the Space bar. 
The Fill Graphic dialog box appears. 

2. Select Graphic File in the Source drop-down list. 

   

3. Enter a file name in the File Name text box.  
Or, click Browse... to locate a file. Select a file, and click OK to return to the Fill 
Graphic dialog box. 
The file name appears in the File Name text box. 

4. Select an option in the Options drop-down list. 
 

• Select Maintain Original Size to import the graphic without changes.  

  

• Select Scale Proportionally to fit the graphic in the fill graphic field while maintaining its 
exact proportions. 
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• If you had a 2-inch by 2-inch graphic, for example, and the fill graphic field was 3 inches 
by 3 inches, the graphic would be enlarged to approximately a 3-inch by 3-inch size. It 
would fit in the field and maintain its 1:1 size ratio. 

• Select Stretch to Fit to change your graphic’s original shape and size to fit in the fill 
graphic field  If you had a 2-inch by 2-inch graphic, for example, and the fill graphic 
field was 3 inches by 3 inches, the graphic would be enlarged to approximately a 3-inch 
by 3-inch size. It would fit in the field and maintain its 1:1 size ratio. 

 

 
Depending on the shape of the fill graphic field, your graphic may be stretched or 
compressed. You might want to use this for special effects. 

• If you had a 2-inch by 2-inch graphic, for example, and the fill graphic field was 3 inches 
by 3 inches, the graphic would be enlarged to approximately a 3-inch by 3-inch size. It 
would fit in the field and maintain its 1:1 size ratio. 

• Select Specify Width & Height to specify the graphic’s size. Enter measurements for your 
graphic in the Width and Height text boxes under Size. The size of the fill graphic field is 
displayed at the bottom of the Fill Graphic dialog box  
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If you enter a size larger than the fill graphic field, only part of the graphic will be visible. 

5. Enter offset measurements under Offset. 
This is useful if you want to position a graphic exactly in the field, crop a large 
graphic, or move the graphic away from a field border that would interfere with 
its design. 

• Enter a number in Left to specify how far away from the left side of the field to place the 
graphic. 

• Enter a number in Top to specify how far away from the top of the field to place the 
graphic. 

6. Select or deselect Transparent. 

• Select Transparent if you want to be able to see information behind the graphic. 
Whether a graphic prints transparently depends on your printer driver. See your printer 
documentation for information. 

• Deselect Transparent if you want the graphic to be opaque. You will not be able to see 
information behind the graphic. 

7. Click OK. 
flashFORM imports the graphic and displays it in the fill graphic field. 

To import a graphic from a TWAIN source: 

1. Click the fill graphic field or tab to the field and press the Space bar. 
The Fill Graphic dialog box appears. 

2. Select TWAIN in the Source drop-down list. 

3. Click Select Source to open the Select Source dialog box. 

4. Select your TWAIN source and click OK to return to the Fill Graphic dialog box. 

5. Type a file name in the File Name text box. 
This is the file name the graphic will have after it is scanned and saved 
automatically by flashFORM.
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• Click Browse... if you need to locate a path for the file. 

• Set a path in the Browse dialog box, type a name for the file, and click OK to return to the 
Fill Graphic dialog box. 

6. Follow steps 4 through 6 in “ To import an existing graphic”  on page 164 and 
then return to step 7 on this page. 

7. Place the page with the graphic that you want in your scanner, making sure it 
is aligned correctly. 

8. Click OK. 
flashFORM scans the graphic and displays it in the fill graphic field. 

To delete a graphic from a fill graphic field: 

Select None in the Fill Graphic dialog box to delete a graphic from the form and 
leave the fill graphic field empty. 

List Fields 

Fields can contain a list of selectable entries. A drop-down list arrow appears when 
the cursor is in the field. 

 

Click the arrow to open the list 
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Select an entry. The entry appears in the field. 

Fields Defined by a Calculation 

The only time you would notice a calculation in fill view is when a field fills in 
automatically.  

In the example below, the TOTAL field automatically added the amounts entered in 
the first and second fields. The TOTAL would increase if the third and fourth fields 
were filled as well.  

  

You define a calculation on a field in design view. See “Using Calculations,” for 
detailed information on calculations. 

Field Validation 

Fill text fields can be configured by the creator to: 

• Require that you enter information in a field and do not leave it blank. 

• Require that you enter specific information in a field. 

• Require both of the above. 

• Require that you choose from a list of choices. 

This is field validation and ensures that information entered in a form is consistent. 
For example, you may be required to enter a date in a validated Date field. You 
would receive a reminder prompt from flashFORM if you attempted to enter 
anything other than a date.  
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• Click No to return to the field and enter the expected information. 

• Click Yes to override field validation. 

See “To set validation options for fill text objects:” for detailed information on field 
validation. 

Spell Checking 

Use the spell-checking feature to verify that text field entries are correct. 

 
Before you check spelling make sure you have selected the correct language for 
your form in the Options dialog box as described below. 

Proceed to “ Spell Checking Your Form”  on page 170 if you have a single- 
language form, or the Current Form language selection is correct, or you have a 
dictionary for that language. 

To Check the Current Form Language Selection: 

1. Choose Options... in the Tools menu. 
The Options dialog box appears. 

2. Click the International tab. 

3. Click Current Form. 

The Language selection is grayed out but readable in fill view.  
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4. If the language selection for Current Form is incorrect, click Cancel and 
proceed to “ To Select a Language for Your Form”  on page 19. 

5. Click OK if the language is correct. 
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Spell Checking Multiple Languages 

You may have scanned in a form with the Allow Multiple Languages option 
selected. (See “The Allow Multiple Languages Option”.) You have two choices for 
effective spell checking: 

• Decide which language makes up the majority of your form and select that language as 
the Current Form selection. 
This is faster but less accurate. 

• Spell check only the portion of the form that the Current Form selection matches. Change 
the Current Form selection to match another portion of the form, spell check that portion, 
and so on for each language in the form. 

This is more time-consuming but more accurate. Remember that changing the 
Current Form selection could cause flashFORM to reformat data already entered 
in fill view. 

Dictionaries for Spell Checking 

Dictionaries for all supported languages are included in the International English 
version of flashFORM. The United States version has a standard English 
dictionary. You can call 1-800-654-1187 to order additional dictionaries. You must 
have a dictionary that matches the language of a form to spell check it. 

Spell Checking Your Form 

flashFORM has two ways to spell check your form. 

• flashFORM automatically places a red wavy line under misspelled words and double 
entries. You simply right-click the error and select the correction from the menu that 
appears. 
If you want to turn off this automatic spell checker, choose Options... in the Tools menu. In 
the dialog box that appears, select the Spelling tab. Deselect Check spelling automatically 
to turn off the automatic spell checker. 

• You can also check the spelling of your form by using the Spelling dialog box.  

To spell check your form: 

1.  Click the Spelling button in the fill toolbar or choose Spelling... in the Tools 
menu. 
The Spelling dialog box appears with the first questionable word after 
Unknown Word. 
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• The suggested spelling, if there is one, appears in the Change To text box. 

• Other suggested spellings appear in the Suggestions list box. 

2. Click one of the following options: Ignore, Ignore All, Change, Change All, Add, 
or Suggest. 

3. Click Close to end the spell check. 

4. Click OK in the dialog box that tells you the spell check is done. 

Saving in Fill View 

flashFORM automatically saves in fill view. flashFORM saves after numerous user 
actions, such as, moving from one record to another, printing or closing a form, 
before importing or exporting data, and in many other situations. You would rarely 
need to use the Save command in fill view except to: 

• Save changes to the entire form, both changes made in design view and data entered in 
fill view. 

• Save information entered in the Print offsets for data option in the Print dialog box. 

Use the Save As... command in fill view to save a form to another location or with a 
different file name. 
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Managing a flashFORM Database 
 

This chapter introduces basic database concepts, including the following sections: 

• What is a Database? 

• Managing Database Records 

• Protecting Your Database 

See “Designing a Form,” for detailed information on defining fields in a form so that 
all your records contain the proper information. 

See “Using Calculations,” for detailed information on using calculations. 
Calculations automate data entry and reduce potential user errors. 
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What Is a Database? 

A database is a collection of information stored as individual records. Each record 
uses the same form design but can contain different information in its fields. 

flashFORM automatically creates a database when you scan in or import a form. 
As soon as you fill in the form, it becomes the first record in a new database. Any 
user of this database can create a new, blank form using the record as a template 
and then filling in new information to create another record. This makes it possible 
to store a large amount of similar information and retrieve it quickly and easily. 

 

Managing Database Records 

This section tells you how to create a database of records and manage its 
information. It contains the following topics: 

The user who 
designed this daily 
planner creates a 
new record every 
day. So far, this 
user has a 
database 
containing three 
records. 

 
The user can sort these 

Record 1 
 
 
 
 
 
 
Record 2 
 
 
 
 
 
 
 
Record 3 
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• Creating New Records 

• Duplicating Records 

• Moving Through a Database 

• Searching Records for Information 

• Sorting Records 

• Recalculating Records 

• Deleting Records 

• Refreshing Records 

• Saving Records 

• Exporting Information 

• Using flashFORM Data Files 

• Importing Information 

The form you open or scan in becomes the first record of a new database as soon 
as you fill in a field. You can then create new records with the same layout and 
fields and fill them with different information. See “flashFORM Procedures,” if you 
do not know how to open or scan in a form. 

For step-by-step instructions on creating a database and performing basic 
functions, see the online tutorials. 

Creating New Records 

As long as you have a form open and fill at least one field in the current record, 
you can create new records. 

 
You cannot create a new record if data protection is turned on. See “ Protecting 
Your Database” for more information. 

To create a new record: 

1.  Open or scan in a form. 

2. If the form opens in design view, click the Fill button in the design toolbar or 
choose Fill in the View menu to switch to fill view. 
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3. Click in a field with the cursor or press Tab to place the cursor in the first 
fillable field. 

4. Enter information in the field. 

 
flashFORM cannot create a new record until you fill at least one field in an empty 
form. A form with fields filled only by automatic calculations (such as a date field) is 
still considered empty by flashFORM. You must fill at least one field manually 
before you can create a new record. 

5. Press Tab to move to the next field. 
Because a field is filled, you now have a database with one record in it. 

6. Fill in as many fields as you like. 
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7.  Click the New button in the fill toolbar or choose Go To in the Records 
menu and New in its cascading menu. 
flashFORM creates and displays a new, empty record with the same form 
design as the first one. 

8. Fill in this record with the appropriate information. 

9. Continue to create new records in this way as necessary. 

Duplicating Records 

You can duplicate any record in a database as long as it has information entered in 
at least one field. This is useful if you want to create records that will contain much 
of the same information. 

A form with fields filled only by automatic calculations (such as a date field) is still 
considered empty by flashFORM. You must fill at least one field manually before 
you can create a new record. 

 
You cannot duplicate a record if data protection is turned on. See “ Protecting Your 
Database” for more information. 

To duplicate a record: 

1. Open or scan in a form. 
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2.  If the form opens in design view, click the Fill button in the fill toolbar or 
choose Fill in the View menu to switch to fill view. 

3. Fill in the information that you want duplicated. 

4. Choose Duplicate Record in the Records menu. 
flashFORM duplicates and displays the new record. 

To change an entry in a filled field, tab to a field or drag your cursor over the entry 
to highlight it and then type a new entry. 

Moving Through a Database 

Once you have multiple records, use the Record buttons in the fill toolbar or the 
commands in the Records menu to move through a database. 

 

                        

 

First Record 

 Click the First Record button or choose Go To in the Records menu and First 
in its drop-down menu to move to the first record in your database.  

Previous Record 

 Click the Previous Record button or choose Go To in the Records menu and 
Previous in its drop-down menu to move to the record that is before the one you 
are viewing. If you are viewing record 3, for example, the previous record is record 
2. 

Record Number 

 The Record Number text box displays the number of the current record.  

To move to another record: 

1. Highlight the number in the Record Number text box. 

2. Type a new number. 

3. Press Enter to move to that record.  

 

First Record Previous Record Record Number Next Record Last Record New Record 
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Next Record 

 Click the Next Record button or choose Go To in the Records menu and Next 
in its drop-down menu to move to the record that is after the one you are viewing. 
If you are viewing record 3, for example, the next record is record 4. 

Last Record 

 Click the Last Record button or choose Go To in the Records menu and Last 
in its drop-down menu to move to the last record in your database. 

New Record 

 Click the New Record button or choose Go To in the Records menu and New 
in its drop-down menu to create and move to a new record. 

Searching Records for Information 

A database can contain a tremendous amount of information. If you had to search 
manually through hundreds of records in your database to find a particular record, 
it could take hours. A flashFORM search, however, can retrieve records with the 
information that you need in seconds. 

These retrieved records are called a found set. You can print, mail, or export the 
found set if you wish. 

To search for information: 

1.  If you are in design view, click the Fill button in the fill toolbar or choose 
Fill in the View menu to switch to fill view. 

2. Choose Search... in the Records menu. 
The Search dialog box appears. 

 

3. Select a field name in the Field Name drop-down list. 
This is the field that contains the information you want to find. All the fields in 
your form are listed here. 

The field to search 
 
How to search 
 
What to search 
 
 
 
Which records to search 
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To simplify searches, give each field a more descriptive name. Otherwise, you will 
have fields named FillText1, FillText2, and so forth, making it difficult to determine 
which fields contain what information. “Defining Objects on a Form” for detailed 
information. 

4. Select a condition in the Condition drop-down list. 
A condition describes how to look for information entered in the Value text box. 
For example, suppose you entered the words Franich & Halsey in the Value 
text box.  
The following bulleted items show the results of a search using each available 
condition option.  

• is equal to: find an exact match of the Value entry. 
This finds records that have Franich & Halsey and nothing else 
in the Customer field. Make sure you have no extra spaces 
after your entry. If, for example, you typed in an extra space, 
then flashFORM would search for the Franich & Halsey entry 
plus a space. 

 

• is not equal to: find anything but the Value entry. 
This finds records that have anything but Franich & Halsey in 
the Customer field. 

 

• is greater than: find records of greater value than the Value 
entry. 
This finds records that have entries in the Customer field later 
in the alphabet than the entry, for example, Franklin or 
Gallatron, Inc. 

 

• is greater than or equal to: find records of equal or greater 
value than the Value entry. 
This search finds records that have entries in the Customer 
field beginning with the entry name itself up to the letter Z.  
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• is less than: find records of lesser value than the Value entry. 
This finds records that have entries in the Customer field 
beginning with a symbol, a number, or letters earlier in the 
alphabet than the entry, for example, France or Dharma Dogs.  

 

• is less than or equal to: find records of equal or lesser value 
than the Value entry. 
This finds records that have entries in the Customer field 
beginning with a symbol, a number, or the letter A up to the 
entry name itself. 

 

• begins with: find records that begin with the Value entry. 
This search finds records that have Franich & Halsey as the 
entry or at the beginning of an entry in the Customer field. 

 

• does not begin with: find records that do not begin with the 
Value entry or that do not contain the value entry at all. 
This search finds records that do not have Franich & Halsey as 
the beginning of the entry in the Customer field or records that 
do not contain Franich & Halsey at all. 

 

• ends with: find records that have the Value entry at the end of 
the selected field. 
This search finds records that have Franich & Halsey as the 
entry or at the end of an entry in the Customer field. 

 

• does not end with: find records that do not have the Value entry 
at the end of the selected field or records that do not contain 
the value entry at all. 
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This search finds records that do not have Franich & Halsey at 
the end of an entry in the Customer field. 

 

• contains: find records that contain the Value entry. 
This search finds records that have Franich & Halsey entered 
anywhere in the Customer field. 

   

 
Be careful when selecting contains as one of your conditions. In a search for the 
value male, for example, your search would include any records that contained the 
word male. It would, therefore, also include records for female.  

• does not contain: find records that do not contain the Value 
entry. 
This search finds records that do not have Franich & Halsey 
entered anywhere in the Customer field. 

 

• is empty: find records that have no entry in the selected field. 
The Value text box is disabled if this is selected. 

 

• is not empty: find records that have an entry of any sort in the 
selected field. 
The Value text box is disabled if this is selected. 

 

5. Type the text to find in the Value text box. 

Information is not case-sensitive. Typing Los Gatos is the same as typing los 
gatos. 

How flashFORM searches for the information in the Value text box depends on the 
selection in the Condition drop-down list as described in the previous step. 
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6. Select an option under Scope of Search. 

• Select Search All Records in the Database to search the entire 
record set. 

• Select Only Search Current Record Set to search a subset of 
records. This option is only available when you have a found 
set open from a previous search. 

7. Click OK. 

flashFORM searches for and retrieves all records that contain the information you 
specified in the Search dialog box.  

                             

Under the fill toolbar, flashFORM displays the search information and number of 
records in the found set. If you need to narrow the search further, choose Search... 
again. 

You might, for example, want to search the Franich & Halsey record set for 
invoices from a specific month. You can search each new subset of records as 
many times as you need to find the specific information you want. 
flashFORM maintains the current found set if it retrieves no records during a 
search. 

8. Click Clear Search under the fill toolbar to return to the full record set when 
you are done. 



Forms Design User’s Guide 
Managing a flashFORM Database 

184   flashFORM Designer User’s Guide 

Sorting Records 

You can sort records in flashFORM in ascending, descending, or original order 
entry. This is useful for many situations. If you wanted to export mailing 
information, for example, you could sort records by postal code to reduce bulk 
mailing costs. Or, you might want to sort invoices by date to find the most 
delinquent accounts. 

You can print, mail, or export this information in the order in which it is sorted. 

To sort records: 

1.  If you are in design view, click the Fill button in the design toolbar or 
choose Fill in the View menu to switch to fill view. 

2. Choose Sort... in the Records menu. 
The Sort dialog box appears. 

                               

3. Select the field by which to sort in the Field Name drop-down list. 
All the fields in your form are listed here. 

 
To make sorting as easy as possible, give each field a unique name after it is 
created. Otherwise, you could have fields named FillText1, FillText2, and so forth, 
making it difficult to figure out which fields contain what information. See “ Defining 
Objects on a Form”  for detailed information. 

• Select a sort order. 

• Select Ascending Order to sort records from least to greatest; 
for example, from A–Z or from 0–100. Symbols precede 
numbers which precede letters: $40, 40, Forty. 

• Select Descending Order to sort records from greatest to least; 
for example, from Z–A or from 100–0. Letters precede numbers 
which precede symbols: Forty, 40, $40. 
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• Select Original Order Entered to sort records in the order in 
which you originally entered information in the selected field. 
This is useful to view the history of information entered. 

4. Click OK. 
flashFORM sorts the records in the order indicated. 

Recalculating Records 

Recalculating records applies any new or changed calculations to selected records 
in a database. Until you use the Recalculate... command, new or changed 
calculations apply only to new records. 

See “Using Calculations,” for detailed information on creating calculations. 

 
This command reapplies all existing calculations to the selected records. You may 
not always want this to happen. 

For example, suppose you changed the mileage calculation in an expense form to 
reflect the latest rate. All new records would use the new calculation and reflect 
this rate. You do not want older records to use the new calculation because the 
original rate was correct at the time. 

If you recalculated all records after adding the new calculation to the expense 
form, the mileage rates on your old records would also change. They would then 
be incorrect. To prevent this, you could search the records for those records newer 
than the date that you changed the mileage calculation, and apply the new 
calculation only to the newer records. 

See “ Searching Your Database”  for information on searching. 

 
You cannot recalculate records if data protection is turned on. See “ Protecting 
Your Database”  for information. 

To recalculate records: 

1.  If you are in design view, click the Fill button in the design toolbar or 
choose Fill in the View menu to switch to fill view. 

2. Choose Recalculate... in the Records menu. 
The Recalculate dialog box appears. 
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3. Select the records to recalculate. 

• Select All Records to apply the new or changed calculation to 
either the current found set or to every record in the database if 
the entire record set is open. 

• Select Current Record Only to apply the new or changed 
calculation to just the record you are viewing. 

• Select From/To to apply the new or changed calculation to a 
range of records. 
Enter a number in the From and To text boxes. If you entered 1 
in the From text box and 5 in the To text box, for example, 
flashFORM would recalculate the first five records in your 
database or found set. 

 
You cannot undo a recalculation. 

4. Click OK. flashFORM recalculates the records according to your specifications. 

5. Click OK in the dialog box that informs you how many records were 
recalculated successfully. 

 

Deleting Records 

This section describes how to delete one or more records in a database. Use this 
command to get rid of old, unwanted, or duplicate records. 

 
You cannot undo a record deletion. 
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You can export information from a record first if you want to delete a record but 
save its data. See “ Exporting Information”  for instructions. 

 
You cannot delete a record if data protection is turned on. See “ Protecting Your 
Database” for information. 

To delete the current record: 

1.  If you are in design view, click the Fill button in the design toolbar or 
choose Fill in the View menu to switch to fill view. 

2. Choose Delete Record in the Records menu.A warning dialog box appears.  

3. Click Yes to delete the current record permanently. 

To delete all records: 

1.  If you are in design view, click the Fill button in the design toolbar or 
choose Fill in the View menu to switch to fill view. 

2. Choose Delete All Records in the Records menu. 
A warning dialog box appears.  

3. Click Yes to delete all the records permanently. 

To delete a found set of records: 

1.  If you are in design view, click the Fill button in the design toolbar or 
choose Fill in the View menu to switch to fill view. 

2. To delete a found set of records instead of all records, click Search... in the 
Records menu to find the records to delete. 
See “ Searching Records for Information”  for more information. 

3. Choose Delete All Records in the Records menu. 
A warning dialog box appears.  

4. Click Yes to delete the found set of records permanently. 

Refreshing Records 

You refresh records to see if records have been updated. You can refresh records 
in a form that is currently open. This option is available only in fill view and when 
the form has sharing properties.  

For more information about how to create a form with sharing properties, see “ 
Setting Attributes for a Form”. 
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To refresh a record or records: 

1.  If you are in design view, click the Fill button in the design toolbar or 
choose Fill in the View menu to switch to fill view. 

2. Choose Refresh Record or Refresh All Records in the Records menu.  
If you have chosen Refresh all Records, flashFORM automatically checks to 
see if any record has been updated and displays the freshest records. If you 
have chosen Refresh Record, flashFORM automatically checks to see if the 
record has been updated and displays the freshest record.  

Saving Records  

You can save your current record anytime during the filling-out process. This 
option is useful when you are filling out long forms. You do not need to finish filling 
out a form before you can save a record of it. Records are automatically saved 
when you move from record to record. 

To save a record: 

1.  If you are in design view, click the Fill button in the design toolbar or 
choose Fill in the View menu to switch to fill view. 

2. Choose Save Record in the Records menu. 
flashFORM saves your record to the database. 

Exporting Information 

This section explains the benefits of exporting information, how to prepare for 
export, and how to export information from an open flashFORM form. 

See “ Importing Information” for information on how to import information into a 
database. 

The Benefits of Exporting Information 

Export information from records to: 

• Share information with other flashFORM databases.  
Information exported as a database file takes up considerably 
less disk space than the database itself. It can be copied or 
mailed more quickly than the entire database. 

• Share information from different databases. 
For example, you might have a FoxPro database and decide 
that you need information already entered in a flashFORM 
database. Simply export the needed information from 
flashFORM in the appropriate format and use FoxPro’s 
commands to import it. 
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• Save other database users the time of entering data manually 
by sending them a flashFORM Data or other database file. 

Preparing for Export 

During import, you will link  field names in the exported data file to field names in 
the import database. This tells flashFORM where to place the field information. If 
possible, try to: 

• Match field names in the exported data to field names in the 
import database. 

• Match field order in the exported data to field order in the 
import database. 

This makes it easier to figure out which information will go in which fields when you 
link the fields on import. 

For example, suppose you export information in the fields Customer, Title, and 
Product, in that order. You have the same field information in the import database, 
but the fields are named What Bought, Name, and Position, in that order. You 
could link Customer4Name/Title4Position/Product4What Bought easily but 
importing hundreds of fields with different names and field order would be difficult 
and time-consuming. 

See “Designing a Form,” for information on naming and reordering fields. 

To export information: 

1.  If you are in design view, click the Fill button in the design toolbar or 
choose Fill in the View menu to switch to fill view. 

2. Choose Export... in the File menu. 
The Export Setup dialog box appears. 
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3. Select a database file type in the Export To drop-down list. 

• Select flashFORM Database to export information to a 
flashFORM Data file. 

• Select ODBC Database to select a data source in the Available 
Data Sources list box. 
See “ ODBC Database” for more information on this dialog box. 

4. Click OK. The Export As dialog box appears. 

 

• A file name appears in the File name text box. 
The file is named by default with the name of the currently 
open database. You can change the file name if you want. 

• The database file type you selected in the previous dialog box 
appears in the Save as type drop-down list.  

5. Use the Save in drop-down list to select a location for the file. 

6. Click Save. 
The Export dialog box appears. 

                            

All the fields in your currently open database appear in the Fields in list box. 
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7. Select each field that contains the information to export and click Add>> to 
move it to the Fields to Export list box. 

                               

• Shift-click to select or deselect multiple adjacent records, or 
hold down the mouse button and drag the cursor over adjacent 
records. 

• Ctrl-click to select or deselect multiple nonadjacent records. 

• Select a field on the right and click <<Remove if you decide not 
to export its information. 

8. If you want to specify a range of records to import, click Range... to open the 
Record Range dialog box. 

 

 
Otherwise, flashFORM exports all records by default. 

• Select All Records to export all records in the current database. 

• Select Current Record Set to export the current found set of 
records. This option is available after a search. 
Type the first record number to export in the From text box and 
the last record number to export in the To text box. 

• Click OK to return to the Export dialog box. 
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9. Click OK. 
flashFORM exports the information in the selected fields to the specified file. 

10.  Click OK in the dialog box that tells you how many records were successfully 
exported. 

ODBC Options 

Installed ODBC database drivers appear in the Available Data Sources list box 
when you select ODBC Database in the Export To drop-down list. Depending on 
your database driver, you can export up to 255 fields at a time. 

                        

To export your data to an available data source: 

1. Choose Export in the File menu. 
The Export Setup dialog box appears. 

2. Select ODBC Database in the Export To drop-down list. 

3. Select a source from the Available Data Sources list box and click OK.  
An Export As dialog box appears.  

4. Enter a file name in the File name text box if it does not appear automatically. 
The database file type that you selected in the previous dialog box appears in 
the Save as type drop-down list. 

5. Follow steps 6 through 10 in the previous section “To export information.” 

Using flashFORM Data Files 

This section explains how to use flashFORM Data files to open shared forms and 
how to set up a shared form location. A shared form is one other users can 
access. 
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When you export flashFORM data from a form, the form’s file name is stored 
inside the Data file. flashFORM uses the file name information as well as pathway 
information in the Options dialog box to locate and open a copy of the original 
form. The form automatically imports information from the Data file. This is useful 
for sharing data, especially if you want to send another user just part of a 
database. 

To set up the shared form location: 

1. Select or create a folder for your shared flashFORM forms. 
You can make the form read-only so users can only open a copy of the form, 
not the original. 

2. In flashFORM, choose Options... in the Tools menu. 
The Options dialog box appears. 

3. Click the File Locations tab. 

4. Select Shared Forms in the File Types drop-down list. 

5. Type the path to your shared form(s) in the Location text box. 

6. Click OK. 

 
All flashFORM users must type the same pathway in the Options dialog box to 
use shared forms in that location. 

To export the data: 

• Use the Export... command in the File menu to create a 
flashFORM Data file. See “ Exporting Information” for 
information. 

• Use the Send... command in the File menu in fill view to mail 
data (as an attached flashFORM Data file) to another user. See 
“ Mailing a Form” for more information. 

To use a flashFORM Data file to open a shared form: 

1. Locate the flashFORM Data file to use. 

2. Double-click the file or select it and choose Open in its folder’s File menu. 
A copy of the shared flashFORM Form from which the flashFORM Data file 
was exported opens. flashFORM automatically imports the information in the 
flashFORM Data file into the form. 

Importing Information 
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This section explains how to import field data (information) into a flashFORM 
database from another database source. You can import data from four sources:  

• Another flashFORM Form 
The selected form must be closed. 

• A flashFORM Data file 
This contains information exported from a flashFORM 
database. 

• Any supported database source, such as FoxPro 

• Available sources depend on the installed database drivers. 

• A flashFORM Mailable Filler 

Data consists of information entered in fields, such as text, check marks, and 
calculations. Importing data saves you the time of entering the same data manually 
and allows you to share data with other database users. 

You must first export data from another database in order to import it into 
flashFORM. See “ Exporting Information” for information. See your database 
documentation if you are exporting from another database program.  

 
You cannot import information if data protection is turned on. See “ Protecting Your 
Database” for information. 

To import field information: 

1. Open or scan in a form. 

2.  If you are in design view, click the Fill button in the design toolbar or 
choose Fill in the View menu to switch to fill view. 

3. Choose Import... in the File menu. 
The Import Setup dialog box appears. 
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4. Select the type of database information to import in the Import From drop-
down list. 

• Select flashFORM Database to import information from a 
flashFORM Form or from a flashFORM Data file. 

• Select a data source in the Available Data Sources list box to 
import files from another database source. 
You can also add, delete, and set up data sources. 

5. Click OK. 

The type of dialog box that appears next depends on the type of database file you 
have selected. The Select Import Files dialog box appears if you have selected 
flashFORM Database. 

 

A flashFORM Data (OFD) file has a different icon than a Form (OFM) file. The first 
New Address file in the picture above is a data file. 
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6. Locate and select a Data file to import. 

7. Click OK. 
Depending on the database source you have chosen, more dialog boxes may 
appear. Select the appropriate options. 
The Import dialog box appears after you select a file. 

 

• Fields in the open flashFORM database appear on the left. 

• Fields you can import from the other database appear on the 
right. 

8. Link fields on the left to fields on the right. 
This tells flashFORM which field data to import from the other database and 
where to import it in the current database. 

• To link individual fields, select a field on the left, select its 
corresponding field on the right, and click Link . 

• Click Auto to automatically link all fields with the same name. 
Linked fields appear in the Links list box. 
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• Select a link in the Links list box and click Unlink  to unlink it. 

• Click Unlink All to unlink all fields. 

• Select Recalculate Imported Records According to Form’s 
Calculations when it is selectable to apply existing calculations 
to the imported records. 

9. Click Range... to open the Record Range dialog box to specify a range of 
records to import. Otherwise, flashFORM imports all records by default. 

 

• Type the first record number to import in the From text box and 
the last record number of the range to import in the To text box. 

• Click OK to return to the Import dialog box. 

10.  Click OK when you are done linking fields. 
flashFORM imports the information into the selected fields, creating as many 
new records as necessary in the process.  

11.  Click OK in the dialog box that tells you how many records were imported 
successfully. 



Forms Design User’s Guide 
Managing a flashFORM Database 

198   flashFORM Designer User’s Guide 

Protecting Your Database 

It is important to protect information and form design in your database. This section 
describes how to use the flashFORM protection options to protect both your data 
and form design from potential deletions or changes, as well as the benefits of 
using the flashFORM Filler program. 

 
If your flashFORM database has an administrator, check with the administrator first 
before making any changes. 

Protecting Data 

Many databases have multiple users. Until a user is familiar with database 
concepts and how to use flashFORM, you may want to protect the information 
(data) entered in fill view from deletion or change. 

To protect your data: 

1.  If you are in fill view, click the Design button in the fill toolbar or choose 
Design in the View menu to switch to design view. 

2. Choose Protection... in the Tools menu. 
The Protection dialog box appears. 

 

3. Select Protect Data. 

4. If you wish, type a password in the Password text box. Passwords are case 
sensitive. You will be prompted to reenter your password for confirmation. The 
next time anyone tries to change the data, a dialog box appears, informing the 
user of the form’s protection status. The user will not be able to make any 
changes unless the user knows the password and can turn off the protection. 

 
If you lose or forget your password, it cannot be recovered. 
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5. Click OK. 
Information in fill view is now read-only. All the commands and buttons 
associated with protected operations are grayed out. 

6.  Click the Fill button in the fill toolbar or choose Fill in the View menu to 
switch to fill view. 

7. Place your cursor in a fill text field and try to type text. 
A dialog box appears. 

 

8. Click OK to close the dialog box. 

Users can export data or copy text in protected mode but cannot alter form 
information in any other way such as by filling fields or importing data. 

Repeat steps 1–4 in the preceding instructions but deselect Protect Data in the 
Protection dialog box to turn off data protection. 

Protecting the Form 

The form layout you create in design view is used by every record in a database. 
Any change made in design view affects all records in fill view. This is important to 
remember if the database has multiple users. 

 
Deleting a fillable field in design view deletes all information entered in that field in 
fill view. 

To protect your form: 

1.  If you are in fill view, click the Design button in the fill toolbar or choose 
Design in the View menu to switch to design view. 

2. Choose Protection... in the Tools menu. 
The Protection dialog box appears. 
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3. Select Protect Form. 

4. If you wish, type a password in the Password text box. Passwords are case 
sensitive. You will be prompted to reenter your password for confirmation. The 
next time anyone tries to change the form’s design, a dialog box appears, 
informing the user of the protection status. The user will not be able to make 
any changes unless the user knows the password and can turn off the 
protection. 

 
If you lose or forget your password, it cannot be recovered. 

5. Click OK. 
The drawing toolbar and many buttons in the design toolbar are now grayed 
out. All the menu commands associated with these buttons are grayed out as 
well. 

6. Click anywhere on the form. 
A dialog box appears.  

 

7. Click OK to close the dialog box. 

Users can change viewing preferences and use most basic file commands such as 
Print and Save but cannot format or redesign the form in any way. 

Repeat steps 2–4 in the preceding instructions but deselect Protect Form in the 
Protection dialog box to turn off form protection. 
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flashFORM Filler 

flashFORM Filler is an easy-to-use version of flashFORM that contains a fill view 
but no design view. Therefore, flashFORM Filler users can open and fill forms 
created in flashFORM (without having flashFORM installed on their systems), but 
cannot edit the form’s design in any way. 

The data protection option, when set for a form in flashFORM, is also enabled for 
that form in flashFORM Filler. It cannot be turned off in flashFORM Filler. 

See “ Protecting Data”  for detailed information on the data protection option. 

flashFORM Filler is included on your flashFORM CD-ROM. However, before you 
can use flashFORM Filler you must purchase an unlock code. To obtain an unlock 
code in the U.S. or to purchase additional versions of flashFORM Filler, please call 
(800) 693-3933.  
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Using Calculations 
 

This chapter describes how to use flashFORM’s calculation features. flashFORM 
automatically performs calculations when you fill in the appropriate fields. 

Use calculations to automate data entry and prevent errors. For example, the 
average person might find it time-consuming to add a column of 100 numbers, and 
easy to make an error, but flashFORM can return an error-free sum in a fraction of 
a second. All you have to do is define the calculation properly and flashFORM 
does the rest of the work. 

This chapter contains the following sections: 

• Calculation Overview 

• Operators 

• Functions 
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Calculation Overview 

This section gives an overview of how to create calculations. It contains the 
following topics: 

• Creating a Calculation 

• Calculation Guidelines 

• Using the Recalculate… Command 

• Usage Conventions 

See the online tutorial for step-by-step instructions on creating a simple 
calculation. 

Creating a Calculation 

Calculations are created in design view. You can create a calculation for fill text, 
comb, check box, and circle text objects. 

You must open the calculation toolbar to begin. 

To open the calculation toolbar: 

1.  If you are in fill view, click the Design button in the fill toolbar or choose 
Design in the View menu. 

2.  Click the Calculation button in the design toolbar or choose Calculation in 
the Tools menu. 
The calculation toolbar appears. 

 

 

 

 

 

3. Select a fill text, comb, check box, circle text, or table object in your form to 
activate the toolbar. 
The calculation toolbar contains five buttons and a text box. 

Accept Calculation Calculation List  Auto Calculation 
 
 
 
 
 
 
Cancel Calculation Calculation Builder Click to Edit Calculation – the calculation  
  For the selected field appears here.  
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•  Cancel Calculation button 
Click this to revert to the last calculation accepted. The text box clears if no version was 
accepted. 

•  Accept Calculation button 
Click this to accept the calculation in the text box. 

•  Calculation List button 
Click this to open the Calculation List dialog box and view all your calculations. 

•  Calculation Builder button 
Click this to open the Calculation Builder dialog box and create your own calculation. 

•  Auto Calculation button 
Click this to have flashFORM attempt to define a calculation automatically. flashFORM 
can determine an auto calculation for an entire table in some circumstances. 

• Calculation text box 
The calculation for the selected field appears here. Click in the text box to edit a 
calculation manually. 

4. Create a calculation in one of three ways: 

• Use the Calculation Builder to define a calculation. 
See “The Calculation Builder”. 

• Have flashFORM define a calculation automatically. 
See “Auto Calculations”. 

• Click in the calculation text box and type a calculation.Follow the guidelines in “ 
Calculation Guidelines”. See “Functions”  examples. 

You can also use the Calculation List dialog box to change your calculations. 

The Calculation Builder 

The Calculation Builder dialog box contains operators, a list of all the fields in your 
form, and functions for creating calculations. 

To define a calculation with the Calculation Builder: 

1.  Click the Calculation Builder button in the calculation toolbar. 
The Calculation Builder dialog box contains the following: 

• Operator buttons 
Each button represents an operator. Click a button to insert an operator in the calculation 
text box. 
See “ Operators” for detailed information. 
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• Fields list 
This list contains all the available fields in your form. Double-click a field name in this list 
to place it in the calculation text box, or select it and click Paste. 
Or, click any field in your form to insert its name in the calculation text box. This is useful if 
you have many fields listed or if they do not have unique names. You can also drag the 
cursor around multiple objects to insert each one. 

• Functions list  
This list contains all available functions that can be used in a calculation. (Functions are 
sorted by category. Click the plus sign in front of a category to open it.) Double-click a 
function to insert it in the calculation text box, or select it and click Paste. 
See “ Functions” for detailed information. 

 

2. Select the operators, fields, and functions that you need for your calculation. 

3.  Click the Accept Calculation button to define the calculation on the field 
and close the Calculation Builder dialog box. 

• A calculation is defined on the selected field when you click the Accept Calculation button. 
flashFORM performs the calculation automatically in fill mode when the appropriate fields 
are filled. 

•  You can click the Cancel Calculation button to clear the calculation text box or to 
revert to the last accepted calculation. 

• You can manually delete entries in the text box and click the Accept Calculation button if 
you want to clear the box entirely. This is useful if clicking the Cancel Calculation button 
causes it to revert to a previously accepted version. 

4.  Click the Calculation button in the design toolbar or choose Calculation in 
the Tools menu to close the calculation toolbar. Closing the toolbar also 
accepts the current calculation. 

Operators 
 
 
 
 
 
 
 
List of fields in your form 

List of available functions 
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Suppose you wanted to create a calculation for a Subtotal field in an invoice. The 
Subtotal field is the sum of the Price1 and Price2 fields. There is often more than 
one way to create a calculation. Here are two calculations you could create: 

• [Price1]+[Price2]  

• Sum([Price1],[Price2])  

Both calculations return the same result. The first calculation is simple addition. It 
is easy for new users to create. 

The second calculation uses the Sum function and is more complex than the first 
calculation. This calculation is useful for adding multiple fields because you do not 
need to place the Addition operator between them. 

 
flashFORM automatically inserts the necessary parentheses, brackets, 

and commas when you create a calculation using the Calculation Builder. See “ 
Calculation Guidelines” . 

Auto Calculations 

To create an auto calculation, flashFORM looks for such common field names as 
Quantity, Price, Total, and Sum. It also determines calculations based on field 
type, field names, and column header labels. If you selected a field named Total, 
for example, flashFORM would look for fields above the Total field to sum. 

This is one reason it is important for fields to have unique names. See “Defining 
Objects on a Form”  for detailed information. 

To create an auto calculation: 

1. Select a fill text, comb, check box, circle text, or table object in your form to 
activate the toolbar. 
A calculation appears in the calculation text box if one was defined for this 
object before. If so, proceed to step 4. 

2. If no calculation appears, click the Auto button in the calculation toolbar. 
A message appears if an auto calculation could not be created. See “The 
Calculation Builder”  if flashFORM could not create a calculation and you want 
to create your own. 

The Auto Calculation dialog box appears if flashFORM proposes an auto 
calculation.   



Forms Design User’s Guide 
Using Calculations 

208   flashFORM Designer User’s Guide 

                              

3. Accept or cancel flashFORM’s proposed calculation. 

• Click OK to accept the calculation. 
The calculation appears in the toolbar’s text box. 

• Click Cancel to close the dialog box without creating a calculation. 

4. Edit the calculation in the toolbar if necessary: 

• Click in the calculation text box and make manual changes, or click the Calculation Builder 
button to open the Calculation Builder dialog box. See “ The Calculation Builder”. 

•  Click the Accept Calculation button to accept changes. 

•  Click the Cancel Calculation button to close the Calculation Builder and revert to the 
version created by flashFORM. 
You can manually delete entries in the text box and click the Accept Calculation button to 
clear the box entirely. This is useful if clicking the Cancel Calculation button causes the 
calculation to revert to a previously accepted version. 

5. Choose Calculation in the Tools menu to close the toolbar. 

The Calculation List 

The Calculation List dialog box lists all of your form’s calculations and allows you 
to make changes to the calculations.  
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To change your calculations: 

1.  Click the Calculation List button in the calculation toolbar. 
The Calculation List dialog box appears. 

2. Double-click the Field Name that you want to change. Or, select the Field 
Name that you want to change and click Edit. 

3. The calculation that you want to change appears in the Calculation Edit text 
box.  

4. Make any changes that you want. 

5.  Click the Accept Calculation arrow to apply the change. 
flashFORM automatically makes the change. 

Using the Recalculate... Command 

Recalculating records applies any new or changed calculations to all selected 
records in a database. Until you use the Recalculate... command, new or changed 
calculations apply only to new records or to current records whose relevant field 
entries change. 

See “ Recalculating Records”  for detailed information. 

Calculation Guidelines 

Keep these guidelines in mind as you work with calculations: 

• Brackets ( [] ) must enclose a field name that contains a space.  
[Quantity Ordered] * [Unit Price] 
flashFORM will not accept the calculation otherwise. 
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• Parentheses ( () ) must enclose an entire function. 
Sum([Price1],[Price2]) 
This tells flashFORM where the function begins and ends. You may have more than one 
function in a calculation. 

• You must insert a list separator between fields in a manually created function. 
Sum([Price1],[Price2]) 
Use the list separator from the Windows Control Panel. 
Use the List Separator selection in the Number tab of the Regional Settings control panel.  

• flashFORM automatically inserts list separators, parentheses, and brackets when you use 
the Calculation Builder or the Auto button to create a calculation, and when you click the 
Accept Calculation button to accept a calculation. 
See the previous bulleted item for an explanation of the list separator flashFORM uses. 

• flashFORM does not automatically insert brackets around a manually created field name 
that contains a space. You must insert brackets manually. 

• If you manually enter a decimal number in a calculation, use the decimal selection from 
the Windows Control Panel. 
Use the Decimal symbol selection from the Number tab of the Regional Settings control 
panel. 

• Quotes ( “ ” ) must enclose a text string. 
If([Name1]=”Ann”,”Dear Ann:”,”Dear Customer:”) 

• flashFORM automatically removes extra spaces (except a space in a field name) when it 
accepts a calculation. 
You can insert spaces between operators and after commas when creating a calculation if 
this helps you to see it more clearly. 

• Calculations are performed in tabbing order. 

• If a calculation contains another field that has a calculation, the other field’s calculation is 
performed first. 
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Usage Conventions 

Substitute the appropriate field name where you see num and str in the function 
examples. Parentheses are required where indicated. Below is a list of 
conventions showing operator and function usage. 

 

Operator Function 

date date value: the expression must evaluate to a valid date  

time time value: the expression must evaluate to a valid time  

num number or numeric expression; num1, num2, and so forth 
indicate additional number values  

str text string: str1, str2, and so forth indicate additional string 
values  

... additional repeating values of the given type may be entered  

[ ] brackets inserted around field names  

log exp logical expression  

true exp true expression  

false exp false expression  
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Operators 

Operators represent mathematical, comparison, logical, and text operations to be 
performed within a calculation. You must have an operator between fields in a 
calculation. 

For example, a calculation for a Total field might look like this: 

[Price1] + [Price2] + [Price3] 

The plus signs between the field names are the Addition operators in the 
calculation. 

The calculation could also look like this: 

Sum([Price1],[Price2],[Price3]) 

The parentheses are the operators in the calculation. Commas, although not 
operators, also separate the fields.  

 
You must insert the proper parentheses, brackets, and commas when you create a 
function manually or flashFORM will not accept the calculation. See “ Calculation 
Guidelines”  for detailed information. 

flashFORM automatically inserts commas, parentheses, and brackets when you 
create a calculation with the Calculation Builder or the Auto button, and when you 
click the Accept Calculation button.  
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Operator Buttons 

See “ Calculation Overview” for instructions on creating calculations. 

 

                       

 

1=Addition 
2=Subtraction 
3=Multiplication 
4=Division 
5=Power of  
6=Concatenate 
7=Equal 
8=Not equal 
9=Less than 
10=Greater than 
11=Less than or equal to 
12=Greater than or equal to 
13=Logical and 
14=Logical or 
15=Logical not 
16=Left parentheses 
17=Right parentheses 

 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17
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Operators — Quick Reference 

See “ Usage Conventions” for information on how to interpret the examples in the 
following table. 

 

Operator Type Description Usage Example 
+ 

Mathematica
l 

Addition: add numbers or 
fields 

[num1] + [num2] 

- 
Mathematica
l 

Subtraction: subtract 
numbers or fields 

[num1] - [num2] 

* 
mathematica
l 

Multiplication: multiply 
numbers or fields 

[num1] * [num2] 

/ 
mathematica
l 

Division: divide numbers or 
fields 

[num1] / [num2] 

^ 
mathematica
l 

Power of: raise a number or 
field by a power 

[num1]^2 

& 
text Concatenate: put together 

strings 
“str1”&”str2” 

= 
comparison Equal: compare values or 

results 
If ([num1]=[num2], true exp, 
false exp) 

<> 
comparison Not Equal: compare values 

or results 
If ([num1]<>[num2], true 
exp, false exp) 

< 
comparison Less Than: compare values 

or results 
If ([num1]<[num2], true exp, 
false exp) 

> 
comparison Greater Than: compare 

values or results 
If ([num1]>[num2], true exp, 
false exp) 

<= 
comparison Less Than or Equal to: 

compare values or results 
If ([num1]<=[num2], true 
exp, false exp) 

>= 
comparison Greater Than or Equal to: 

compare values or results 
If ([num1]>=[num2], true 
exp, false exp) 

And 

logical Logical And: use with 
Logical If to put together 
more than one condition. 
All conditions must be true 
for the Logical If function to 
be true. 

If ([num1]=[num2] And 
[num3]=[num4], true exp, 
false exp) 

Or 

logical Logical Or: use with Logical 
If to include more than one 
condition. Only one 
condition must be true for 
the Logical If function to be 
true. 

If ([num1]=[num2] Or 
[num3]=[num4], true exp, 
false exp) 

Not 
logical Logical Not: used with the 

Logical If function to negate 
a condition. 

If ([num1]=[num] And NOT 
[num3]=[num4], true exp, 
false exp 

() 
mathematica
l 

Left and Right Parentheses: 
show precedence. A 
matching set of 
parentheses must exist. 

([num1]+[num2]) * 3 
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parentheses must exist. 

“ ” 

text Constant Quotes: mark the 
beginning and end of a 
character used as a 
constant or characters 
used as a text string. A 
matching set of quotes 
must exist. 

“John Doe” 
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Functions 

Functions are single words used by flashFORM to represent operations within a 
calculation. Functions can use field values, information you enter, and information 
from outside sources such as the computer date. 

Please refer to the online help for a definition of each function and instructions on 
how to use a function in a calculation.  

See “Creating a Calculation”  for instructions on creating calculations. See “Usage 
Conventions”  for a list of the conventions used in this chapter. 

The format of the values returned in the examples is dependent on: 

• The Language selection in the International tab of the Options dialog box 

• The Format selection in the Properties tab of the Object Definition dialog box for the 
selected object 

Functions — Quick Reference 

See “Usage Conventions” for information on how to interpret the examples in the 
following table. Or, refer to online help for an example of each function. The 
following table lists a brief description and usage of each function. 

 

Function Type Description Usage Example 
Abs mathematical Absolute Value: returns the value of num Abs(num) 
Avg statistical Average: returns the average for num1, num2, and so 

forth 
Avg(num1, num2, ...) 

Date date Date: returns the current date as MM/DD/YY based on 
the current system date 

Date() 

DayName date DayName: returns the name of the day of the week for 
a given date 

DayName(date) 

DayOfMonth date DayOfMonth: returns the number for the day of the 
month for a given date 

DayOfMonth(date) 

DayOfWeek date 
DayOfWeek: returns the number for the day of the 
week for a given date. Sunday returns 1, Monday 
returns 2, and so forth 

DayOfWeek(date) 

DayOfYear date DayOfYear: returns the number for the day of the year 
for a given date 

DayOfYear(date) 

Exp mathematical 
Exponentiation: returns the value of the constant e, the 
base of natural logarithms (approximately 2.71828) to 
the power of num; inverse of ln function. 

Exp(num) 

FV financial 
Future Value: returns the future value of an investment 
given a payment num, interest rate num, and num of 
periods 

FV(payment num, rate num, 
num of periods) 

Hour time Hour: returns the hour for a given time Hour(time) 
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I f logical If: if the log exp is true, the true exp is executed; 
otherwise, the false exp is executed 

If(log exp, true exp, false exp) 
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Function Type Description Usage Example 

Int mathematical Integer: returns the integer portion or whole number of 
num 

Int(num) 

Left text Left: returns the characters for str beginning from the 
left and proceeding to the right for num characters 

Left(str, num) 

Length text Length: returns the number of characters in str Length(str) 

ln mathematical 
Natural Logarithm: returns the natural logarithm (base 
e - approximately 2.71828) of num; inverse of Exp 
function of num 

ln(num) 

Log mathematical Base 10 Logarithm: returns the base 10 logarithm of 
num 

Log(num) 

Lower text Lower: converts the str to lowercase Lower(str) 
Max statistical Maximum: returns the maximum (highest) value for 

num1, num2, and so forth 
Max(num1, num2, ...) 

Middle text Middle: returns the characters for str beginning at start 
position num for num of characters 

Middle(str, start position num, 
num of characters) 

Min statistical Minimum: returns the minimum (lowest) value for 
num1, num2, and so forth 

Min(num1, num2, ...) 

Minute time Minute: returns the minute for a given time Minute(time) 
Mod mathematical Modulus: returns the remainder of the dividend num 

divided by the divisor num 
Mod(dividend num, divisor 
num) 

Month date Month: returns the number of the month for a given 
date 

Month(date) 

MonthName date MonthName: returns the number of the month for a 
given date 

MonthName(date) 

Pi mathematical Pi: returns the value of Pi (approximately 3.14159265) Pi() 
PMT financial Payment: returns the payment required given a 

principal num, interest rate num, and num of periods 
PMT(principal num, interest 
rate num, num of periods) 

Position text Position: returns the position in the source str of the 
find str beginning at start position num 

Position(source str, find str, 
start position num) 

Proper text Proper Case: converts the first letter of each word in 
str to uppercase and the rest of the word to lowercase. 

Proper(str) 

PV financial 
Present Value: returns the present value of an 
investment given a payment num, interest rate num, 
and num of periods 

PV(payment num, interest 
rate num, num of periods) 

Record Count database Record Count: returns the number of records in the 
current database. 

RecordCount() 

Replace text 
Replace: replaces the source str beginning at start 
position num for num of characters with the 
replacement str 

Replace(source str, start 
position num, num of 
characters, replacement str) 

Replicate text Replicate: repeats a str for num times Replicate(str, num) 
Right text Right: returns characters for str beginning from the 

right and proceeding to the left for num characters 
Right(str, num characters) 

Round mathematical Round: returns the value of num rounded to the 
specified num of decimal places 

Round(num, num of decimal 
places) 

Second time Second: returns the second for a given time Second(time) 
Sign mathematical Sign: returns the sign of num. A positive num returns 1, 

zero returns 0, and a negative num returns -1. 
Sign(num) 

Sqrt  mathematical Square Root: returns the square root of a positive Sqrt(num) 
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number 
Sum statistical Sum: returns the total of num1, num2, and so forth Sum(num1, num2, ...) 
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Function Type Description Usage Example 

Time time Time: returns the current time as HH:MM:SS based on 
the current system clock 

Time() 

Trim text Trim: removes leading, trailing spaces, and all other 
extra spaces from str. 

Trim(str) 

Trunc mathematical Truncate: returns the value of num truncated down to 
the specified num of decimal place 

Trunc(num, num of decimal 
places) 

Upper text Upper: converts str to uppercase Upper(str) 
Year date Year: returns the year number for a given date Year(date) 

 

Functions Sorted by Type 

The following table lists each function by type. (The Calculation Builder dialog box 
contains folders for each type of function listed.)  

 
Database Date/Time Financial Logical  Math Text 
Record Count Date FV If Abs Left 
 DayName PMT  Avg Length 
 DayOfMonth PV  Exp Lower 
 DayOfWeek   Int Middle 
 DayOfYear   ln Position 
 Hour   Log Proper 
 Minute   Max Replace 
 Month   Min Replicate 
 MonthName   Mod Right 
 Second   Pi Trim 
 Time   Round Upper 
 Year   Sign  
    Sqrt  
    Sum  
    Trunc  
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Technical Information 
 

This chapter explains how to troubleshoot common problems you may encounter. 
It also provides technical information on such topics as how to improve Optical 
Character Recognition (OCR) and scanning performance. 

This chapter contains the following sections: 

• General Troubleshooting Solutions 

• flashFORM Setup Issues 

• Uninstalling flashFORM 

• Scanning and Recognition 

• Operation 

• Improving Performance 

• flashFORM Compatibility 
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General Troubleshooting Solutions 

If you have a problem with flashFORM, first check that your computer, scanner, 
and other applications are functioning properly. 

 
Make backups of flashFORM files regularly, preferably in a location other than your 
hard drive. This could save you hours or days of work if the unexpected happens: 
file deletion or corruption caused by disk crashes, viruses, or user error. 

Solutions to Try First 

Try these possible solutions if you experience problems using flashFORM. 

• Make sure that your system meets all requirements as listed in 
“ System Requirements”. 

• Restart your computer and make sure other applications are 
functioning properly. 

• Make sure that your scanner is plugged in and turned on, and 
that all cable connections are secure. 

• Turn off your computer, restart your scanner, and then restart 
your computer. 

• Use the software that came with your scanner to verify that it 
works properly in Windows before using it with flashFORM. 

• Fix Windows problems before using flashFORM again. 

• Run virus-checking software regularly. 

• Defragment your hard disk occasionally. See your Windows 
online help for more information. 

• Run ScanDisk for Windows 95 or 98 or Check Disk for 
Windows NT to check your hard disk for errors. See Windows 
online help for more information. 

• Uninstall and reinstall flashFORM. 
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flashFORM Setup Issues 

This section contains information on some common installation problems and 
information on how to optimize the installation process. 

Memory and Installation 

Close all applications — including screen savers, virus checkers, and mail 
applications — to free up memory before starting the flashFORM setup program. 

Installing flashFORM 4.0 over Older Versions 

Select your current flashFORM folder during installation to install flashFORM 4.0 
over a 3.0, 2.0 or 1.x version. flashFORM prompts you to confirm that you want to 
overwrite the previous version. 

You will no longer be able to run an older version of flashFORM in this case. 

Uninstalling flashFORM 
Follow these steps to remove flashFORM from your system. 

 
The steps listed here remove all flashFORM files from your computer. Back up 
files and records outside your flashFORM folder if you want to save them. 

To uninstall flashFORM: 

1. Exit from flashFORM. 

2. Click Start in the Taskbar and choose Settings�Control Panel. 
The Add/Remove Programs Properties dialog box appears. 

3. Select flashFORM 4.0. in the Install/Uninstall tab. 

4. Double-click Add/Remove.... 

5. Click Yes in the confirmation dialog box. 

Windows removes flashFORM from your system. 
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Scanning and Recognition 

This section describes common scanning and recognition problems and possible 
solutions: 

• System Hang During Scan  

• System Hang During Auto Form Design  

• Scanner Compatibility 

System Hang During Scan 

A system hang during a scan could have several possible causes: 

• An interrupt conflict between your scanner and another device 
such as a bus mouse or network card. 
Check interrupt addresses for a possible conflict. See your 
device documentation. 

• A SCSI termination problem. 
Make sure the scanner is terminated properly. See your 
scanner documentation. 

• A memory-related problem. 
Try closing open windows and applications to free up memory. 

System Hang During Auto Form Design 

Many computer systems provide a feature called shadow RAM to enhance system 
performance. If flashFORM causes the system to hang, turn off the shadow RAM 
function of your computer and try again. See your computer’s operations manual 
for information on disabling shadow RAM. Some computer systems do not allow 
you to turn off shadow RAM. Incompatibilities with these systems are usually not 
related to shadow RAM. 

System hangs may be related to incompatibilities with memory-resident 
applications or device drivers. Use a text editor to comment out any memory- 
resident device drivers and applications from your autoexec.bat and 
config.sys file not used by Windows, DOS, flashFORM, your scanner, or your 
hard drive, and then restart your system. 

 
Do not remove a device driver unless you are aware of its function and know that it 
may be removed safely. 
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Hard disks often require special device drivers that should not be removed. Video 
displays that require special device drivers may need to be reconfigured instead of 
removed. 

Make a backup disk with your current operating system version, autoexec.bat, 
and config.sys to guard against potential mistakes. Consult your device 
documentation for more information. 

Scanner Compatibility 

If you experience a problem between flashFORM and your scanner, make sure 
your scanner is one that flashFORM supports. 

Please refer to Scanner Setup Notes for a list of compatible scanners and more 
detailed information about how to solve scanning problems.To open this PDF file, 
click Start in the Windows taskbar and choose Programs4FORMation4FORMation 
Documents4Scanner Setup Notes after flashFORM has been installed 

 

 
Select setup options for TWAIN-compliant scanners in the TWAIN dialog box that 
appears before scanning. Select 200, 300, or 400 dots per inch (dpi) for the 
resolution. Select line art, bi-tone, or black-and-white line drawing for the image 
type. flashFORM cannot process grayscale scans. 
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Operation 

This section provides troubleshooting techniques for potential operational 
problems as well as additional technical information: 

• flashFORM Limits 

• Low Memory 

• Low Disk Space 

• Right Mouse Button Functions 

• Object Linking and Embedding (OLE) Automation Support 

flashFORM Limits 

The following limits apply in flashFORM: 

• Pages in a form: 100 

• Open forms: 20 (depends on your system) 

• Records in a database: 10,000 or approximately 5.4 MB of data 
across all records 

• Length of Help message in an Object Definition dialog box: 100 
characters 

• Number of choices in the List of Choices list box in an Object 
Definition dialog box: 500 choices, each up to 100 characters 
long 

Low Memory 

Low memory can cause a number of problems, from persistent low-memory error 
messages to system hangs. You need a minimum of 16MB RAM for Windows 95 
or 98 and Windows NT. 

More memory is recommended if you run multiple applications. 

Close Open Applications and Windows 

You may receive out-of-memory error messages or find that flashFORM works 
slowly and accesses the hard drive frequently. Try closing open flashFORM 
windows and other applications to free up memory. 

Amount of Memory Available 
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You can find out how much memory you have and how much is currently available.  

To check available memory in Windows 95 or 98: 

1. Click the Start button in the Taskbar and choose Settings, Control Panel. 

2. Double-click System in the Control Panel. 
The System Properties dialog box appears. 

3. Click the Performance tab.  

 

4. All memory information appears in this tab. See your Windows documentation 
or the Windows online help for more information. 

 
You can click Virtual Memory... if you want to change virtual memory settings but it 
is recommended that users let Windows manage the virtual memory settings. 

5. Click OK to close the System Properties dialog box and return to the Control 
Panel. 

Virtual Memory 

flashFORM uses virtual memory when memory runs low. Windows uses disk 
space to simulate the RAM it does not have available. Your system runs more 
slowly when it has to use virtual memory. 
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Try closing any other open applications and restarting your computer or Windows 
to free up memory so flashFORM does not use virtual memory. If you often work 
with long, complex forms or need to have many forms open at a time, add more 
RAM to your system. 
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Low Disk Space 

Check your Temp folder for unnecessary files if you seem to be running out of disk 
space too quickly. Files are stored here especially after a system hang or crash. 
Usually the path to this folder is: 

c:\Win95\Temp (Windows 95) 

Right Mouse Button Functions 

Some programs allow you to reconfigure your right mouse button for various 
functions. This may prevent you from using certain flashFORM functions, such as 
the right-mouse-button click to open a shortcut menu. Use your other software to 
return the right mouse button to its default state if you wish to use these right-
mouse-button flashFORM functions.  

Object Linking and Embedding (OLE) Automation Support 

OLE Automation support is built into flashFORM. This allows you to write programs 
to control flashFORM from another application such as Microsoft Visual Basic, or 
from an application that supports Visual Basic for Applications (VBA) and other 
forms of OLE Automation control. You might, for example, write a program that 
allows you to send information from your open application directly into a 
flashFORM form and then print that form. 

A flashFORM OLE Automation Programmer’s manual and sample scripts are 
available. Please call 1-800-223-7346 for order information. 

Improving Performance 

If you scan typeset, high-quality printed pages, text recognition accuracy should be 
very high. 

With lesser-quality pages, however, text recognition may not be as accurate. This 
section discusses a number of factors that affect scanning and recognition 
performance: 

• Document Quality 

• Scanning Angle 

• Scanner Glass Clarity 

• Paper Transparency 

Document Quality 
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flashFORM recognizes characters in almost any font from 6 to 72 points in size. 
However, keep the following in mind when using flashFORM: 

• The print should be reasonably clean and crisp. Characters 
must be distinct: separated from each other and not blurry or 
overlapping. 

• The document should be free of notes, lines, or doodles. 
Anything that is not a printed character slows recognition, and 
any character distorted by a mark will be unrecognizable. 

• The document font should be nonstylized; for example, 
flashFORM may not recognize the Zapf Chancery font 
accurately. 

• Forms with underlined text should have the lines placed below 
the text and not touching it for best results. It is difficult to 
recognize underlined text because the underline overprints the 
descenders on the letters g, j, p, q, and y, changing their 
shape. 

Scanning Angle 

Make sure that each document is positioned correctly in your scanner and is not 
crooked. Even if you use the Auto Form Straightening option, it is possible for the 
page to be too skewed for flashFORM to design it properly. Adjust the page and 
rescan it if you see numerous recognition errors due to skewing.  

Scanner Glass Clarity 

The sheet of glass on the flatbed of the scanner must be clear. If it gets dirty, wipe 
it gently with a soft, damp, lint-free cloth or tissue. Be sure that it is completely dry 
before you put pages on it. 

See your scanner documentation for more information on proper scanner 
maintenance. 

Paper Transparency 

Some paper is thin enough that the scanner sees text printed on the opposite side 
of a two-sided page. To correct this problem, put a black piece of paper behind the 
page between the page and the lid of the scanner. 

flashFORM Compatibility 

This section provides flashFORM compatibility lists. 
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Database Information Exchange 

flashFORM uses industry-standard ODBC to exchange information with the 
following databases:  

• Microsoft Access (2.x or higher) 

• dBASE (III or higher) 

• Excel (3.0 or higher) 

• FoxPro (2.0 or higher)  

• Paradox (3.x or higher) 

• text-based and CSV files 

E-mail Programs 

• Microsoft Exchange/Outlook 

• Lotus cc:Mail/Notes (32-bit versions only) 

Graphic Formats 

flashFORM can import the following file types into a graphic object or a fill graphic 
field: 

• BMP 

• GIF 

• JPEG 

• PCX 

• TIFF 

• Macintosh PICT 
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Image File Formats 

flashFORM can import and recognize black-and-white forms in either PCX or TIFF 
format. Image resolution must be 200, 300, or 400 dots per inch (dpi) for black-
and-white forms, and 300 dpi for color forms. 

Scanners 

The Scanner Setup Notes contains information about supported scanners and 
related issues. To open this PDF file, click Start in the Windows  
taskbar and choose Programs4FORMation4FORMation Documents4Scanner 
Setup Notes after flashFORM has been installed. 
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Index 
 

A 
Align, 66, 103, 108 

commands 
Align 

align to bounding box, 108 
AS/400, v, 1, 2, 3, 11, 16, 27, 36, 38, 39, 40, 66, 68, 69 
AS/400 Electronic Form Integration, 1, 11 
AutoFill list 

create a list  from an ODBC source, 127 
create a list from an flashFORM form or database, 125 
creating a new list, 120 
create a list and automatically fill fields 

create an AutoFill list and automatically fill fields, 
135 

for tables, 142 
use a previously saved list, 123 
use an AutoFill list from another field, 124 
use from another source, 123 

AutoFill Wizard;, 120 

C 
Calculation 

Auto calculations, 207, 208 
toolbar 

toolbar 
calculation toolbar, 204 

calculation overview, 204 
creating, 204, 208 
functions, sorted by type 

sorted by type, 220 
guidelines for creating 

calculation, 209 
operator buttons 

buttons, 213 
operators, quick reference chart 

quick reference chart, 214 
recalculating records;Recalculate command 

Recalculate, 209 
see also Functions, 216 
usage conventions chart, 211 

Calculation Builder dialog box 
Calculation Builder dialog box, 205, 207 

Check Box Definition dialog box, 87 
Check box object 

creating, 75 
defining 

check box 

check box, 87, 88 
Check Printing, 1 
Circle text object 

creating, 76 
defining 

circle text  
circle text, 88 

Color 
adding to a form, 99 
changing existing colors on a form, 101 
selecting background color of object, 93 

Color drop-down palette, 99 
comb, 65, 75, 76, 78, 83, 84, 85, 86, 91, 102, 171, 204, 207 
Comb object 

creating, 75 
defining 

comb 
comb, 83, 85 

commands, 3, 5, 14, 47, 65, 66, 98, 101, 103, 104, 108, 
109, 159, 163, 169, 178, 188, 199, 200 

Conventions in this manual, 3 
Copyrights, iii 
Currency 

euro currency symbol, 23 
Current Form option, 21 
Cursor 

as Graphic tool, 72 
as resize cursor, 72 
use to select objects, 102 

Customizing toolbars 
using the Commands tab, 64 

D 
Database 

databases supported, 231 
defined, 174 
found set, 183 
recalculating records, 185, 186 
deleting record(s) 

deleting;Delete Record command 
Delete Record, 186 

moving through 
buttons in toolbar, 178, 179 

records management 
management of, 174 

refreshing records 
Refresh All Records 

refreshing, 187 
saving records, 188 



Forms Design User’s Guide 
Index 

236   Index 

found set 
found set, 179 

sorting records 
database records, 184, 185 

Dates 
affected by language selection 

affected by language selection 
affected by language selection 

affected by language selection, 21, 23 
Comb element, defining 

comb element 
comb element, 85 

Delete a found set of records , 187 
Design toolbar 

described 
commands 

design toolbar, 65 
Design view 

button, 61 
changing object appearance , 92 
creating objects, 66, 77 
defining objects, 77, 91 
editing a form, 102, 117 
inserting OLE objects, 157, 163 
overview, 60, 168 
toolbars, 61 

Break Table Apart command 
breaking a table apart, 108 

E 
Convert command 

Convert, 117 
Edit menu commands 

Object, 163, 166 
Insert New Object command 

Insert New Object 
Change Icon option, 158 

Paste Link command 
Paste Link 

paste links, 161 
E-mail 

add routing slip, 47 
mailing forms, 44, 47 
programs supported, 232 

Export 
benefits of exporting information 

preparing for, 188 
exporting database information, 188, 192 
Record Range dialog box, 45, 191 

ODBC database options 
ODBC database options 

Export As dialog box, 190 
Export dialog box, 190 

F 
field mapping, 1, 16, 40 
Field validation 

filling a validated field, 178 
Fields 

defined by a calculation 
filling a field defined by a calculation, 178 

check box 
filling in fill view, 171 

circle text  
filling in fill view, 172 

comb 
filling in fill view, 171 

fill graphic 
filling in fill view, 174 

fill text  
filling in fill view, 171 

changing tab order 
changing tab order 

changing tab order, 109 
spell checking 

checking in fill view;Spelling command 
Spelling, 179, 182 

tab order, 110 
table 

filling in fill view, 172 
Add Routing Slip command 

Add Routing Slip, 47 
File menu commands 

Export;Export command, 189 
Send;Send command 

forms, 44, 46 
New, 42 

Form Assistant command 
Form Assistant, 14 

Import command 
Import, 194 

Fill graphic object 
creating, 77 
defining 

fill graphic 
fill graphic, 90 

import options 
import options, 174, 177 

importing from TWAIN source 
importing from a TWAIN source 

scanning in a graphic with, 176 
importing existing graphic, 174, 176 

Fill lines, 96 
Fill Text Definition dialog box, 78 
Fill text object 

creating, 74 
defining 

fill text  
fill text, 78, 83 

fill lines, 96 
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Fill view 
filling fields 

filling, 169, 178 
moving through fields 

moving through, 169 
button 

filling fields 
overview, 168 

overview 
button;, 168 

saving changes 
in fill view, 182 

flashFORM Filler, 201 
flashFORM 

design view, 168 
flashFORM Data file 

exporting information to, 189, 192 
icon, 195 
importing to database, 194, 197 

flashFORM Design 
arrange toolbar, 66 
calculation toolbar, 204 
fill view, 168 
fill toolbar 

fill toolbar; Fill toolbar 
fill toolbar, 168 

starting the program;Taskbar, starting flashFORM 
appears on launch, 12 

system requirements 
system requirements, 10 

shortcut menu, 61 
drawing toolbar 

drawing toolbar, 66 
font/text toolbar 

font/text toolbar, 65 
limits 

flashFORM limits, 227 
Internet Filler, 56 
flashFORM tutorials, 5 
flashFORM400, i, v 
Font dialog box, 104 
Font Mapping dialog box, 31 
Font types and OCR, 231 
Form Assistant 

opening 
button, 14 

functions overview, 16 
appears on launch, 12 

Form Assistant dialog box 
dialog box, 14 

Form design 
using OLE 

using OLE, 157, 163 
Form image 

select source 
graphic from form image source, 71 

Form Macro, 40 
Form usage 

Auto Form Design option, 30 
designed form 

example 
designed form 

not retained in designed form, 17 
selecting an option 

form usage options 
form usage options 

Auto Form Design option, 17 
Use Designed Form option 

Use Original Form option, 19 
changing;Form Usage dialog box 

Form Usage;Original form usage option, 19 
Form usage option, 17 
Bring to Front command;Send to Back command 

Bring to Front 
Send to Back, 109 

Font command 
Font, 104 

Format menu commands 
Object Definition, 78 

Object Appearance command 
Object Appearance, 92 

Size and Position dialog box 
Size and Position;Size and Position command, 104, 115 

Table AutoFormat command 
Table AutoFormat 

auto formatting, 107 
Formatting text, 104, 106 
Automated data entry 

setting up a form for automated data entry, 120 
Faxing a form to flashFORM 

importing color forms, 32 
Forms 

automatically fill fields on a form 
automatically fill fields, 128 

automatically fill fields on a form with an ODBC source 
automatically fill fields with an ODBC source, 133 

automatically fill fields on a form with an flashFORM 
form or database 
automatically fill fields on a form with an 

flashFORM form or database, 131 
replacing data entered in a field with new data 

replacing data entered in a field with new data, 140 
filling, 36 
shared 

use to open shared form, 192, 193 
form  protection, 199 
scanning angle 

document quality, 231 
mailing 

select mail system, 44 
paper transparency, 231 
printing 
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forms, 36 
data protection 

Protect Data option;Data protection;Protection 
command;Protection dialog box 
Protection, 198 

proofing; Proofreader option 
proofing after, 34 

saving 
a form, 47 

searching for information, 42 
searching for information, 41 
adding security to 

adding to forms, 146 
see also Design view, 59, 119 
setting summary information, 144 

Hyperlinks 
adding hyperlinks to, 152 

International options 
selecting a language for 

selecting for a form 
see Language, 20 

selecting for a form, 24 
Open dialog box 

opening forms 
Open, 43 

Publishing a form 
publishing to Web 

publish a form to 
publish a form to, 52 

Shared forms 
sharing, 143 

Submission information 
setting submission information, 145 

Forms cartridge, vii 
Functions 

all, 216 
all, 216 
quick reference chart 

functions quick reference chart, 216 
defined, 216 
see also flashFORM’ s online help, 216 

G 
Generating an AS/400 field mapping file, 2, 27, 40 
Generating an AS/400 form overlay (“macro”), 27, 38 
Graphic Definition dialog box 

Graphic File source, 73 
selecting sources, 72, 73 

Graphic object 
creating, 74 
defining 

graphic 
graphic, 74 

creating 
importing into a graphic object, 71 

Graphic File source option 

graphic file source  
graphic from graphic file source , 73 

Graphics 
filling a fill graphic field, 174, 177 
form image source 

copy from original to designed form, 71 
options for import 

definition options for  import 
options, 74 

definition options for import 
options 

defining 
graphic 

graphic, 73 
importing into a graphic object, 74 

H 
Help 

online, 3 
Home Page , v 
Preview in Browser command 

preview in browser, 48 

I 
File formats, supported 

supported formats, 233 
Importing 

an image file 
importing image files 

Scan Form 
importing, 33, 34 

graphics, 174 
see also Importing data, 34 

Import dialog box;Select Import Files dialog box 
linking field names, 195 

Importing data 
data sources, 194 
field data, 194 
Auto linking 

Auto linking, 196 
see also Importing, 194 

Insert Object dialog box 
Create From File option, 160 
Create New option, 159 

Installation 
installing 4.0 over a 3.0, 2.0 or 1.x version 

installing 4.0 over a 3.0, 2.0 or 1.x version;, 223 
on Windows 95, 98 and Windows NT 4.0 systems, 10 

Uninstalling flashFORM 
uninstalling flashFORM 

uninstalling flashFORM, 223 
International options 

dictionaries, 181 
check/change for spell checking 

check/change for spell checking, 180 
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L 
Line object, creating, 70 
Low memory 

general troubleshooting 
low memory, fixing, 227, 229 

M 
MACRO (PCL MACRO format), 40 
Mail 

add routing slip;Routing slip, 47 
Memory 

and installation 
memory and installation, 223 

RAM, amount available 
amount available in Windows 95, 227 

Virtual memory 
virtual, 228 

MICR Laser Check Printing, 1 

N 
New Forms option, 20, 21 

O 
Object appearance 

fill lines 
changing fill lines appearance, 96 

border 
changing border appearance, 94 

Object definition 
how language selection affects options, 24 

Object linking and embedding 
see OLE, 162 

Objects 
creating, 67, 77 
creation guidelines, 67 
defining, 78, 91 
moving 

moving objects 
moving objects, 103 

redesigning a table 
table redesign 

table redesign, 107, 108 
filling objects in fill view, 170, 179 
aligning 

aligning objects 
aligning objects, 108 

converting to another type 
converting objects 

converting objects, 115 
deleting 

deleting objects 

deleting objects, 104 
resizing 

resizing objects 
resizing objects, 103 

selecting 
selecting objects 

selecting objects, 102 
creation guidelines 

creating objects, 67 
changing appearance 

changing, 92 
changing background appearance 

background, 92 
overlapping 

sending to front or back 
overlapping objects 

overlapping objects, 109 
Shift key, using 

use to create objects, 67 
OLE 

converting an OLE object, 165 
creating new objects, 159 
creating objects from a file, 160 
linking 

Links;Links dialog box;Links (OLE), 162 
edit OLE object, 164 
object linking, defined 

object embedding, defined, 157 
opening an OLE object 

editing an OLE object 
converting an OLE object, 163 

playing an OLE object, 165 
static object, 163 
window, 159 

Operators 
overview 

operators, described, 212 
Options dialog box 

check/change for spell checking 
check/change for spell checking, 179 

selecting a language 
Options, 20 

shared form location 
type ahead; Type Ahead 

Options;, 170 
Shrink text to fit fields 

shrink text to fit within fields, 171 
Oval object, creating, 71 

P 
Page Setup dialog box, 99 
PageKeeper 

adding a form to 
adding to PageKeeper, 48 

Password 
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for data protection, 198 
for form protection, 200 

Prefill element 
and Interpret As option, 83 
creating, 86 

Print dialog box, 37, 38 
Macro printing 

a form as a macro, 40 
Page Setup dialog box 

setting paper size, margins, orientation and color, 37 
Printing 

to OmniForm from any application 
an existing electronic form, 40 

Proofreader option index panel 
window 

instruction panel, 35 
Protection 

flashFORM Filler, 201 
Protect Form option, 199 

R 
Recalculate dialog box, 185 
Recognition 

factors affecting accuracy 
factors affecting recognition accuracy, 231 

font style 
font types and recognition, 231 

Record Range dialog box, 197 
Records 

create new, 175, 177 
searching 

searching records 
procedure, 179, 183 

duplicating, 177, 178 
Delete All Records command 

Delete All Records , 187 
Duplicate Record command 

Duplicate Record, 178 
Go To command 

Go To, 178 
Records menu commands 

Recalculate, 185 
Refresh Record, 188 
Search;Search dialog box, 41 

Search command 
Search, 179 

Sort command 
Sort, 184 

Rectangle object, creating, 71 
Right mouse button 

unable to use with flashFORM 
right mouse button, unable to use, 230 

use to open shortcut menu, 78, 150 
Rotate 

line object, 70 

S 
Save 

in design view, 60 
as a mailable filler, 52 
a record(s) 

saving, 188 
HTML Converter options 

HTML, 49 
PDF Converter options 

PDF, 51 
Save As 

Microsoft Word (RTF) format 
PDF 

HTML 
OFML 2.0 

OFML 1.0 
flashFORM Form, 47 

Word Converter options 
Microsoft Word (RTF) format, 49 

Scan Form dialog box 
language selection in, 23 
settings 

options in Scan Form dialog box, 28 
Scanner 

hardware, 225 
see also Scanning, 231 
see also the Scanner Setup Notes, 225 
glass clarity 

scanner glass clarity 
paper transparency;, 231 

Scanning 
and paper thickness, 231 
angle, 231 
books, 29 
paper forms 

scanning forms 
Scan Form, 28, 32 

paper forms with the Scan Form command;Scan 
Form command 
scanning forms with the Scan Form command, 28 

problems 
scanning problems, 224, 225 

Scrapbook 
deleting scraps, 155 
using 

using the scrapbook, 153, 157 
defined 

opening 
Scrapbook 

copying objects to, 153 
views, 156 

Search 
conditions, 180, 182 
found set, 183 
results;Clear Search button 

Clear Search button, 183 
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security, viii 
Security 

adding a user to the database, 148 
creating a user database, 146 
creating signature fields, 149 
deleting a user, 149 
passwords  

in Security option, 148 
updating a password 

updating a full name, 148 
signing signature fields, 150 
verifying signature fields, 151 

Security Check Printing, i 
Select Special command;Select Special dialog box 

with the Select Special command 
Select Special, 102 

Selecting objects 
multiple 

single, 102 
Serial Number Settings dialog box, 91 
Recognition options, 30 
Serial numbers, 91 
Shadow RAM, 224 
Software Registration, v 
Spelling 

check form language first 
Options, 179 

Spelling dialog box, 181 
Spool Data Mapping, 1 

T 
Table cell 

defining 
table cell 

table cell, 90 
placing objects in 

placing in table cells 
placing objects in table cells 

placing objects in table cells, 114 
Table Definition dialog box, 89 
Table object 

creating, 76, 77 
defining 

table 
table, 89 

Technical information 
see Troubleshooting, 221 

Text  
merging; Merging text  

merging text, 106 
command 

Text, 105 
formatting 

formatting text  
formatting text  

formatting text, 104 
Text dialog box 

dialog box, 105 
Text object, creating, 70 
Arrange toolbar 

arrange toolbar 
toolbars, 66 

Drawing toolbar 
drawing toolbar, 66 

Font/text toolbar 
font/text toolbar, 65 

Toolbars 
customizing, 62 
proofing toolbar, 36 
web toolbar, 56 

Tab Order command 
Tab Order, 110 

Tools menu commands 
Calculation 

command, 204 
Options 

selecting a mail system, 44 
Disk space, low 

low disk space, 230 
Improving performance 

improving performance, 230 
Temp directory 

temp directory, 230 
Troubleshooting 

back up files, 222 
installation and setup 

technical information/troubleshooting 
technical information/troubleshooting, 223 

memory, amount available, 228 
memory, amount available, 227 
operation, 227, 230 
recognizing underlined text  

underlined text, 231 
system hang 

system hang during 
system hang during, 224 

solutions to try first, 222 
Unrecognizable characters 

unrecognizable characters 
unrecognizable characters, 231 

Tutorials 
see  flashFORM  tutorials, 5 

V 
vectorization, 1 
Form Image command 

Form Image 
horizontal bar 

resize form image windows, 71 
View menu commands 
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